Will Guix work straight out of the box with Framework laptop?

If some things don’t work right out of the box, could they be easily fixed? Given that a Guix installation can be scripted, would that make it viable for users ‘right out of the box + this transparent script’?

1 Like

Guix was one of the first Linux distros I tried on the Framework - it worked pretty well by my recollection. I stopped using it because Tailscale doesn’t work on it and that’s a basic requirement for me. But all of the basic tenants of Guix hold true when maintaining a Framework laptop with Guix SD installed.

Main issue is getting the proper kernel if you’re using the stock wifi since it needs iwlwifi >5.15 to be safe. SystemCrafters has a iso that you can use that uses nonguix out of the box, so you don’t have any issues trying to bootstrap from the laptop itself. I would recommend following their guide as well.

1 Like

Awesome! I was worried about this, as I’m looking to migrate from Arch to Guix (assuming I can get everything ported over as planned) once my Framwork comes in.

Thanks for the info! :smiley:

I’m actually in the process of moving back to Guix, I’ll post more about it here:


Guix did not work out of the box for me. I installed it from the install image, but when I went to boot, I got stuck at a non-interactive black screen with a blinking underscore at the top left.

Ubuntu worked fine using a similar install procedure.

I just installed it with using i3 as my wm (trying to switch to xmonad).

My problem was that I got a lot of screen tearing and had to change/add the following lines to my config.scm file:

  (extra-config '("Section \"Device\"
                           Identifier \"Intel Graphics\"
                           Driver \"intel\"
                           Option \"TearFree\" \"true\"
                           Option \"AccelMethod\" \"sna\"
   (keyboard-layout keyboard-layout))

AccelMethod is set to uxa by default which seemed to be an issue with this hardware.

Oh, by the way, you may need to use non-guix, linked by @kjhoeer above, and make sure you use the most recent installation image on his github.

However, I am having some trouble getting xmonad to compile my configuration file. Anybody have any tips for this?