11th Gen Intel Core BIOS 3.10 Release

for those that had the problem of booting into the os after running fwupd to update the bios:
if you don’t have an option in grub/systemd-boot/refind/… about fwupd you have to do it manually byrebooting it into the uefi bootloader:

  • with F3(fn+F3 with the notebook keyboard) before the framework logo shows up
  • the navigate with the keyboard to the harddisk/EFI/fwupd
  • then booting the .efi entry there
    after that the pc reboots multiple times and after this the update is done, ths can take a while.
1 Like

Failure to upgrade to BIOS 3.10! Running Fedora 36 (EDIT: resolved; see below)

  • Secure boot is off
  • uncommented “DisableCapsuleUpdateOnDisk=true” line in /etc/fwupd/uefi_capsule.conf
  • made sure to raise the 80% charge limit to 100% so the battery was actively charging when I attempted my upgrades.

Tried “fwupdmgr update”. After “Upgrade System Firmware from to” it offers also an “Upgrade UEFI dbx from 33 to 77”, but this fails:
Blocked executable in the ESP, ensure grub and shim are up to date: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.freedesktop.UDisks2.Filesystem” on object at path /org/freedesktop/UDisks2/block_devices/nvme0n1p2
restarting the system does boot differently: some tiny-print version number appears in the top-left. But after that the system reboots and I’m back to my normal grub and my BIOS is still at 3.7.

EDIT: The “UEFI dbx” problems seems to have gone away by doing a “fwupdmgr update --force”. Now running “fwupdmgr update” or fwupdmgr install --allow-older" seems to correctly schedule the System Firmware Upgrade and offer to reboot (it didn’t before; apparently due to the dbx failure). Same problem occurs then, though: system reboots, there’s a tiny version number in the upper-left of the “Framework” boot screen, system reboots almost immediately, and I’m back at grub.

Also tried EFI Shell (which successfully got me to 3.7 in January). I can successfully boot into the EFI shell from USB. It gives me the screen:

Please do not remove the AC power!
Insyde H20FFT (Flash Firmware Tool) Version 2.12
Copyright (C) 2000-2020. Insyde Software Corp. All Rights Reserved

Current BIOS Model Name: GFW30
New BIOS Model Name: GFW30
Current BIOS Version: GFW30.03.07
New BIOS Version: GFW30.03.10

    Update BIOS failed!
Shell> _

No indication about what failed, unfortunately.

EDIT: I finally did succeed via the fwupd route, but I’m not entirely sure what did the trick. Uninstalling an old kernel did not seem to do much for changing the space used on /boot/efi (/boot and /boot/efi are separate partitions), but there was a whole “Microsoft” subdirectory as well, and removing that did free up some space.

When I retried fwupdmgr after that, things did work. So perhaps filesystem space was the problem? It would mean that the firmware updater itself needs space, since I went from 70% full to 50% full on /boot/efi: by no means full! If the EFIShell updater failed for the same reason, then apparently it DOES end up using the disk as well, even though it starts from a USB drive.

My partition table looks like:

Device           Start       End   Sectors  Size Type
/dev/nvme0n1p1    2048    206847    204800  100M EFI System
/dev/nvme0n1p2  206848   2158591   1951744  953M EFI System
/dev/nvme0n1p3 2158592   4255743   2097152    1G Linux filesystem
/dev/nvme0n1p4 4255744 780214271 775958528  370G Linux filesystem

where the first partition is the one that is mounted as /boot/efi. The 100M is a bit small! I think it’s a remnant of the Windows install and that I made p2 when I partitioned the disk for linux (at that point it seemed the p1 partition was “protected”). Either it never used the p2 partition properly for EFI or the F35->F36 upgrade confused the system. It would explain why there was a Microsoft directory there in the first place … As a plus: by removing that Microsoft directory in /boot/efi I’m now finally rid of the defunct Windows boot entry.

This sounds similar to the problem I initially experienced. This is what solved it for me, maybe it’ll help you as well: 11th Gen Intel Core BIOS 3.10 Release - #39 by Jason_Hottelet

Thanks. I’ve tried scheduling the update from “Software Update” as well. That has the same result, unfortunately. Do you recall doing anything more?

Particularly the fact that the EFI-shell method doesn’t work for me either, which I assume should circumvent any installed operating systems, makes me suspect there’s some other system state in the way …

Unfortunately not, but you might want to check if your EFI partition has enough free space left (mine had, but others reported problems).

I reverted to BIOS version 3.07 and the issue seems to have gone away for anyone else having this issue. The only thing I can think that can differentiate me from others on Ubuntu 22.04 is if they didn’t use the post-install automated script for Ubuntu 20.04 and 22.04.

I’ll update this post pending further progress/discussion with Framework support.

Edit: Successfully reverted to 3.07 without any issues. I decided to EFI flash 3.10 instead of LFVS and it seems to be working now. Not sure of any root cause, just happy to have a working laptop. Hopefully it stays this way!

Running on Windows 11 I get “This platform does not support IHISI interface” - do this mean anything to anyone?

Did you use a USB or µSD card to load the file, if so try transferring the file to the Desktop and run from there.

Under what circumstances are you getting this message?

Sorry, my mistake - I had not realised this was only 11th gen, and not 12th gen as well. Might be worth adding a check on that in case I’m not the only one making this silly mistake.


Ah! You tried installing the 11 gen update on a 12 gen :slight_smile:


Thank you for the quick update. After going through this process several times now I have some suggestions. I use the EFI shell to preform my upgrades as I run an unsupported OS. This works well enough though having to remove the boot SSD seems like an unecessary step. Can we add that logic to the installer itself or just have an option in the bios to disable the m.2 slot so when someone goes in to disable secure boot it can all be taken care of in one step. Lastly can we add some type of binary verification method to these releases. Checksums or signatures that the community can use to verify the software being installed is as intended.

I updated to this BIOS version today, and my right USB ports stopped working for data transfer.

In Windows 11 I got an error that read “Power surge on the USB port – Unknown USB Device needs more power than the port can supply.”

Rolling back to 3.07 solved the issue for me.

1 Like

Did anyone else get a boost when upgrading to 3.10?

My cinebench23 went from 4800 to 5003. My CPU is the 1135g7.

I can’t find anything in the release notes that indicates a performance increase.


It can happen if you run cinebench when the cpu has a low initial temperature (meaning the heatsink is also cooler). e.g. when it’s waking up from sleep as opposed to being booted up fresh.

@CSab6482 did you have any specific expansion cards/devices connected to your right usb ports?

Yes @Kieran_Levin. I had a USB-C card in the top right and an unofficial SD card expansion card in the bottom right. Nothing was connected to these cards, but attempting to plug my phone in only charged it (no data), and my mouse dongle worked on the left side, but not the right side. I also attempted to uncheck any power limitation options for USB controllers in Device Manager, and i uninstalled the USB controller drivers and restarted, but the problem remained.

I flashed the efi shell script from 3.09 to 3.10 with no issue last Saturday. Tried to use it today and I got no activity on all ports when I plugged in AC; no power LED at all. Only way to fix was to open it up and pull the RTC out. Was this the Intel bug? I’ve always been able to plug in AC and get it to boot on prior versions. Still plenty of main bat left (61%).

Nothing to do with main battery, it’s the RTC|CMOS [ML 1220] battery that can get depleted and then the Intel bug can flip in.

Detail on the viability of the ML 1220 ~ there are 260 posts on the issue in that one topic :slight_smile:

I’ve upgraded the BIOS from version 3.2, so far so good!