11th Gen Intel Core BIOS 3.19 release

I think the problem is that the Firmware team at Framework is still small, and while they were able to get the windows update out, they’ve now had to pivot all their time to the firmware issues on the AMD systems that are about to launch. They have made it clear that the EFI update for 3.19 is still important, and they will get to it soon, but the new product that is about to release has become a higher priority than the 1st gen product that works fine on BIOS 3.17 for most people, and that CAN be updated to 3.19 with a workaround if needed.

I agree that it is bothersome to not have the easy method of doing this available, but the Framework team is doing exceptionally at supporting all of their hardware despite the generation, which I think is highly commendable.


Completely agree with you. I think they should even shutdown / pause those forum threads…before they get boiling.
What they did with 12th gen bios update.
They just have no answer, discussing “when will it arrive” just make people angry.
Let it be

I would have to disagree on that one with you. I think it’s important to keep these threads open for people to report any BIOS issues so that Framework is aware of issues.

Not necessarily, the reasons why I believe people got mad is because there isn’t any official explanation from Framework and there isn’t regular communication. A lot of the tools that Framework’s partners use are Windows based such as the HDMI and DisplayPort updater. Framework even had to ask for permission to release them to the community. So from that, porting things over the Linux can take time.

I agree with Azure’s statement that Framework is a small team and given the resources they have, it’s a careful balancing act between supporting older products and ensuring the new products have their best foot forward. I think it was ultimately a tough but correct decision for the company to prioritize the AMD launch. But this comes back to the issue of lack of communication. Framework hasn’t explicitly mentioned that is the case so all this is just speculation.

Honestly, having some kind of monthly or regular post on software updates and changes in focus would alleviate a lot of tension in the community. Looking at the 12th BIOS update thread, while some may say the 1-2 month frequency of official responses is regular, I would slightly disagree as it’s out of the blue. No one knows when they’re going to happen.

For a small team, a lot of things will move slowly and that’s just the nature of it. There’s just not enough resources to go around. But I think that’s what makes regular and predictable communication so much more important to the community and vital to maintaining community sentiment.


Not gonna lie, I haven’t fully been aware of the 12th gen BIOS discussions since I only own an 11th gen. Today I finally found and skimmed through the 12th gen 3.06 thread.

I understand everyone’s frustration and I don’t think that Framework is in the right here, but I do think the situation is complicated and that more communication may not always be possible. It’s hard when you have to manage not only your own team, but many other companies teams and their software that is being written for your device. I do not envy the Framework firmware team or the technical support team that is managing the communication, since saying too much is bad, but saying too little is also bad.

The one thing I can say is that it seems like Framework has not given up on any of these projects, and while they are struggling a little bit now, it seems like they are already reworking the process and talking to the other companies they rely on for these updates in hopes of making this process simpler and better organized in the future, and I really hope that is the case.


@Julio_Martinez i’ve been here but mostly lurk as I have other projects that I do, you can look to reddit or arstechnica for those write-ups, but I’ve been around the Linux community a long time, but am much less engaged (directly) than the mid-90s.

The EFI file is in the exe, and if you have the prior EFI direct updates - that’s where I grabbed the files from. I just stashed things on my EFI partition vs making a USB because it’s easier and once you boot into an EFI shell it’s pretty easy to do. This is how I did earlier updates as well, but I just haven’t grabbed the right intel EFI updater and put it together yet. I am not saying anyone should trust my random zip file on the internet either, hence why I gave the steps.

If someone has the right version of FwUpdLcl.efi handy for this post a link or e-mail me and I’ll update the zip. It might actually be inside the hx20.3.19.bin as well and I just didn’t poke hard enough to extract it because there are only so many hours in a day.

I get it from the manufacturer side, it’s likely that Linux is a subset of the people that would use/want to use the device, but posting the firmware and saying “figure out how to get to the EFI shell yourself” seems like a reasonable middle ground.

Ok, so I stuck everything together including the ME., the Linux updater (!) as well as the EFI updater in a single zip for everyone.


Archive:  11th_Framework_3.19.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
        0  10-08-2023 20:32   11th_Framework_3.19/
  2350112  10-08-2023 20:31   11th_Framework_3.19/FWUpdLcl.efi
   796040  10-08-2023 20:31   11th_Framework_3.19/FWUpdLcl
 10372480  10-08-2023 20:31   11th_Framework_3.19/ME.
  1574208  10-08-2023 20:32   11th_Framework_3.19/H2OFFT-Sx64.efi
 35699128  10-08-2023 20:31   11th_Framework_3.19/hx20.3.19.bin
   951744  10-08-2023 20:32   11th_Framework_3.19/bootx64.efi
---------                     -------
 51743712                     7 files

That way if your ME didn’t update, you have the ME firmware updater and can do that all at once.

Good luck all


Appreciate your efforts, however, to everyone, this is NOT tested or vetted or file hosted by Framework - this would be at your own risk and not something we have tested with.

Thank you.


Yes, as I said don’t trust random files on the internet :slight_smile: (and why I posted how I extracted them from the other files that framework does provide, of course minus the intel software that is used to update the ME)

But you can compare the firmware files extracted from prior bios versions, and such. It would be nice if Framework did post them, and for those folks like me who aren’t going to run windows, having an option is good. Matt if you want to e-mail me offline I can let you know what files from Intel as a manufacturer I think would be good to share, as they do give these out in a bundle, not sure if those just go to Insyde or to Framework as the OEM.

I’m sure there’s a better way to get into the EFI shell than my boot the h2offt-sx64.efi then boot the bootx64.efi but I’m an old person who remembers the days before there was even a turbo button on PCs :slight_smile:


From 3.17 to 3.19
Starts Ok
Will have to reset

  • Battery Charge Limit and
  • Power button back light.


As random files on the internet do make me rather uncomfortable, I thought I’d try to look over them. You would want to check these yourself to be sure of them, but here are a few sha256sums, and where they came from, showing matches for Framework-associated files for everything except the FwUpdLcl binaries:

# From  Framework 3.17 linux firmware (zip):
67738efe0459967e11fb26fca59c159a573dbb080e5c7152c66a2161da2a3c1c  H2OFFT-Sx64.efi
04c89f19efee2a22660fd4650ff9add88e962d102b1b713e535f4e32a07c5185  efi/boot/bootx64.efi

# From Framework 3.19 windows firmware (exe with 7z x)
2c20f7d2a64a87b84ec928d86b8e9235c99dcb3d3888f6a53f2227c69ed27326  isflash.bin
95c79381f56f55f66e88f004de9a11ee0f6accccf89e503316940e1f9eb22cf0  FWUpdate.bin

# From Jared_Mauch1's 11th_Framework_3.19.zip

# matches 3.17
04c89f19efee2a22660fd4650ff9add88e962d102b1b713e535f4e32a07c5185  bootx64.efi

# matches 3.17
67738efe0459967e11fb26fca59c159a573dbb080e5c7152c66a2161da2a3c1c  H2OFFT-Sx64.efi

# matches 3.19 isflash.bin
2c20f7d2a64a87b84ec928d86b8e9235c99dcb3d3888f6a53f2227c69ed27326  hx20.3.19.bin

# matches 3.19 FWUpdate.bin
95c79381f56f55f66e88f004de9a11ee0f6accccf89e503316940e1f9eb22cf0  ME.

# No clear matches
936ef32556e8e0abd1dc9e7957cdc97db14682c050a31d53516f66476e1a5aae  FWUpdLcl
fda2e3055e54c0fdaed0619079961a5cb80db24f64f6616fcba8ddc70ed28a07  FWUpdLcl.efi

I’m unable to find any source, authoritative or otherwise, for the FwUpdLcl binaries in the zip above. The Linux version is, and I have not checked the EFI version. CSME 15.0 tools are available with a reasonably simple search, but not from a reputable source, and the version I found was the more recent

Neither worked for me alongside H2OFFT-Sx64.efi, which appeared to call them with the wrong command line options, though the screen moved too quickly for me to see the specific command line, if it was shown. As a failed return code there prevented the BIOS+EC update, I used bootx64.efi renamed as a standin for FwUpdLcl.efi, which allowed the update to proceed. Using the FwUpdLcl.efi on its own, I then had no problem updating CSME.

I now have a fwupdmgr security on Fedora 39 that returns HSI:3, and nothing has exploded yet. I would reiterate that all of this is very much at our own risk.


Thanks. Yeah, this is why I listed where I got things from except for the FwUpdLcl stuff, which as you mention someone can find from CSME tools as you said with some work.

I get why it might take a few days/week to repackage things, but for a device that is marketed as repairable and capable of upgrades, the idea of releasing an EFI updater and tools from Intel shouldn’t be significantly delayed IMO.

I also understand things often take much longer than anyone wants in real life.


Hello everyone,

I’m running Windows 10 on my i5-1135G7 FW13 and upgraded from BIOS Ver. 3.10 to 3.19. Everything seems to work fine. No obvious problems.


Hi all,

I tried to go back a few months in this thread and I couldn’t find a definitive answer. I’m running Mint on my 11th Gen 13. If I throw another NVMe in here, install Windows and then run the 3.19 updater from Windows… Do I potentially break anything when I swap the drives back?

I really can’t think of any reason this wouldn’t work, and I can’t think of a reason why it would break, but I wanted to double-check with folks here to confirm. :slight_smile:


You’ll be fine :slight_smile:


Just to circle around, I ran into issues using another Windows 10 NVMe disk. It was the same error posted here: BIOS update problems [SOLVED]

I created a Windows to Go USB disk and was able to update without issues. I popped my Mint drive back in the laptop and all was good.

Thanks for the confirmation @DHowett :+1:


@Matt_Hartley any plans to post the non-win64 binaries that as others have mentioned are findable or stored in the win64 exe?

One of the reasons that this device was interesting to me was it provided an x86_64 device I could use. Having made it through the HDMI and USB power draw issues, the BIOS updates are super important.

I’m hoping now that we’re almost 2 months later, even if it’s posting a similar set of files as an official version would happen.

1 Like

Hi Jared, the moment I have word that it’s ready, it will appear here. We are a tiny team and we’re balancing a few other things at the same time. So it may be a bit, but we’re working on it. :slight_smile:


11th gen linux user with my 61 Wh battery sitting on my desk :wink: hoping we can have 1 official avenue to update our bios in the near future, since the windows release has been out for a few months now.


I got fed up waiting for the linux bios update support on 3.19 and found a way using “Windows ToGo” aka booting win10 from an USB stick.

It’s fairly easy to do from linux, but it does require a windows VM to run Rufus.
Thankfully the quickemu project offers an easy way to download the win10 iso for the USB and the VM from the linux cli.

1 Like

Thanks dfh for the pointers. If somebody has the time and ability, I would greatly appreciate a complete script for Linux update. I have some neurological damage, and can’t afford to risk an oopsie when I have to correlate several sources of information.

I have been using the old 3.06 BIOS on 11th Gen Intel for some years, and it’s not clear how bad that is, but I would definitely prefer to stay up to date.

I’m also totally unsure which of, so far I think I count 3, methods I should use, and how long to wait for the simplest to be available.