11th Gen Intel Core BIOS 3.19 release

@dfh did this update the CSME? Seeing multiple reports in this thread that going through a Windows live iso doesn’t update everything.

Thanks for hinting - I managed to overlook this.

I can confirm the WIndows USB-To-Go method did not update my CSME. BIOS reports while it should be according to [1]

[1] Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)

@Eric_Putney / @dfh - Pardon my stupidity but I want to make sure I’m on the same page. In the BIOS of my machine the Intel ME Version / SKU shows / CONSUMER.

The BIOS link posted by dfh shows Should the v2 show in the BIOS or no?

And the only reason I am going down this route is that I used the Windows OTG USB made via Rufus and it appears mine did update properly then.

That sounds good

The official BIOS update page says v2 “Update Intel CSME package to Corporate.” and without v2, also stated by Matt Hartley.

I would guess that they both mean v2 and that omitting it is just shorthand. Of course @Matt_Hartley can provide clarification on this.

Interesting, I’m not sure what you did that would have differed from what other folks have tried. What distro, and did you follow any special steps not outlined in this thread?

Yeah, I’m glad to hear that… :+1:

Did you need or happened to install the 11th Gen Driver package before running the update?

This is how I setup Rufus for this. It takes forever to write the ISO to the USB stick but that’s what I did.

As for the driver package, I did not. I generally presumed the drivers were Windows-specific so I didn’t bother.

And I actually just installed Linux Mint Edge on my Framework to reduce the odd hardware issues I was having and they appear to have gone away now. So updated BIOS, updated CSME, and updated OS. All seems good at this stage.

@dfh you can update it via the Linux binaries iirc, yes it’s not official but the CSME was a security update so it is kinda important to update :slight_smile:

@Matt_Hartley @nrp -

I was willing to be patient and accept the “we’re busy” explanation / excuse for some time. But we’re at 10 weeks here. The excuse doesn’t hold water any more.

The Linux community deserves to not be treated like second class citizens in the Framework world. We’re used to that from other OEMs, but we expect more and better from Framework. I’ve talked up Framework to many people because of your embracing the Linux community and doing well to support at least a couple of common distros. Kudos for that. But you are also going to get called out when you don’t do as well by your customer base as you could, would, and most importantly should.

Please take this as the well intentioned constructive criticism that I want it to be: this kind of delay in publishing a security update that we can use is not okay.


A usually satisfied Framework Customer who would like you to do better in this case.


I had a suspion a lack of drivers could be bite me, since my Win2Go was missing a whole bunch of drivers. Eg. right mouse clicks weren’t working, no WiFi card, default graphics and what not.

I did a dedicated test re-flashing with my stock Win2Go version but that did not change CSME version.
During installation of the driver pack I saw an

Install Intel CSME driver

output in the Command Line window of the driver package installer and after a reboot my Insyde H2oFFT utility did something new when I ran another update:

After writing the new image a command line window popped up with a tool that called itself Intel FW Update and did some flashing/ updating.
And :tada: after I let the BIOS update finish, I am now running Intel ME Version / CONSUMER

Since I can’t re-test my instructions I’m curious if installing the Framework driver pack ** in Win2Go helps others too and if the indicators above (missing WiFi cards, no right-click on touchpad) are sufficient to figure out if you need the driver pack in the first place.

** Can be downloaded from the BIOS page – Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)


I am trying to fix the very annoying power issues on a 11th Gen Framework.

Two months ago, BIOS 3.19 was released. But so far there is only an installer for Windows. The support site sais “BIOS 3.19 EFI Shell update (coming soon)”.

What time is “soon”? I really need to fix this problem. Thanks.

1 Like

We have no way to know the exact release, but the firmware team has the Framework Laptop 16 release and the Framework Laptop 13 (12th gen) firmware before they can get back to the 11th gen. They have contracted more help from upstream firmware developers, but they will need to train them before they can start working on these projects. For now if you desperately need the 3.19 update, the best solution is to use Windows, which there are ways to do the firmware update without paying for Windows or fully installing the OS.


For more detail on what @Azure said, if you have a spare NVMe drive, you can install windows without giving it a product key and it will happily work for long enough to update the BIOS.

While that windows is installed, you can also create a portable windows install with Rufus in case you ever need it.

Of course, this whole process shouldn’t be needed, and hopefully they’ll have the EFI version soon (I honestly have no idea why the EFI version wasn’t the first one they got working, since that works regardless of the OS on the machine). But depending on how critical the fix is, sometimes you gotta do what you gotta do.

Thankfully the AMD board will let you manually select a file on the EFI partition to boot from, so after ditching the windows drive, you can still boot back into your regular OS and reinstall the bootloader so it auto-boots again. (I really like this feature TBH. Quite nice.)

Of course, all of this is predicated on you having a spare NVMe drive to use, so if you don’t happen to have one there’s not much that can be done. You might be able to run windows in a VM and use USB passthrough to let Rufus create a win2go drive, though that might be a bit of a pain to get working.

1 Like

Thanks for your replies. However, I do not have a spare NVMe drive, I do not have an existing Windows machine, I do not have a Windows To Go USB-drive, and I do not have many hours of free time to somehow get a Windows running on the Framework. I really hope the EFI BIOS version will be released soon and that it fixes the annoying power issues.


They never said that. They said, the contract is negotiated, they never said, the other party signed it yet.

Because upstream only give them Windows files. They did the repackaging in the past themselves.

1 Like

@Simon84 @Azure (other mentions removed because I think i’m still tagged as a new user in a second account maybe?)

I will again say that you can basically take a prior zip file and replace the files with the right CSME and EFI files that are within there - i mean i can just go in and rename them and the same startup.nsh in there should take care of it. As I mentioned above I just stick the things in my /boot/efi partition as it’s sized to hold enough

That should make it work, it’s not really rocket science but like many tasks I know it just takes getting to the top of someones list.

I’d be happy to post directions and a more clear series of steps, I really just reverse engineered the directions from what I did which was use the prior EFI version files and moved the newer bios and CSME in place and also found the Intel CSME Linux64 update tools and tossed them in the latest zip I had posted.

Honestly that’s what I would just do, take the 3.17 and drop the 3.19 file in its place and same for the CSME one and it should just run™ or update the startup.nsh script to point to the updated files.


Is there a workaround for linux? I booted into InsydeH20 and didn’t find anything. I have a spare usb stick if that helps