BIOS update problems [SOLVED]

When trying to use the Windows updater: ““The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash.””. Plain old “Update BIOS Failed” when attempting to use the USB stick. Very annoying. Turns out the problem was lack of free disk space on the EFI partition. Just posting this here, hope it helps somebody, because none of the other threads even suggested this (though it did seem to often be related to a Linux dual-boot, which it was in my case as well).

The Windows updater should test for this, I think, so it can give a more sane error message.

1 Like

@Jim_Duchek Can I just check what your solution was in the end? I’m having very much the same issue but dual booting with an external drive.

Well, as above, it was lack of free space on the EFI partition. I cleared out a backup Linux ramdisk that was on there. I think it needs around 30 MB free? Not sure why the EFI partition is made so small (100M) to begin with.

I’m also unsure why it was unable to use the EFI partition on the external flash drive I was using to do the update. I think the scripts use the internal HD by default, perhaps. I didn’t look very much further into it once I got my BIOS updated.

It looks like there are some options for resizing the EFI partition to 200MB, which should be plenty of space.

Thanks @Jim_Duchek.

My slightly unconventional solution was to remove my drives including the internal and then I was able to flash the BIOS using a USB drive.

Maybe @FrameworkSupport could look into resolving this issue for future updates - the ability to use a USB drive for flashing without a workaround would be great.

Yeah it seems to be a slightly annoying Windows feature, I noticed some of the solutions for resizing the EFI partition but most looked like propriatry software.

This might be the solution I’ve been looking for. I’ve set up a dual boot Ubuntu/Linux system on this Framework laptop with a UEFI I need to update to 3.10. But I don’t want to rebuild grub when the update wrecks it. Create the UEFI update USB, remove the NVMe, boot from the USB and job done?

Is it really that simple? But isn’t the problem that the NVRAM gets wrecked by the UEFI update?


@Chris_Bidmead It was certainly the solution that worked for me however you should disable secure boot and switch off Bitlocker on Windows if you have it enabled.
@FrameworkSupport did recommend using the Linux EFi BIOS Shell worth trying first.

Many thanks for that feedback, @mtthwbrd. Very helpful.