11th Gen Intel Core BIOS 3.20 Release and Driver Bundle Update

Mine is the full laptop not just the mainboard.

It would be cool if Framework made an AC<->DC adapter (or even just a DC<->DC adapter that converts from the battery ribbon cable style connector to a barrel plug) so standalone users had another option than having to open the case, and also pull apart your laptop to temporarily hook up a battery so you can do a BIOS update. Possibly easier said than done, since there’d probably have to be some electronics to emulate being a battery, unless the system has a mode where a connected device can say “this is really wall power, I have no charging circuitry.”

(Ideally, it’d be nice if the BIOS update could be done with dual USB-C power connections so the PD could be updated without losing power, but that might be a little more exotic than just making the device think it had a battery connected.)

Guess this all comes with the territory of a first gen product. Ah well, though… if this doesn’t improve, I’m still better off than I was because I got to upgrade my laptop and got a pretty nice HTPC as a side effect… Small price to pay.

It appears the update to 3.20 went well on my Laptop with the EFI updater (apart from when progress bar reached 100% and then jumped back a little bit and remain there for some nerve-racking minutes). After the reboot I checked all the version numbers and found they were as they should be according to the first message of this thread.

However I’m wondering, whether this has happened on my system:

I would expect iw phy to show at least some 6GHz channels working, but all are disabled. Also iw reg get does not list any 6GHz channels for phy#0 even though it shows, that country DE has been detected, where 6GHz is officially allowed.

I’m running Debian Trixie with kernel version 6.9.7

Has anybody had success with 6GHz WiFi after the update to 3.20?

Oddly, that’s really good to hear. Means it’s probably fixable.

Thanks Kieran. What’s the recommended way to do that on a CoolerMaster mainboard?

6GHz bands are working here (US) after the bios update.

Probably a stupid question: Do these support Windows 10? The table at the top of the page says “Windows 11” but elsewhere it just says “Windows.”

Sorry if this is answered elsewhere but I didn’t see anything in this thread or on that page to make me certain. Thanks!

If you look a #t the download you will see it is clearly a Win 11 bundle so I image there is no need or update for Win 10

Framework_Laptop_13_11th_Gen_Intel_Core_driver_bundle_W11__2024_06_25.exe

I had a somewhat weird experience with this upgrade.

  • I had tried an upgrade a little while back (probably to 3.19), but when I checked with dmidecode it said I was still on 3.02. Huh?
  • I saw the new update said something about needing to be on 3.17 or later for it to work, so I downloaded 3.17 first.
  • I ran the update, which worked once I figured out I had to disable Secure Boot.
  • Then I accidentally ran it again, because of the lost nvram thing it rebooted into the updater again. When I escaped that and tried to do the F3 thing, I must have been too slow because it rebooted into the updater and then it took the “F3” as meaning “go ahead with the update”.
  • Once I got back into Linux, I deleted everything from my USB drive and unzipped the 3.20 update into it.
  • Rebooted, ran through the update, everything seemed to work. Except the nvram thing happened again, ugh.
  • Once I rebooted into Linux and tried dmidecode though, it told me I had 3.19 instead of 3.20. WTF?
  • So, rebooted again, ran the updater again, lost nvram again, but once I got back into Linux this time dmidecode says 3.20. Finally, success!
1 Like

I’m seeing the same issue. Ran the startup.nsh from a USB drive with Secure Boot disabled. Everything seemed to succeed, but then after a reboot it’s still reporting itself as version 3.19 unfortunately.

No error.log that I can see, which seems to suggest that it thought it had succeeded.

My EFI-based upgrade from 3.19 to 3.20 went great. With 3.19 I think some of the subcomponents didn’t get updated, but with 3.20 installed I can confirm the CSME and PD versions in BIOS setup match what’s listed at Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)

For EC, the BIOS screen says “EC Ver: hx20_v.0.0.1-553827c” which doesn’t look at all like what that page lists for EC, “ec_320_553827”. But the 320 matches the BIOS version and the hex (likely commit sha) at the end matches, so I assume it’s good.

Hey Guys!

I cannot update from 3.07 to 3.20 .
I use a Linux system and updated via USB drive since the LVFS does not work on my system. I followed the instructions here Updating BIOS on Linux and it seems like it worked, but when I check the bios version it is still 3.07.

FW Update completed successfully and a reboot will run the new FW.

But in the end it says

failed to update capsule - Not Found

might that be an issue?

And if I check the bios version I get this:

Can someone help?

you should be on 3.17 or later. for the EFI updater to update correctly.

You can also try updating by manually running the update from the EFI shell using one of the following commands:
Escape to drop to the shell.

First select the filesystem you are on: FS0: or FS1 (you can see which device is usb based on the path)

And then try running:
CapsuleApp.efi winux.bin firmware.cap

Or running
H2OFFT-Sx64.efi firmware.cap

2 Likes

Thx for the fast reply! I did not see the hint to update to 3.17.
I just successfully updated to Version 3.17 by following the steps here: Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)
But now all my expansion cards and as well as the USB-C port behind them are not functional anymore. Could not find any answer to this. I already tried this My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on but this did not help.

Is there a solution for this?

Have you attempted a mainboard reset?

1 Like

Ah thank you for the hint! This did the trick! :slight_smile: Did not know that the reset fixes the charging issue.

2 Likes

Black screen after update from 3.19.

Come on guys…

11th gen 13" in a coolermaster case. No battery or lcd.

Video on external monitor in bios mode was working fine before. Only problem was that if the bios settings were wiped from the RTC battery problem (come on guys…) then the only way I could get video in bios mode was with an ASUS MB16AC that is natively USBC DP that I luckily just happen to have. Once I got a new cmos battery and saved the settings again, then after that a normal hdmi monitor worked even through a generic dongle. But the portable usbc-dp monitor always worked even with a reset bios.

Updated from whatever to 3.19 a few weeks ago with no problems.

Applied the 3.20 update from windows 10 on nvme (though not the only OS installed)

And now no video, and fan never spins.

short press (2 sec) , long press (15 or so sec), switch which side has power vs video, try v1 hdmi module, try generic hdmi/ethernet/power dongle, any/all of which which worked before, nothing.

2-second press and then wait 10-15 seconds, and the leds flash green, red, & amber alternately, mostly green, then shut off.

press something like 15 seconds or more and the leds flash blue & red for a bit, then what looks like the same mostly gree pattern as the short press, then off.

Tried a few different 100W supplies and a few different cables (all of which have worked for full power many times before). Tried using a v1 hdmi module instead of the generic dongle, as well as the above usbc-dp monitor which always worked in bios & bootloader before.

Funny. I got a similar issue.

I tried to update from 3.07 to 3.19 but it failed. I, then, learned from a forum post that I needed to do incremental updates.

So, I updated to 3.10 then 3.17. After that, I tried to update from 3.17 to 3.20. The bios installer completed without issue but know dmidecode is showing me that I’m on 3.19.

I guess I’ll need to re-apply 3.20… However, I find it odd (and a bit scary) that the installer or chip gets confused so easily. I’d hope this could be better documented in the future.

No battery seems to be a problem

It sounds to me that some of the problems are caused by the device where the update files are sometimes gets disconnected during the firmware updates. Maybe the firmware update tool could load all the firmware update files into ram before it does the update?
Does EFI have a ramdisk?