12th gen bare board as opnsense router

I’m trying to use framework as a router. I’ve posted this on OPNsense forums, but have gotten nothing so far. Everything i do works on the LAN side, but not on the WAN side. My modem never gives an IP as WAN but does as LAN, which is… odd. I’ve tried default settings, manually selecting Ethernet ports, unplugging my modem for 30 seconds with opnsense set to default, and even tried copying my old router’s Mac address. My modem (as WAN) never had link set to “up”, and never gives me an IP address (as WAN). Maybe the official Ethernet cards aren’t FULLY functional somehow?


Are you using 2 network cards on the framework (1 for LAN and 1 for WAN). Have you configured OPNsense DHCP? I also assume your modem is in bridge mode already as well since you said you previously had a router (maybe it switched back?). Sorry for the questions but I am trying to imagine your set up first.

… Good idea though… Framework board could be a very powerful router / firewall!.. I might steal the idea for my first Gen framework.

I’m struggling to imagine how you’re setting this up. Perhaps you could give us a mud map and let us know if you’re using one (router-on-a-stick) or two Ethernet ports.

The absence of the link annunciator makes me wonder about cable faults and/or MDI orientation. Do you know if the modem’s UTP port auto MDI-X? Have you tried swapping the UTP cable and/or using a cross-over?

Seems like there are connectivity issues and until they’re resolved, no one will offer your WAN interface a DHCP lease.


edit: remove stray semicolon

I’m planning to do the first one, but I can’t even do the second one. For the second pic, the only one I tested, I got both to link up with PC as WAN and modem as LAN, but not the other way around.

I got the PC to log in and change settings (in the correct configuration), but nothing else works.
Modem is Arris TM1602. I didn’t even know there were different types of Ethernet cable other than cat5, cat6, cat6e, etc.

Can you tell us the information of your WAN interface in OPNsense?
Is it enabled? What does IPv4 and IPv6 configuration type say? Did you change speed and duplex or MTU?

Everything is default/auto dhcp. Will find out specifics later

Enabled: true
Prevent interface removal: false

Generic configuration:
Block private networks: true (false doesn’t work either)
Block bogon networks: true
IPv4 configuration type: DHCP
IPv6 configuration type: DHCPv6
MAC address: both default and cloned from old router don’t work
Promiscuous mode: false
Dynamic gateway policy: false

Hardware settings:
Overwrite global settings: false

configuration mode: basic
Override MTU: true

Configuration mode: basic
Request only an IPv6 prefix: false
Prefix delegation size: 64
Send IPv6 prefix hint: false
Use IPv4 connectivity: false
Use VLAN priority: disabled

The “CAT” of the cable is mostly about signalling rate. Roughly speaking, the higher the number the higher the bit rate.

Twisted pair Ethernet cables can be constructed so that each pair is wired “straight through” to the same-numbered “pin” on the other end. So-called “cross-over” cables have the transmit pins on each end connected to the (different numbered) receive pins on the other end.

These days the difference is largely immaterial since most Ethernet interfaces include a mechanism to detect the cable construction and ensure that the signal orientation is correct. Occasionally you might encounter a device that requires a particular cable construction although I cannot remember the last time I needed one.

The documentation I found for your Arris modem doesn’t mention how the port is configured so I think it’s safe to assume it’s auto-sensing (or auto MDI-X). It also shows that the Ethernet port has an amber and a green LED.

Does one of those LEDs illuminate when you connect your Ethernet cable?


Yes, orange blinks randomly like a PC’s orange light. Green never lights, even with working store-bought router.

That the orange (amber) LED illuminates suggests that the physical connection is OK. My search-fu turned up several “official” Arris documents for your modem’s model. None of them define how to interpret the LEDs (and there’s no universally valid interpretation). I’ve never worked out what the Framework Ethernet Module’s LEDs mean since I always connect it to the same switch.

I’m sorry this line of diagnosis didn’t get you closer to getting it working.


The fact that I’ve tried rebooting the modem, holding the modem reset button, using different cables, using opnsense defaults, cloning the MAC address, and every permutation of those things means that this could be a framework problem. My off the shelf router works with this modem and both cables. The bright side is, i realized i was using a sub-par WAN cable for my plan and replaced that.

Do you have any other USB-NIC you could test? Or another computer to install OPNsense?
The Framework Ethernet Expansion Card uses an Realtek Chip which is supported by FreeBSD/OPNsense but people on Reddit say that this combination (FreeBSD+Realtek+USB-NIC) is not very reliable.

Do you think pfsense would be any different? The only other ethernet to usb thing I have is part of an eGPU enclosure.

I am wondering if this is a 12th gen with BSD issue. If it is PFSense is likely to be worse simply because it trails behind in updates. I recently ran into a case of no 2.5Gbps nic support in PFSense but OPNSense did support it. I would dig into what kind of support OPNSense has for 12th gen platforms and go from there. Also any of these Framework motherboards is overkill for SOHO.

Don’t know. Both pfsense and opnsense are based on FreeBSD so they use same drivers. But it’s possible one or another has implented some optimizations or patches.

Would be worth a try. Maybe there’s a chip from another vendor inside.

Are you using the WiFi-module? You could try finding a fitting m.2 ethernet adapter with Intel chipset.

Can you deactivate all the performance cores in BIOS and just use efficiency cores? Then it would be less overkill regarding energy usage.

PFSense tends to run behind OPNSense in versions of FreeBSD used. Currently about a year behind.

Have not tried this so I am unsure if you can in the BIOS, you could configure it on the OS side though. Regardless cutting cores rarely gives you the power savings you think it will simply because everything takes longer to resolve i.e. rush to idle. In short you wont turn a 28w part into a 7w part. Lastly FreeBSD and Realtek often don’t mix well and pretty much every external 1Gbps and 2.5Gbps adapter are Realtek chips inside.

1 Like

That is assuming the os handles the cpus power management well, given how “not well” linux currently deals with intels heterogenous cores it isn’t unimaginable that it’s even worse on bsd.

It actually might, you could also just lower the power limit.

Does anyone have any user-friendly alternatives to FreeBSD? Preferably ones that play nicely with Realtek?

You could try openwrt (linux base), though the framework board would really be complete overkill for an openwrt router XD.

There is also the option of using a m.2 to pcie adabter in the ssd slot and putting a bsd compatible dual lan pcie card in there to use with opnsense. Of course that would be a lot bulkier though.

1 Like