12th gen bare board as opnsense router

Wondering what you mean by this, I have encountered no issues with this.

It very likely won’t and I generally don’t recommend messing with the power limit outside of a BIOS option for most users. More likely to break it than fix it.

Strangely enough running it as a vm may solve your problem. i.e. use the Framework motherboard as a low power virtualization platform (i.e. KVM, Proxmox) and then use PFSense or OPNSense from there.

1 Like

Like properly powering down stuff and putting the right tasks on the right core clusters and stuff. The 12th gens work in Linux as in they don’t crash but the power management is still quite sub optimal (though there are improvements on the horizon). So with bsd usually running behind on hardware support it is not impossible they just have the cores at a fixed frequency, in which case turning off the p-cores would save quite a lot of power.

Messing with the power-limit has very little abilities to “break” anything, if you got too high it’ll thermal throttle and if you go too low it will just be slow and/or ignore it partially, that is of course asuming you even have acces to set the msrs from the os which idk if you can do that in bsd. But if you wanted to limit power consumption in a performance per watt standpoint, running a lower pl would give you more of that even if it stays on longer.

Anyway the 12th gen framework board even with the p-cores turned off and the pl set to absolute min is likely still going to be comically overkill for even 2.5Gbit routing XD.

Proxmox is actually a great idea, would also give you the ability to use some of that massive overkillness for other things. Not sure how well that fits into the user friendliness route though but then again using the fw mainboard as a router generally wouldn’t in my book.

Have not really noticed issues with it myself, but I run Fedora and keep it updated daily so newer kernel all the time. Usually by the time I beign to notice a problem it has been fixed. I know there is room for imporovement, but Windows is not really ahead in this realm. I was not thinking of FreeBSD power management, but yeah it probably sucks or is at least six months behind the curve.

I look at it as the likelihood of someone setting it too low? Very high. Not knowing what they did wrong? Also high. Likelihood of a help ticket? High. Do not recommend it :slight_smile:

Proxmox is pretty user friendly, sre there is a learning curve, and yes deploying it as VM also has a learning curve, but once you get past that, you have the same interface for the firewall, and an easy way to back it up.

You might notice an imporvement once the thread director and stuff hit mainline, from what I read it makes quite a difference on the battery life with 12th gen stuff.

I mean this is a special case already so idk how much that matters help ticket wise, also power limits set from the os are really not sticky. But anyway if it would help highly depends on how bsd does the power management on those chips.

Oh definitely, love me my proxmox and as a hypervisor it is pretty freaking user friendly, running a router os inside a hypervisor however does add another layer of complexity which is what I meant with the user friendliness. But yeah the fw mainboard makes for a much better vm host than it makes for a router XD (except maybe for stuff like thunderbolt p2p networking, cause don’t find a lot of other devices with 4 tb ports).

1 Like

Funnily enough, I thought about a VM almost as soon as I sent my last message. Would an OS like Windows, Linux, or ones y’all suggested send the information to a VM in a way that’s easier for the router OS to understand?

Compared to an old desktop, as Linus Tech Tips suggested, it’s probably less power hungry, seeing as it’s not a gaming laptop.

Just got news from an official Framework tech support agent that OPNsense (on bare metal) is not supported. No word on VM support though. :thinking:

1 Like

Throw proxmox on there and try it.

1 Like

Sure will.

With proxmox, my PC won’t connect to the IP address when plugged in to either card. It acts like it’s not connected, but when I unplug the cable while it’s loading it says, “your connection has been interrupted”. I think using any purpose-built VM/router OS on bare metal might be a lost cause. At least not with a framework/realtek NIC.

do you (or anyone else) have a suggestion for a 2.5 gig usb c nic that doesn’t use realtek? Why would FreeBSD not support the chip that is most common by a wide margin? and yes, it has to be 2.5 gig (because of my internet plan) & usb c (because framework)

Probably because they have had problems with them for years because Realtek puts out shit drivers that have to then be reverse engineered, also FreebSD is primarily an OS geared towards desktops and servers. In this instance you have ZERO need for a usb nic adapter, and any server grade motherboard will have intel onboard, or a pcie nic adapter with intel, or broadcom adpaters. That being said you wont find intel chips on a usb nic adapter and the only ones that are not Realtek are of the 10G variety and those cost.

For further troubleshooting you will likely have a better chance of getting help at the chosen OS sub reddit or community forums. BSD is niche, and while I can get around and figure things out on a BSD system I am not really qualified to give advice sight unseen. I did just notice that you had both ipv4 and ipv6 enabled. Try disabling ipv6 unless you are 100% sure your provider is running both.

Posted on May 3rd. Absolute silence. I’ve had more help here.

The point of this project was to reuse my old motherboard. Anything else is either hardware I don’t have on hand, or is way bulkier, slower, and more power hungry (i think) all at the same time. The switch and wifi AP don’t count as “extra” because I would’ve bought them for any diy router project.

This is going to be a lot bulkier and you’ll have to source 12v from somewhere but how about a dual intel 2.5gbit pci card (like an i225 or something) in a m.2 (you can probably even use the one for the wifi, there are pcie 1x dual i225 cards) to pcie adabter?

There is also stuff like this, but the the ones with intel chipsets I could find were all single poert and the dual ports are realtek too so same issue there.

In the end it may be better to sell the board and buy one of those fanless mini pcs with a couple intel 2.5gbit nics in them that are made for this application instead, you can get those for <200$ depending on how much horsepower you need. Definitely not as powerfull as the 12th gen i5/7 chip in the fw mainboard but for routing and a bit of medium duty firewalling it should be more than fine.

For your original configuration (OS and hardware), one of your ethernet adapters worked but the one connected to your cable modem did not? Presuming that both network adapters are physically working (e.g., one is not broken), then the issue is not your hardware or drivers per se. You might try changing the 'Block bogon networks: true" to false and see if your ISP side will pick up an address from the modem. There were some issues in the past where opnsense would not accept a DHCP address when that rule was set to true on an interface.
If you change that setting and your ISP side network adapter still doesn’t pick up an IP address, you can try setting your ISP side with a static IP address if you can get the network/subnet/gateway information that your modem is putting out.


Are there any 2.5 gig A+E key m.2 to ethernet adapters that don’t use realtek? I’ve found 1 gig cards from Intel, but no 2.5 gig ones.


Just realized my internet plan was 1 gig anyway. Since framework’s cards work with LAN, hopefully I can get the non-router VMs to work correctly.

Just got my m.2 to ethernet adapter delivered and it doesn’t even show up in the system on any OS. The contacts are a little different than the wifi module framework provides, even though they’re both e+a key. I also noticed that the mainboard has a socket that looks like it can physically support e key with no a. What does this board support, why is e+a different from e+a, and what do i look for? Is there a certain protocol that i missed, like nvme vs sata on the ssd socket? I’m clearly out of my element here.

The different m.2 keys have different pinouts (check out the table with the keys), maybe a few pictures would hep see what’s going on?


I currently have pfSense on a power hungry (~105W) Dell R630. Now the 11th Gen boards are £199 I figured it’d make a great replacement and bought one without hesitation! On paper it should pay for itself in energy savings in less than a year!

Only now do I realise the potential minefield I’m stepping into regarding network adapters :confused:

Did you ever find a stable solution?