12th Gen i7, Ubuntu 22.04 Wakeup

I received my machine yesterday and got Ubuntu 22.04 on it no problem. Frankly I’m amazed at how everything, including the fingerprint reader, just works. I spent far more on an Oryx Pro from System76 as my last Linux machine and features like that never worked at all, even with their own distro.

The only problem I’m having is when the machine wakes from sleep. I usually have to reboot it completely when this happens. The screen is all over the place, trying to search for apps gives me nothing and it generally locks up until I power it down. Sorry, wish I could get more descriptive. I can’t get a screenshot in that state and my phone camera is giving me issues.

Anyone else seen anything like this?

What kernel are you on? When I first upgraded to the 12th gen board, I lost hibernation and had issues with standby. It wasn’t until I updated to a newer kernel that things worked again. For your reference I am on 5.19.5 and everything works, dare I say, perfectly.

Hmm… 5.19.0-26-generic according to uname. Looks like I need to update. I’ll give it a shot. Thanks!

Should wake up just fine. Some things to test with:

  • What is attached when it’s in suspend/resume, try detaching these things and trying again. Peripherals, monitor, etc. Helps us to pin point a likely cause.

  • In a terminal, you can try sudo journalctl | grep resume or sudo journalctl | grep suspend to see what trigged what and why, then share what may be a relevant line here. But easiest is to eliminate external sources first, then try this if it persists.