12th Gen Intel Core BIOS 3.08 Release

Could you please share some kind of genetic roadmap just to have clearer expectations about what’s happening and dated?

“we are still identifying the best path forward”
From my understanding/experience this means something like: “We are currently talking/thinking about what we should do next, because right now we don’t know or don’t have the time/resources for it.”.
At least that’s what our project leads at work tell the customers and leadership if there is no progress :smiley:

While creating a Windows boot stick to install the update is a good workaround/short term solution, I can’t imagine “normal” users are happy/willing to do this.

1 Like

Did the EFI method break laptops? cause it worked fine for me and some others it seemed. I dont like sharing the efi files while the official beta got removed, cause who can trust little ol me? if the windows stick method truly is such a problem, why consider a beta bios at all. just wait.


@Matt_Hartley Can you please share some details. What is the exact problem of the EFI updater? Is it the missing ME update? If people used the EFI updater (and updated the ME), will they need to wait for another update to fix something? If yes, what?

I’ll also have the impression that this will end as the EFI updater for Gen11 3.19. “Coming soon” forever and no clear communication.


Has anyone done this successfully so far?

  • Nothing but Charger + USB Drives attached
  • I booted a Win10 (22H2) installation media from ventoy (normal mode)
  • I can find the second drive (FAT32 formatted USB drive) with the msi file on it
  • Executing the msi without by simply calling it from cmd gives me a messagebox with “No such interface supported”
  • cmd afterwards shows “Access denied” (cmd was opened as administrator)
  • Calling msiexec /i [installer.msi] cannot find msiexec

Edit: I also tried using Win11 (23H2), but it gives me a messagebox with “An attempt was made to reference a token that does not exist”
Edit2: Formatting the second drive as NTFS does not work either

Any ideas?

  • FAILURE SKU# and SYS SERIAL NUMBER: FRANMACP04 (SN: I have that ready, but not sharing that in a public forum)
  • SYS CONFIG: i5 1240p
  • RAM: Crucial 3200 2x16 GiB (Jedec, CT2K8G4SFRA32A)
  • SSD: Samsung 980 1 TiB (non-pro)
  • Wi-Fi: Original - AX210
  • External Devices/Other: Baseus 100W USB-C charger (worked perfectly in all previous situations)
  • EXPANSION CARD TYPES: Left: USB-C Rear, USB-A Front, Right 2x USB-C (charger plugged in here)
  • BIOS VERSION: 3.04
  • DRIVER PACKAGE VERSION: Framework driver setup (there is only one), updated to newer GPU, WiFi, BT drivers from Intel
  • OS VERSION: Win 11
  • STEP TO REPRODUCE: 3.08b Windows installer.
    1. Installed ME update fine
    2. Reboot into capsule installation
    3. progress bar BS (not intelligible which run)
    4. came back to the device after a few minutes: device off
    5. turning back on manually, Windows loads
    • BIOS & ReTimer 01 updated successfully, ReTimer 23 not. Choosing to retry ReTimer update from Device Manager + Reboot showed update screen shortly, but quits silently and reboots back to Windows without updating
  • EXPECTED RESULT: Device manages to finish all 3 updates on its own
  • ISSUE RECOVERY METHOD: BIOS → Battery Disconnect, wait 5 Minutes. Plug charger into right side, let Windows retry → Success. Everything fine and updated.

This is pretty much the same behavior and solution I observed when updating my personal 1260p (FRANGACP06) from 3.03 to 3.06 last year (WD SN850 back then, more RAM, all USB-C expansion cards). Even was the same ReTimer that failed to update. Although, while I am not 100%, I believe I had a different charger plugged in and on the left side back then.
So it seems very much that the ReTimers updating is what is problematic and nothing has changed with that since the 3.06 update. Only that my own FW already had up-to-date ReTimers, so that was not an issue this time around.

1 Like

Following up on my attempt yesterday i just installed a fresh copy of Windows 11 23H2 on an SSD and tried to run the installer.
Surprise Surprise: It did not work…
Unfortunately i did not make any pictures, so i dont remember the error message…

I had to run Windows Update, restart the device and only then the BIOS update would install.
@Matt_Hartley Did you even test this method, before recommending it?

Matt is the Linux Guru at Framework. While it is conceivable that he would help with Windows testing it is not directly his lane. Furthermore, because it didn’t work for you, doesn’t mean it doesn’t work for someone else.

It would be really great if you could share the error you saw as this would help to improve things.

1 Like

I should have been clearer with the above statement. I did test it Friday after this went up, no, it is lacking msiexe in the installer, so it’s a no go. Post was updated to reflect this.

For exe’s, you just drop them in and hit enter. For msi packages, you would need msiexe, which is not available from the install media itself unless the OS is installed. We were able to determine this afterward.

I have spoken to engineering and the course of action is to continue to work on getting the efi option sorted.

However, those who do not wish to wait can install Windows and run the MSI which has a solid success rate in testing here in with the community and with us. Ideal, no. But it does mean there BIOS are available now, but for efi we need to get some things sorted as there are some configurations that are not playing ball.

For those of you using Linux that are not thrilled with this. Yes, I get it. Fulltime Linux user here. However the ventoy method of creating a Windows installer USB is sound and works.
Install Windows, run the MSI updater, complete the process. Then once you have confirmed the BIOS update, wipe Windows.


I know, but this is exactly where im coming from.
EFI was pulled, so FW recommends all Linux Users to install Windows or use the Windows installer method, that Matt suggested.
We know at this point, that installing from a Windows install works, but no one ever gave a heads up, that an Windows Update is required, to run the BIOS update.
The windows installer method does not work at all…
Imo FW should test these methods from a Linux users perspective, before recommending them.

1 Like

Updated the post and also replied with extended details here as well.

But to your point, this is where it fell down on my end:

I should have been clearer with the above statement - shaping up did not mean tested by me, it meant a lead on a likely fixes.

I did test it Friday after this went up, no, it is lacking msiexe in the installer, so it’s a no go. Post was updated to reflect this.

Please see this for details:


Im pretty confident the general recommendation is not to install this update at all since this is just a beta. There are still no updates for the 12th gen laptops as far as the average user is concerned.


*All Linux users, who want to participate in the beta :stuck_out_tongue:

1 Like

Suggestion: Ship a bios update ISO in addition to the zip. This will help users work around incorrectly formatted USB drives and should reduce customer support requests relating to BIOS updates.


might not even browse these community pages, nor be on discord and be unaware of any bios updates. the average computer user is annoyed when a system reboots multiple times and all scary white characters appear and multiple progressbars.

EDIT !!! SHA1 I took was for 3.06, now its for 3.08.
Framework_Laptop_12th_Gen_Intel_Core_3.08_EFI.zip SHA1:317771e616be990ff3c54b24f9864d41dbea8d23
is still on the FW servers.

Thank you for double tripple checking


@Matt_Hartley Thank you so much for your candid reply. It really does mean a lot.

Looking forward to you guys crushing this release, in due time :slight_smile:


Just wanted to report a success with the 3.08 Beta EFI upgrade on my 13 inch Intel.

I’m well aware that it has been removed for the moment, however, I have had a 61kWh battery waiting to be installed for months now so I really did want to do the update to enable full support for that, and took the risk.

Nothing unusual - disabled secure UEFI boot in existing BIOS; booted from USB-A stick formatted FAT with the update unzipped to it; watched and waited while it went through all the steps; booted back into Fedora 39; restarted to re-enable secure UEFI boot.

1 Like

I’m likely going to be doing the same thing. I have a 61Wh battery coming and only have Fedora 39 installed. Don’t want to reformat to install windows.

Worst comes to worst, I remove the SSD as others have said they have been doing


I installed this today via EFI method and got the line 97 error. I had the power plugged in on the same side as my flashdrive when I got the error.

Moving power to the opposite side and rebooting fixed the issue for me. I did not have to remove my SSD.


You might want to check your download here. I just downloaded the file (for clarity, it’s still on the servers but Framework say you shouldn’t use it) again which shows up with a SHA1 of 317771e616be990ff3c54b24f9864d41dbea8d23, this also matches the file I downloaded Jan 11 2024 (my post in this thread) which I still have.

For posterity, the SHA256 of the file is:

ddb2ef62f589e5c972d577e2e44b6ac2d7d040767189dfb4bcd04aa5d93751e6 *Framework_Laptop_12th_Gen_Intel_Core_3.08_EFI.zip