12th Gen Intel Core BIOS 3.08 Release

You might also just try:

… before you go to the trouble of opening up the laptop and removing components.

Updated from 3.05 to 3.08 this morning via the usb-stick method. It took 3-5 minutes to complete and worked out well. I’ve removed all unnecessary cards before updating (e.g. HDMI), started with a ~70% charge level and let it do its thing without interfering.
My System: i7-1260P, 1TB SN850X, 32GB Corsair RAM

EDIT: Connecting a USB-C dock with two monitors works as expected

installation went smooth using EFI installer but display through type-c is not recognized after update (fedora kde 39)

also connecting HDMI is not working for me.

So i can’t revert… and can’t use any external monitor… please release fix asap :pray:

1 Like

Just updated from 3.06 to 3.08 with the UEFI Shell updater. Everything worked flawless and system booted up normally.

CPU: Intel i5-1240P
RAM: Corsair 32GB (2x 16GB) 3200 MT/s
Storage: Samsung SSD 980 Pro 500GB

Probably that, or someone felt you used a combative tone, or someone got up on the wrong side of the bed, or just because, it don’t matter until a mod reviews it…but really how constructive is this? This is a BETA release, and we are in the testing phase, so maybe if you want to vent…open a new thread where you are not creating clutter in a thread dedicated to testing it.

P.S. Quoting your flagged post in another post is a sure way to prejudice any mod to your position on pretty much any forum I have ever been on.


This has failed I’m afraid


@Richard_Osterloh Iirc, I had this problem with 3.06 when I hit F3 instead of F12 to select the drive.
Did you hit F3?

For the people whose ports stop working, can you try disconnecting the SSD and trying again without the SSD connected?

I get the same error whether I press F12 or F3. I have not installed an SSD. I am on version 3.06.

1 Like

Success on my 12th Gen board. I used the windows version.

EDIT: solved now!

Actually now I have the same problem as @Richard_Osterloh and @Heinz-Willi_Eichmeye

Here is my screen:

My current bios is 3.06, on a i7-1280p.

Same on my side! Fedora 39, update went through but now my external Monitor through dockingstation and HDMI doesnt display anything anymore.


That’s the same problem I had. Power off, disconnect from AC power, remove your ports, wait 30 seconds, reinstall ports and try again. In my case it resumed seamlessly at firmware 2.


OK I solved my problem.
Now it works! Upgrade succeeded :smile:

Mainboard i7-1280p.
Upgrade from 3.06 to 3.08.
By EFI boot method.

@Benjamin_A_Ewoldt Yes, thank you! Indeed I had to do this kind of steps.

Overall it was not straightforward, so it would need to be fixed in order to go out of beta state.

My steps (I call them “points” to not confuse with the installer’s “steps”):
0 - started the laptop, and the installation process (with F12)
1 - I was stuck, as described in my previous post.
2 - I powered off and waited a bit, and removed the AC and the USB key (I did not need to remove my expansion cards, as they are all 4 just USB-C expansion cards)
3 - I started over again (with F12 key). I needed to try again and reboot several times, because the ports were not ready yet (I should have waited longer). I also used different ports, so that may have helped; maybe some ports were stuck in the middle of the previously failed upgrade.
4 - The process got stuck in the middle because of low battery (although I was at 20%, and I was AC-plugged anyway, but maybe that was due to a faulty or partially-upgraded PD firmware), and the text on the screen advised me to reboot in OS. (EDIT: I forgot to mention that from that point, until my point “6”, there were color codes on the side LED)
5 - I disobeyed the text on the screen and rebooted in the EFI installer again (instead of the OS)
5bis - (actually I think I did the point 5 several times)
6 - the install process just resumed (now I was at step 3/5, etc), seemingly oblivious that the previous step did not happened because of “low battery”
7 - after several scheduled reboots, the text on the screen said that the upgrade was done. I was skeptical, though. So I started again the flashing.
8 - So everything repeated again. But this time there was no battery issue (probably thanks to fully updated/fixed PD firmware). By the way I could check on the info displayed in the screen that the EC version was still 3.06 and being upgraded to 3.08. So I was right to do it again (It stated that the PD firmware was already up-to-date though).
9 - So, after several scheduled reboots, the upgrade was completed. I could check that the BIOS was properly upgraded to 3.08, and everything works correctly for now.

That’s it!
I will report again if I notice problems, e.g. peripherals not working etc.


Eventless update from 3.05 to 3.08 on my 1240p via Windows.

Thanks! This solved this issue for me as well

Updating without battery in the CoolerMaster case via EFI was a failure, I do not recommend. At the end of the update process via EFI it told me it had successfully updated but version numbers had not changed. Instead connect a battery and update via Windows.

Here is what happened when I tried EFI update without battery:

Updating from stock, the mainboard is outside of the laptop in the Coolermaster case. Rear left port is power, read right port is USB-c to monitor, front left port is keyboard, front right port is the USB stick with the update.

Booted, updates started, screen went blank, 5 minutes later screen is still blank. Fan is whirring.

After 10 minutes I powered off and thankfully it was not bricked. It booted in to the update and gave the message “Progress: 0 out of 5 flash steps done. Right PD controller (01) is up-to-date. Skipping flashing. Flashed one PD controller. The system will shut off. Please move the power-source to the other side, to update that PD controller. Then turn the machine back on. The firmware update will continue.”

I powered off and swapped the monitor and power cables, initially it seemed it would not power on but after 2 minutes of mashing the power button it did, and the update resumed. Shortly after, the screen went blank again. This time, the screen came back on after a minute with the message “Unable to redirect file. Script error Status: Invalid Parameter (line number 116) FS0:\framework-firmware-updater\firmware>”

I randomly changed up the ports (power rear left, monitor front left, keyboard rear right, usb stick with bios update front right) and powered on. It told me 2 of 5 had completed. Before I could do anything else it told me it needed to reboot, and it did so automatically. I lost track of what was happening because it was so fast, but the screen went blank and the device powered off. Once again it refused to power back on, so I disconnected it from power and waited 30 secs as suggested. Still it will not power on.

So I swap the left-side ports around as suggested, now it powers on and tells me 3 of 5 have completed. It continues the updates and says update 3 has completed. It moves on to update 4 (H2OFFT-S64) and tells me “Warning: No battery connected, this process requires AC power and a charged battery … . Error, update bios failed! Press any key to return to OS”. I press CTRL-ALT-DEL to reboot, and it appears to start up but there is no output to the monitor, I am treated to a pretty lightshow with red blue and green lights from the mainboard. I try disconnecting and reconnecting the monitor, no joy, so I unplug the power and wait 30 seconds. Just for kicks I swap the power and monitor cables around again.

It powers on and tells me 5 out of 5 flash steps done.

Display output from right-sided ports no longer working.

At this point maybe you could try hitting ENTER?
See what it does after several minutes.
If nothing, I would try rebooting.

Ok then now it looks like a lot the same issue as many of us. Lukily, it has a fix!

See this post: 12th Gen Intel Core BIOS 3.08 Beta Release - #52 by Benjamin_A_Ewoldt

or my post: 12th Gen Intel Core BIOS 3.08 Beta Release - #53 by Mapleleaf

I bet you current screen looks like that? : 12th Gen Intel Core BIOS 3.08 Beta Release - #50 by Mapleleaf

To those who have already updated: Can you please test this and post your feedback?

1 Like