12th Gen Intel Core BIOS 3.08 Release

Thank you for that link. The following is the modified result with the b version of the beta. I was wondering how windows had such great success without any issues.

FAILURE SKU# and SYS SERIAL NUMBER: FRANGACPA42234003F
SYS CONFIG: i5-1240P
RAM: 2 Sticks Crucial DDR4-3200 - 16GB (Total)
SSD: Brand/model and how large is the capacity. If removed, please indicate.
Wi-Fi: Stock
External Devices/Other: Plugged in via USB C
EXPANSION CARD TYPES: 1 HDMI 2 USB-A 1 USB-C
BIOS VERSION: 3.04
DRIVER PACKAGE VERSION: If known and if using Windows.
OS VERSION: Windows 11
FAIL RATIO: 0% (With b version of firmware)

STEP TO REPRODUCE: EFI Shell via USB drive, Windows package, and the steps you recall taking. Just do your best. I realize no one will remember all of this.
Step 1 - Download Framework_Laptop_12th_Gen_Intel_Core_BIOS__3.08
Step 2 - Launch MSI
Step 3 - Yes on UAC prompt

OBSERVED RESULT: Installer launched but returned error "This installer can only be run on Framework 12 Gen Intel Core Mainboards.

EXPECTED RESULT: It to flash successfully and be reflected in BIOS settings.

ISSUE RECOVERY METHOD: Firmware did not even start.

EXTERNAL DEVICE MODE or NAME: Not used

I do not normally install beta software because of possible warranty issues. However, my system was shipped with a security vulnerability. Now that it has been a year my warranty is over, so I figured. Might as well take the risk.

I do agree they should have updated the initial post. Or created a new thread and retired this one if the original post was not editable.

My only hope is they are not looking at this thread because they are deep in development cycle and any future reports would be pointless until the next cycle.

My other concern is that they may be making perfection be the enemy of the good. As long as it fails properly they can release what is mostly successful then work on the next cycle for an updated version that fixes it for those that did have failures.

2 Likes

@Kieran_Levin is the framework team still working on the correction to the EFI update method? Or do we Linux users just use LVFS? Currently still on 3.05

2 Likes

It be intresting to know if they make any progress on fixing the efi method. the old one is still there tho.

Getting out of beta and a stable windows and linux based method would be cool.

3 Likes

Now I’ll be moving into criticizing Framework again. It’s been over a month now since the last Framework communication and the update is still not out of beta and issues with EFI are still unresolved. I will acknowledge that they have been doing other things, recently saw a thread regarding updated firmware for the fingerprint reader. Currently wondering what the blockers are and once again, not feeling the love and getting frustrated.

18 Likes

No more complaining from me. My mom needs a new laptop and we’re getting her a Lenovo.

6 Likes

Not sure if this is a bug with this new firmware or a separate issue, The monitor I use at work(90w PD) doesn’t power the laptop enough to charge from dead and power on. In the past it did.

“Update PD firmware to version v0.1.2C”

This is why I think it may be the firmware but this is an old mainboard at this point so I’m not really sure if it could be something else due to age. Plugging it in to a 65w charger was enough to power it on.

This doesn’t happen often, but sleep isn’t perfect and I walk into work with a dead laptop every now and then.

1 Like

I installed Windows 10 on a USB stick to run the update.
I usually use Linux on the SSD but for the update I removed them.

Update process go to 100% and the computer restarts and boot direct Windows. However, no update was installed. Biso’s version still shows 3.04

Does the update only work if Windows is installed on the SSD or do I have to update to 3.06 first?

1 Like

The progress you see from within Windows is just the Intel ME update. Sounds like you already have that updated. All the other parts are handed to Windows and Windows is supposed to hand them over to the BIOS on the next reboot, for the BIOS to update itself.
So maybe whatever you did to get Windows on a USB device interferes with this. I do not yet know whether Windows only notifies the BIOS during the next boot or does that immediately when the firmware becomes available to Windows. Or how exactly Windows hands the firmware updates over. If Windows just tells the BIOS where on the harddrive it put it, that may not work from such a USB stick.
DevManager lists the firmwares under the Firmware node. And each of them should normally tell you if they are still outstanding and queued to be installed on next reboot etc.

But on the other hand, I theorized above, that that “capsule” self-updating of the BIOS is also supported by Linux/fwupdmgr. As the main work is done by the BIOS itself. The only thing that is not available under Linux is the ME firmware update, that you have already done.
So you could potentially extract (7zip for example) the .inf and .cap files from FWs update installer. And install them using fwupdmgr as I believe FW themselves showed on some threads here already.
And their previous Linux fwupdmgr updates are basically those .inf and .cap files packed into a .cab file.

Same as I could extract those files and install them manually. The FW installer does nothing but automate installing those 3 capsule updates and then runs the ME updater.

All of this is of course to be considered experimental. Although since the BIOS handles the actual updates, I’d guess that most of the things that can go wrong are just failing to hand those files over to the BIOS or the BIOS refusing them for some reason.

Almost 2 months since anyone from Framework made any commentary on this thread. Is there any progress on a STABLE release of a BIOS/UEFI for the 12th gen CPU? Is there any plan to ever deliver a stable release. The device has been released for almost two years now and outside of the buggy factory BIOS (it was buggy thunderbolt had all sorts of issues on it), no stable release. We were promised priority, clearly that happened for a hot minute, and then nothing. Still can’t get over the goal line with this.

15 Likes

And Framework AMD 13 and 16 get new Beta BIOS updates while the 12th gen continues to get the Gen X treatment. An update would be really nice. I have two Framework 13 12th gens and one is updated the other is still running on the original BIOS. Can’t update it because I am not going to update that one until we have a stable release, as it is not my daily driver, and the user might have issues if I break it with a Beta update. 1.5 years since purchase and still no STABLE update, and in light of yet another update for other Framework platforms, even I am beginning to lose my patience. @nrp promised priority, clearly that has not happened. Priority until a new shiny happens along, can we get this done? Is it possible to get a STABLE release? Can a user who purchased their laptop in 2022 finally have a fully functional laptop? At this rate I will be upgrading to a 15th gen Intel board when those are available and my 12th gen will still be waiting for a STABLE release.

5 Likes

what is the difference between a stable and beta bios? sofar its been running pretty stable on my system. installing it is sofar where most people have issues with (when they have issues) it seems to work when its fully worked.

I understand its frustrating to dont see a stable update after 1,5 years, hope we see a few someday soon tho.

1 Like

Then it would have been easy for FW to release them officially.

And typically, if sth. goes wrong with the BETA update it’s not the manufacturers fault because it was a BETA without any guarantees. And so far we cannot even roll back from the BETA if sth. actually is broken.
If FW would clarify that they fully support the BETA and would warranty exchange a board bricked by a BETA update or if a rollback is needed but impossible that would ease peoples minds.

But just let me remind you that FW decided to stop the release process for both of the Beta updates so far, yet they never even bothered to update their Known Issues or clarified what the remaining problems in that firmware were. So I think they have proven, that their own info on potential issues with the updates is unreliable, untrustworthy and out-of-date.
And then you advocate for people to just treat them as normal updates without the company itself doing anything for it?

I have installed the beta updates too, but I would never blame anybody for not wanting to participate in an explicitly labelled beta. Especially those for whom the FW is their primary or only computer.

7 Likes

As @Ray519 stated, primarily liability. I have other reasons as well. If you can’t provide stable releases, you have no business selling to Enterprise. A lot of people come to me for recommendations both professionally and personally, I simply cannot recommend Framework until such time as they prove they can handle this vital security function.

9 Likes

Could we please get another update on this? It’s been a while.

CC: @Matt_Hartley

9 Likes

Sadly, the Intel FWs really seem to be the last thing they think about.
For the AMD FW13 they also released a new driver bundle beta that includes new Goodix Fingerprint Sensor drivers that also comes with a firmware update to fix security issues. As I understand all the 3 Intel FW13 should have the same fingerprint sensor and the same security issues (and the firmware version is the same as from the Beta LVFS update for the fingerprint sensor that was not limited to any specific model).
That is sth. that they could easily communicate or release for all of us. But silence for the Intel models.

Maybe affected by the fact that FW so far only had the model-specific monolithic driver bundles that install all of the drivers and they do not want to release a new installer that downgrades many Intel drivers just to beta test the new fingerprint driver and firmware.
But still. Another way to make us feel like 3rd class customers. And avoiding that would have taken 2 sentences posted about it somewhere.

3 Likes

Some great news, they’re finally hiring another firmware dev: Framework - Firmware/Software Engineer

So maybe once the engineers are up to speed and they have a process nailed down, they’ll be able to maintain their devices. Too late for the 12th gen, but good news for future generations at least.

8 Likes

The main support page for 12th Gen laptops has been updated with link to the 3.08 BIOS. I guess this means 3.08 is no longer in beta?

Note that the link on that page points to 3.08 and not 3.08b

EDIT: maybe they’ve updated the 3.08 link to incorporate the 3.08b fix? Can anyone check this to confirm?

9 Likes

Hash of the file is actually identical to the hash of the non-b installer. So yeah, they managed to release the version that was shown to wrongly classify some devices as non-12th gen…

7 Likes

They also managed to copy the tiny mistake of labelling the GOP firmware as “same”, even though the versions they quote are not…

GOP 21.0.1061 21.0.1046 Same

And they managed to not provide any instructions for what to do, when the update stops on the 2nd ReTimer. And I’d expect more people to run into this with the Release, as the only reason many people here did not have to go through this, was that participants of the 3.06 beta already had the ReTimers updated. But people going from previous release to 3.08 will get the ReTimer updates. That for me, hung on 2 separate devices and required the powering off for a few minutes workaround they themselves described with the 3.06 beta…

Edit:
And the “Known Issues” are empty. Even though on the 3.05 AMD Beta they list known, but most likely not exploitable components on default settings in Insydes Network Stack. That is included in all FW BIOSes so far, even though none of them seem to have a use for it (would be very surprising if the AMD 3.03 BIOS included issues, that were not fixed with 3.05 for AMD, but are neither in our 3.04/05 nor the new 3.08)

And we can debate over whether the Fingerpint Sensor known security issue should be listed there or not (it is not updated from the BIOS, but either LVFS or the new Windows driver).

Edit2:
Uhh, one more oversight for them: The table of updated parts of the firmware compares with 3.06, which was never released, only beta. So on a webpage that up until now said 3.04/05, the factory version is the newest, suddenly mentioning and comparing to a firmware version that was never released, is also confusing and very much careless.

9 Likes

Also the German version still says there is no update available. Sounds like something did go wrong there.

4 Likes