A strange multiple monitor thunderbolt 3 dock problem

Hi, I just got my Framework 13 (13th gen Intel) last june (Batch 2).

I have a 2 x 4K 60Hz monitor setup connected via a Belkin Thunderbolt 3 Dock Pro. During a day of working a strange problem occurs. One of the two monitors seems to disconnect (black screen) but is still visible in the Display config of KDE/Gnome/Windows 11. After I change the display config of one of the monitors to 30Hz the display re-enables for a random amount of minutes.

The things I tried:

  • Tried running on 30Hz on both of the monitors. Same result.
  • Search this forum and found a few kernel options for the Intel Graphics card. Tried it and it didn’t make a difference.
  • Changed desktop manager from KDE Plasma to Gnome both Wayland (Newest versions available on Arch)
  • Tried the LTS kernel on Arch. Same problem
  • Changed Linux distro from Arch to Manjaro (Gnome)
  • Changed over to Windows 11 22H2 Enterprise. Same problems. Checked the eventlog and nothing.
  • Connected my MacBook Pro M1 Max (Ventura) to the Belkin dock and everything is working.

Some hints an tips would be appreciated.

Kind regards,


Is the dock overheating?

It’s getting pretty hot so it could be overheating. Why would it keep working with a Macbook Pro and not with a Framework? I am prepared to by a different Thunderbolt 3/4 dock but I don’t want the same issues. I could try to connect a charger and the thunderbolt 3 dock at the same time. That’s for next Wednesday…

1 Like

Same problems, back to working on a Macbook for now.