AMD Batch 3 Guild

Documenting: my unit came with BIOS 3.02. R5 DIY.

1 Like

My order to Vancouver, Canada, also arrived at my door (I’m in an apartment, though). Both boxes were quite banged up, just fedex things I suppose:

I’ll test the mainboard later today, hopefully it’s OK.

Edit: Update, appears to work okay. Bios version is 3.02 and I’m trying to upgrade it now.


My order also arrived today here in Calgary!

1 Like

Received mine with 3.02 firmware. What are the current drawbacks with upgrading to 3.03?

Mostly issues with chargers not working after the update. But FW has decided that the gains to 3.03 far outweigh any regressions, and is pushing 3.03 as a stable release.

I just assembled my R5, installed the latest nightly ISO of Fedora 39, upgraded the BIOS to 3.03, and am looking forward to all the goodness to come.

Just configured mine!

Some issues I found:

  • Linux Mint login window resolution is really small, the elements are huge! It was fine before I updated the kernel though.
  • Fingerprint on an empty session (whether from boot or if logged out) does not work and re-loops back to login window. Pasword needs to be typed first. The fingerprint works on unlock (with existing session), sudo or admin right requests inside session.

Other than that! Pretty zippy! Will try out running VirtualBox VMs that have Docker container instances and see how that holds up!

Ordered on April 3, arrived just now (to northern Germany)!

If you happen to have “signature on file”, this would be why it as left unsigned for. Do you happen to know if this is the case?

1 Like

Upgraded my laptop last night, and then promptly installed my old 11th gen board into my waiting CoolerMaster case. Both machines working flawlessly. Super happy with the upgrade! In particular, while my laptop was already reasonably fast (now faster!) I’m actually most satisfied with the encased 11th gen board – it replaced my old HTPC machine from 2015. That thing flies now, and has no problem playing high bitrate H265 videos!

The only thing that I wasn’t expecting was the boot time of the new motherboard on the first boot. I had forgotten about the memory training and was briefly concerned when I was staring at a black screen for 2-3 minutes.

1 Like

received mine yesterday - spent today (public holiday in germany) setting up ubuntu 23.10 - and iam super happy with the Framework 13 so far :slight_smile: keep up the good work Framework! :heart:

1 Like

Yes, I do have my signature on file, but that wasn’t the issue. I was expecting FedEx to send a notification when the item was out for delivery, and that didn’t happen. Everything worked out though!

Last night, I tried to run a VirtualBox VM (Lubuntu guest) with the UEFI secure boot still enabled.
I had to setup a MOK signing key, enroll it in the UEFI firmware and then sign the modules. The annoying thing is that every boot, I need to re-sign the VirtualBox modules for the VM to start!

1 Like

Received mine last Tuesday a day early, installed that day, no issues and everything’s a-okay. Just posting pics of the package since part of the outside was torn (but the inside box was perfectly fine).

1 Like

It arrived! Package was in the same condition as the post above, but the mainboard was fine.

I’m so used to noisy Framework fans, this board is so quiet it’s almost creepy. I can get the fans to spin up, but I have to try pretty hard.

1 Like

got my Framework on Monday, and i got a strange behavior. My display showing something that looks like image noise on black and dark backrounds. especially when im charging my Laptop. I will try tomorrow to reseat the display connector, hopefully it will help.
Everything else is great. Got 32 GB Kingston Fury 5600 Mhz CL40 and memory training took under a minute.


Technically speaking I don’t have my signature on file (from what I have checked with my online Fedex account). I had mine dropped off at the door without any notification from the driver. FedEx email came 2 minutes after the delivery.

I think there is a level of detail that FedEx cannot necessary manage at every level of the company (on its delivery).

FedEx cannot always force the drivers to walk packages to the front door. Technically the driver can leave the package at the garage door, the sidewalk, etc

FedEx does not even check that the picture captured by the drive is fussy (vs a clear high quality photo).

I would suggest the best way to deal with FedEx (or any delivery company) is watch for the shipment delivery notifications; use a camera or doorbell camera; and be aware of weather conditions.

It is hit or miss to get a good driver that will take the care to make sure packages are secure.

Mine had a similar tear in the brown packaging, but the box in the photo i linked was very similar to mine.

I was planning to assembly my until this afternoon/this evening. I know I received it Monday, but had not had a free moment (from daily life activities) to upgrade to this new mainboard.

I just received the laptop but the display is defective!

I did get my unit assembled…

I took the Intel Gen 11th mainboard and wifi card out. Transplant those components with a new audio port and wifi antenna to the cooler master.

The unit booted up. I stopped because I wanted to focus on the AMD mainboard.

I did get the mainboard, wifi, new DDR memory, and new NVMe installed. The unit did power on, but I got a error. I was able to check the BIOS and it recognized all the RAM and the mainboard.

I was using an USB stick that uses ventoy – that could have been an issue. I am not changing to a simple USB A boot stick with Fedora Workstation Live. I am using 38 as I want to wait for 39 when it is officially released.

AMD batch 3 arrived today, now working with Manjaro Linux KDE , kernel 6.6,
64G GSkill Ripjaws DDR5-5600, and Samsung 990 2T. Everything I’ve tested works so far,including fingerprint reader, wifi, sound, Bluetooth.
It arrived with BIOS 3.02, but I used the USB upgrade to 3.03.

Installation needed turning off TPM in the bios.
Fingerprint reader needed extra drivers described here and Arch Linux wikis.
RAM is running at claimed speed, at least in BIOS.

Sweet machine!