AMD Batch 4 Guild

After 6h of installing SW and testing, very happy! Using Samsung 990 Pro SSD with 2TB and 32GB RAM.

I installed Ubuntu 22.04, and it went very smooth. I also installed 80% of my software already, I can read emails, use vscode and compile my Julia programs.

My largest compilation now takes 6 min, which is fine, still need to compare it
correctly with my old laptop.

A simulation run with 289 wind turbine simulations in parallel takes about 27 seconds, which is perfect. The laptop reaches about 80% of the performance of my Ryzen 7950x based desktop, which is perfect, taking into account the TDP of 30W compared to 170W for the desktop.

Battery life looks also good. Now in a café, laptop runs at 5.4W with vscode IDE running, firefox open, WiFi active… This would give me more than 10h battery life, just perfect. Using “Balanced” power mode…

The screen is also very nice. Put it on 150% fractional scaling.


Is this something that could be tested with a multimeter before connecting it? Since this has happened to multiple users now, I’m wondering if that might help spot the problem before it short-circuits.


Really depends on the fault, I guess you could continuity test but i’m unsure if it would pick it up or not, worth a shot though I guess.

Update: Now that support is back i’m waiting on them to get back to me and see how it goes.
What’s really interesting is how the short may have killed my display too, with posts reporting that it cant be reached.


Batch 4 delivered in 6 days to myself yesterday in Australia (NSW) after taking a trip halfway around SE Asia. Assembly was pretty straight forward no hiccups here. I opted for a single 16gb stick of RAM from Framework (to allow for expansion to 32gb should I need it) and the 1TB SN770 NVME SSD also. Absolutely loved the packaging it all came in - sustainable and excellent design and the laptop itself is a thing of beauty in person.

I installed Ubuntu 23.10 last night, no issues to report except I had to use a Framework guide to get the finger print reader to work. Running the mainline kernel from Ubuntu with no issues. Is there much benefit to the Framework Kernel? If so, I can reinstall 22.04 LTS and then upgrade my installation. Mine came shipped with the updated BIOS out of the box.


My first impression is great.

I’ve had no problems with the assembly, everything sort off fitted together after a little careful nudging in the corner of the powerbutton.

Installation of fedora 39 from live usb image went smoothly. I only had to apply the fingerprint reader firmware to get that part working.

I played some Minecraft and have not experienced any graphics artifacts.

Some specs:

  • AMD 7840
  • 64 Gb (2x32)
  • 1T SN850X (btrfs)
  • active cards:
    • usb-c (power, empty)
    • usb-a (mouse)
    • Ethernet
  • keyboard: English International
1 Like

Received mine today!
Ryzen 5, 2x8 GB DDR5, 500 GB SSD.

Was afraid I had a defect at first because it wouldn’t start, but I didn’t socket the RAM properly. Took me around 20 minutes to set it up to boot and I successfully installed Linux Mint Debian Edition on it as I’ve been using this system for a while and no issues so far.

I only wish the scale factor could be set to 150%. 200% feels like I’m on a 640x480 screen and 100% is a bit smallm though I got used to it.

1 Like

Well, I set mine to 150%. Using Ubuntu 22.04. Should also be possible with Mint somehow.

1 Like

I believe this is what you want



All right, thanks, I will have a look!

I think I already did that on my previous system and I didn’t remember I had to dig a bit deeper. I’m also unable to push 1080p on my external screen when plugged on HDMI (stuck on 1280x800). Managed to fix the sleep issue too by upgrading the drivers (firmware-amd-graphics from Sid instead of Bookworm Stable).

I’ll check it out later when I come back, I’m still going through all the custom settings I had and I’ll figure it out.

1 Like

Fedora 39 doesn’t offer fractional scaling (in the default Gnome desktop environment out of the box, at least) and 125% or 150% is sorely needed. I’m using the Win11 half of my dual boot for the most part ATM.

1 Like

Have you applied the setting from this guide? This enables fractional scaling in F39, including 125% and 150% settings. It’s working well for me. :slightly_smiling_face:


I thought I’d read somewhere it was removed in 39 because it caused some apps to appear blurry in Wayland, but I’ll give it a shot.

1 Like

All right. Now 1920x1080 is available!
Chose 150% scaling. Loving the 3:2 display, it’s really insane how useful it is for web browsing and coding.


I set it up w/ the fractional scaling per the guide. I’ll see how it goes. I’m working with external displays at the moment which are fine at normal 100% scaling, but I’ll play around on the integrated screen at home and see how the scaling holds up.

1 Like

I know that the fractional scaling has been associated with a greater chance of graphical corruption in other threads here, but I haven’t seen that… yet.


Received my DIY Ryzen 5 Framework yesterday. I took my sweet time setting it up - what a great experience it was! It really is an amazing piece of technology. Now running it with WD Black SN770 1TB and 16GB RAM (2x Kingston ValueRAM KVR56S46BS6-8) which, according to the BIOS, runs perfectly fine at 5600MT/s. It’s such a big step up coming from my 11 y/o Zenbook with a 3rd gen Intel CPU :smiley:. My aim is to use my Framework for at least 10 years. The whole OOTB experience with Fedora is also superb! The 3:2 screen ratio is such a pleasure to work with. I’m really happy with it! Definitely worth the 5 month wait!


Upgrade kit finally arrived. Upgrade went smoothly and it’s all in good working order as far as I can tell. None of the magic smoke escaped and none of the data cables got crispy.

Shipped with the 3.02 firmware, so I had to update it myself. The hardest part was figuring out how to fix my bootloader afterwards. :smiley: (Tip: you don’t have to boot off external media, you can get into your existing install by explicitly telling the laptop to boot a specific EFI, even if it won’t automatically boot it until you’ve reinstalled and reconfigured GRUB, or at least that worked for me.)

All the other updates I made (matte screen, stiffer hinges, bigger battery) went really well as well. The biggest disappointment is the ridiculous whistling from the CoolerMaster case I’ve got my old mainboard installed in. Gonna have to figure out how to modify that case to fix that later.


Some benchmark results:

Testcase a: Heavy compilation, about 50% multi-threaded
Testcase b: Startup time of a Julia program, single threaded

Testcase c) OpenGL performance
vblank_mode=0 ./glxspheres
framework: 3700 frames/s
old laptop: 510 frames/s
desktop: 6400 frames/s

Testcase d)
Heavily parallel simulation.

Relative to Ryzen 7950X desktop
a. 75%
b. 88%
c. 58%
d. 78%

Average CPU performance: 80.3 %
GPU performance: 57.8 %

Relative to old laptop, i7-10510u
a. 184%
b. 138%
c. 725%
d. 287%

Average CPU performance: 203%
GPU performance: 725%

Two times the CPU performance compared to my old laptop,
about 80% of the performance of my desktop.

Seven times the GPU performance compared to my old laptop
still 58% of the GPU performance of my desktop.

Very happy overall.

For a crisp browser experience with fractional scaling I had to add the line


to the file /etc/environment.


Soo… attempting to show off the laptop to my co-workers resulted a strange sequence of events.
All was going great until, I connected it to one of those curved high resolution screens with build-in ethernet/camera/speakers.

  • Plugging it into usb-c top left it switched to using the external monitor only at a very low resolution (charging started, I did not check to see if any of the peripherals were recognized)
  • At this time I believe the framework keyboard and track-pad stopped responding. so I connected an apple keyboard using a usb-c (lower-right) to lightning cable. and a mouse on usb-a (lower-left) and could continue using the system.
  • Then plugged it into the usb-c top-right and the screen used full resolution.
  • At full resolution I thought it be sweet to show off some Minecraft graphics and speed. The game loaded perfectly and started generating terrain of a new off-line world.
  • As soon as I started flying around the epileptic white bars started to interfere with the graphics.
  • Using F3 Minecraft showed me it was running low on memory, so I assigned more and restarted to no avail.
  • At this point the laptop decided to go into sleep mode every couple of seconds (now the fingerprint module really helped to get back into the system quickly). changing the power-saving mode made no difference.
  • As the systems behaviour (also white bars outside of Minecraft and non-responsive keyboard/track-pad and the going to sleep) I decided to reboot the system.
  • After rebooting the keyboard/track-pad was still not responding.
  • Now I decided the demo was over and I just completely shut it down and put it away.

Back at home I booted up and all appears to be fine again (keyboard/trackpad are functional again… no more sudden sleeping)

As far as I can find… most of the above is already known by the community/framework and is being worked on to resolve in various other threads.

Only the falling asleep after a couple of seconds I have not found a precedent for.


1 Like

Received my order last week and the screen is excellent - loving the 3:2 ratio.

Anyone have slight touchpad issues?

This area on the left seems to be double clicking when clicked once (similar to a camera shutter button having a two stage press).

The right click does not have this issues.

I looked up the touchpad FAQ and it does not seem to be rubbing.