[Announcement] Linux on your Framework Laptop 13 (AMD Ryzen 7040 Series)

@Gabriel_Esposito and @bitsandhops there is a fix found by one of the people on the Framework discord linux channel for the sway crashes.
You need to set a Linux Kernel option: amdgpu.sg_display=0
Here is the Arch Wiki for that: AMDGPU - ArchWiki


I’ve had nothing but problems with a fresh install of Fedora 39 KDE spin since I received my AMD board last week, crashes that completely stop the DE from running and cannot access any TTY to restart the session.

Tried the suggested kernel options and looked around at what people are saying but not seeing this mentioned anywhere so dropping it here to see if anyone else is getting this.

Gonna install the official gnome version today but I personally hate gnome’s look and feel, but it might help me not want to leave the laptop turned off.


Well, Matt said multiple times in this topic and others about the supported flavor of Fedora being only the Gnome version at this time. But don’t panic ! Once installed, you can install KDE on top of the Gnome DE, which seems to be the go-to path for the all the KDE lovers out there.
For the how-to, maybe this article can help you out:

Have fun !

1 Like

Given it an install and weirdly this official spin doesn’t recognise displays plugged into my dock which the KDE spin did. CalDigit TB4 with USB-C monitor and DisplayPort monitors plugged into it. Definitely authorised as other devices are working through it and boltctl reflects that.

1 Like

I wonder if you’re hitting the same behavior I just filed a KDE bug for: losing display signal to external monitors connected through a dock. There’s a detailed description in my bug report but if you’re hitting the same thing, you should get display if you switch your session from Wayland to x11.

Since f38, I think the spin defaults to Wayland for sddm as well which causes immediate display loss as the login screen loads but if you use gdm it will bypass that.

If it is the same thing, it doesn’t seem to be specific to framework but rather is a more general AMD problem since I could reproduce on a non framework laptop.


Edit: editing for clarity, if it is the same problem, just logging out of Wayland and into x11 is not enough; once display output dies this way it doesn’t come back without a reboot so you have to get to x11 plasma session without touching Wayland and plasma/sddm together.

The GPU drivers (or firmware) are definitely not ready for prime time yet. A lot of what I do is GPU accelerated, and even in vanilla Gnome I’ve been getting regular (compositor?) crashes and a lot of mesa errors in my logs. Maybe that 3.03 firmware update will help, or maybe we need to wait for mesa updates. I dunno, it’s too bad, but to be honest I knew I was getting myself into early adopter territory. Hope you can find a workaround for your issues. Seems like the hardware will be fantastic with the software catches up.

1 Like

Oh how weird, when I used the KDE spin I believe I was getting monitor outputs but the crashes would occur and would affect all displays including the internal monitor while your issue sounds like it doesn’t affect the internal display. Do you get DE crashes or freezing when using the laptop stand-alone?

Wholeheartedly agree, for the moment I’ve installed my previous generation board which I kept close in case this happened and will revisit this once the BIOS is out and sentiment changes on its stability.

1 Like

No, the internal display is unaffected, and I get no crashing, but I’m not using the KDE spin. I installed the standard gnome workstation version then installed KDE packages on top of that.

When you said you were losing display to external monitors connected through a dock I thought you might be hitting my issue, but if it affects your internal display you’re hitting something different.

The AMD BIOS 3.03 is available now!


As @junaruga has been awesome enough to point out, a beta release of 3.03 BIOS is out - you will absolutely want to upgrade to it.


FYI for anyone who is compiling their own kernel: with the AMD mainboard, for your touchpad to work, you will need to have CONFIG_PINCTRL_AMD enabled (along with CONFIG_I2C_HID_ACPI as mentioned on the Gentoo wiki page). I had to do a bit of guesswork to see what might be missing from my kernel config.


Fedora Official spin with the firmware update has resolved the issues I was having from previous posts, yet to try KDE. Dock worked straight away with my multi-monitor setup on boot and didn’t die when I unplugged it while logged in.

This is with gnome, right? I’d be very interested in whether you get display output through the dock with KDE + Wayland session.

Works great with sway. I have an external monitor directly connected via usb-c and a second connected through a usb-c hub connected to hdmi. All three monitors work well, no errors, stuttering or other oddities we have been seeing with the earlier firmware.

I think what I have is specific to KDE/sddm, Wayland, docks, and late gen AMD igpus.

Anything outside of that specific combination seems to work fine.

Good advice. Winblows is even known to change linux partition guids because reasons…

Yet another reason I kept the dual boot separate, using an expansion card for Ubuntu Linux.

Still waiting for my Ryzen laptop (batch 4). Question: How long does it take after power on until you get a login screen using Ubuntu 22.04 ?

I see currently that the APU has been given 512MB of dedicated VRAM. Is there any option in the BIOS to increase that amount? I think that would fix the display flickering issues (or at least delay it for a long while).

You can set the UMA buffer to UMA_GAME_OPTIMIZED which gives a larger memory block to the GPU. I doubt this would fix or delay display flickering but worth a try if you wish to.