[Announcement] Linux on your Framework Laptop 13 (AMD Ryzen 7040 Series)


Running an update with fwupd and making sure all your packages are updated (for that day, meaning dnf update every day until the release settles down a bit). There should be no hang, Workstation/GNOME.


@Gabriel_Esposito I am having the same experience as you with swayfx on Arch.

@Matt_Hartley I’ve been running ArcoLinux since my AMD framework came in. Aside from the FW upgrade on the fingerprint reader, everything worked out of the box. I’ve used both the stock kernel and xanmod (both 6.5.7-1).

Used Arcolinux L - Downloads | ArcoLinux

Hrm. Just got mine, and I don’t see anyone else having so many issues on the Fedora 39 Beta. It installed fine for me, but…

  • The GPU seems to not work at all. I just get llvmpipe/lavapipe and most GPU accelerated stuff just fails to start. This is kind of a dealbreaker as I can’t run any of my tools. :frowning:
  • BIOS doesn’t seem to have a setting for making F-keys the default. This is a mild dealbreaker as I use a ton of tools that use F-keys constantly.
  • Doesn’t go to sleep when I close the lid.
  • Sleeps from the Gnome menu, but I can’t get it to wake back up.
  • Can’t adjust screen brightness with the keys (fn or not), and the default is really dim.
  • Fingerprint reader didn’t work out of the box. I updated firmware and now recognizes it, but it failed to add a single print after 5 minutes of trying. Dunno… never had one of those before, and honestly not sure I care?

Is it just working fine for everybode else?

edit: Ooooh. I think I know what happened. I couldn’t get the F39 installer to start GDM, it would just hang on a blinking cursor. So I used safe graphics mode… and apparently that installs the GRUB bootloader set up that way. I tried booting the installer again and it works now for some reason. Surely I could have fixed the bootloader config… but it was easier to just reinstall. I didn’t really have anything set up anyway.

edit 2: Yup, Reinstalling sans the “safe graphics” mode in the installer has fixed the GPU and sleep issues. Derp. I also tried the fingerprint reader again, and apparently you just need to stick your finger on the sensor like 20 times to train it? I guess it’s a Gnome issue, but that was really non-obvious. Still not quite perfect, but it mostly works now.

1 Like
  • You may need to log out then back in. Make sure you are updated completely after install, there are a number of packages that are updated since initial install.
  • FN+Esc will allow you to toggle FnLock.
  • There is a bunch of suspend issues being looked at with newer firmware that hasn’t been released to the public yet.
  • For the screen brightness, check to make sure you are updated to the latest, fiddle with the FnLock settings before using. Make sure you are on the latest kernel.
  • The main thing is making sure you are updated and running linux kernel 6.5.7. You may need to update the default kernel to run.

It’s still a bit buggy, if you look at all the different threads out there, it seems we are waiting on a newer firmware version that’s not publicly available that will fix our woes.

Nah, I’ve triple checked for updates, rebooted many times at this point, etc. Kernel is indeed 6.5.7-300.fc39.x86_64. GPU just isn’t having it. Same for the screen brightness.

fn-lock: Oooooh. I guess I’ve seen that on other people’s laptops and always wondered what it was. Apple has a OS setting and my last laptop had a BIOS setting for it. Well, that’s one issue solved. I don’t suppose there is a way to make that permanent?

1 Like

I’m not in front of my framework at the moment, but I feel like the FnLock setting was persistent across power cycles.

1 Like

I haven’t gotten my AMD FW 13 yet (Batch 5) but I’m wondering if I can dual-boot Linux and Windows? I need Windows for my current job, but I want to experiment with Linux, and I was hoping I could boot Windows on my main SSD, and boot Linux on the 250Gb expansion card. Does that sound like something I could do, and any advice on executing it? Thanks!

Yes, dual booting is possible.

Personal opinion, but keeping the operating systems on separate storage devices generally minimizes the number of times things break (like you suggested, Windows on the internal drive, Linux on an expansion card)

1 Like

That! I’ve watched plenty of folks struggle with keeping 2 OSes on the same disk. (Windows Update doesn’t seem to play nice) I’ve always kept them on separate disks, and haven’t had any issues.

I have them on the same internal disk. That’s why I went with a 2tb ssd

Yeah, Windows update will typically destroy your bootloader if you’re not using the Windows bootloader. Keeping them separate and just using GRUB is usually a lot more reliable.

I couldn’t edit this thread’s first comment, regardless of the “a Community wiki post (here)” is mentioned. Could you change this thread to the wiki?

1 Like




1 Like

@Gabriel_Esposito and @bitsandhops there is a fix found by one of the people on the Framework discord linux channel for the sway crashes.
You need to set a Linux Kernel option: amdgpu.sg_display=0
Here is the Arch Wiki for that: AMDGPU - ArchWiki


I’ve had nothing but problems with a fresh install of Fedora 39 KDE spin since I received my AMD board last week, crashes that completely stop the DE from running and cannot access any TTY to restart the session.

Tried the suggested kernel options and looked around at what people are saying but not seeing this mentioned anywhere so dropping it here to see if anyone else is getting this.

Gonna install the official gnome version today but I personally hate gnome’s look and feel, but it might help me not want to leave the laptop turned off.


Well, Matt said multiple times in this topic and others about the supported flavor of Fedora being only the Gnome version at this time. But don’t panic ! Once installed, you can install KDE on top of the Gnome DE, which seems to be the go-to path for the all the KDE lovers out there.
For the how-to, maybe this article can help you out:

Have fun !

1 Like

Given it an install and weirdly this official spin doesn’t recognise displays plugged into my dock which the KDE spin did. CalDigit TB4 with USB-C monitor and DisplayPort monitors plugged into it. Definitely authorised as other devices are working through it and boltctl reflects that.

1 Like

I wonder if you’re hitting the same behavior I just filed a KDE bug for: losing display signal to external monitors connected through a dock. There’s a detailed description in my bug report but if you’re hitting the same thing, you should get display if you switch your session from Wayland to x11.

Since f38, I think the spin defaults to Wayland for sddm as well which causes immediate display loss as the login screen loads but if you use gdm it will bypass that.

If it is the same thing, it doesn’t seem to be specific to framework but rather is a more general AMD problem since I could reproduce on a non framework laptop.


Edit: editing for clarity, if it is the same problem, just logging out of Wayland and into x11 is not enough; once display output dies this way it doesn’t come back without a reboot so you have to get to x11 plasma session without touching Wayland and plasma/sddm together.