Arch Linux on the Framework Laptop 16

This is a wiki post, so feel free to edit it with instructions on installing and using Arch!

(Matt’s note: This is a COMMUNITY SUPPORT Linux distro. All support for this distro will be from the Framework and Arch communities. Ticketed troubleshooting will continue to be done using our officially tested/supported distros, Ubuntu LTS and Fedora.)

Enabling full speaker performance

To enable full speaker performance in Linux, you’ll need to toggle the Linux Audio Compatibility setting in BIOS. You can find steps for that here: Ubuntu 22.04 LTS Installation on the Framework Laptop 16 - Framework Guides

See also:

18 Likes

This’ll be my daily and I run Arch, so I’m stoked. I’ll be sure to contribute to the archwiki if there’s anything I can add, when I get my Batch 3 device.

2 Likes

Same.
I’m commenting so I see updates to this thread.

1 Like

I’ve been running Arch (and working on it) for about a day and a half. It has been a very seamless experience so far! Bluetooth, web cam, wifi, microphone and my trackpad config from my FW13 worked as-is. I don’t have a GPU so I haven’t tested that. And I don’t use the fingerprint scanner.

I did run into a hiccup today where I resumed my laptop from suspend and I couldn’t get wifi working. I have suspended-and-resumed with wifi working several times before that. A reboot fixed that. So I’ll be on the look-out for that happening again.

Also, as with the FW13, you’ll want acpilight instead of xbacklight to configure screen brightness. Note that acpilight provides an xbacklight command:

[andrew@bart ~]$ pacman -Ql acpilight | rg bin
acpilight /usr/bin/
acpilight /usr/bin/xbacklight

Also, if you use Firefox, don’t forget to set MOZ_USE_XINPUT2=1 to get a much nicer two-finger-scrolling experience. It’s much smoother.

7 Likes

Second this. My main OS will be Arch Linux for both work and play. I hope to be able to contribute to the wiki.

This would be amazing. Yes, we will be depending on this as this happens (once the page is updated and goes live) - it will point to the Arch Wiki for the AMD Ryzen 16 and 13.

2 Likes

I have this issue inconsistently on my install as well. Doesn’t matter if the ssd is installed in my Razer Blade or my Thinkpad T470. I wouldn’t assume it’s a Framework issue at this time. Most of the time it doesn’t happen, but sometimes the machine spirit chooses to express its malcontent with its neighbors.

I don’t think I’ve ever had the issue with my FW13. :slight_smile:

does anyone have udev rules for interacting with the led matrix? i was able to use the qmk rules in order to get access to the keyboard and numpad

So far, so good. I was able to install Hyperland (Wayland wm).

The only gotcha is that I did enable “game” mode in the bios setting for embedded GPU. I’m using two 4K monitors, and default 0.5GB VRAM is not enough for that :sweat_smile:

P.S. I did not encounter any framework-specific issues, only Wayland’s issues :melting_face:

Update: This is an issue with Hyperland. It is working fine using Sway.

Did anyone experience video stuttering issues while using Firefox on an integrated GPU?

I’m using Wayland session with a dual 4K monitor setup. The Integrated GPU has 4GB of memory. My total system memory is 64GB.

Firefox commands (integrated GPU):

MOZ_ENABLE_WAYLAND=1 MOZ_DRM_DEVICE=/dev/dri/renderD128 firefox

Firefox command (7700S):

MOZ_ENABLE_WAYLAND=1 MOZ_DRM_DEVICE=/dev/dri/renderD129 firefox

Wanted to first say, welcome Arch users!

Please, please do what you can to help the Arch community by populating the wiki (using Arch contribution rules of course).

If you have a useful tip, please see about getting it shared there as well,. :slight_smile:

4 Likes

You shouldn’t need this anymore. Wayland was enabled by default in Firefox as of a few weeks or so ago.

1 Like

The Firefox did not use hardware acceleration otherwise :frowning: But it is an issue with Hyperland.

I switched to “sway”, and it works fine. The current version of Hyperland has performance issues. My GPU load is 25% idle, causing Framework to run with 50-55C temps :melting_face: And the steam client doesn’t like it (too many bugs and glitches)

Maybe related to: GPU spikes after enable/disable `mouse_move_enables_dpms` · Issue #4670 · hyprwm/Hyprland · GitHub

P.S. The sway is stable so far.