[Arch] Wakeup from systemd hibernate spamming empty lines in shell

There was an update (linux, systemd, idk) over the last few weeks that’s introduced some strange behavior when waking from hibernation. I manually start hibernation with ‘systemctl hibernate’, so I’m in the shell when the system shuts down. When it wakes, it starts spamming enter into the terminal (with nothing typed, so it just makes new lines). This is just an annoyance, it’s not a huge issue, but I was wondering if anyone else has encountered this. I tried to do some digging but I can’t find any other reports of this behavior.

I’m running Arch with GNOME 42 btw

I’m also using arch and I can’t reproduce this behavior.



1 Like

I found what was causing it. When I would submit the hibernate command with enter, it would wake up still thinking I was pressing enter until I sent another keyboard input. To prevent this, I added a 1 second delay to my hibernation alias so that I wouldn’t be pressing enter when it saved the machine state. This fixed it completely.

I didn’t think hibernation would save the state of the keyboard inputs, and I’m guessing that it really isn’t supposed to since no one else is reporting this. Perhaps it is some strange GNOME behavior.