Artix Linux wifi install issues [SOLVED]

I’ve been trying to get an artix linux wifi install working on this computer.

Using wifi because computer doesnt have an ethernet port and I dont have a dongle at this point to get ethernet.

I’m currently using the connmanctl to try and initiate a connection. However, every time I try and connect to a network I get the error “Not registered”. This error is not mentioned in any of the documentation for this and the register command does not have the correct inputs for this type of service as far as I know.

Thanks for the advice.

Admittedly, I’ve never tried Artix before, but I have used Arch (though not with connman). I did a quick search and this turned up on the Arch forums. Maybe give this a try?

Edit: looks like you do specifically need to use the command " agent on" when working with a protected network vs open.

Interesting thanks for the info.

It seems that when entering that command I get:

“Error: Not supported in non-interactive mode”

This seems to be a consequence of how it is installed on the artix ISO.

I’m tempted then to just unsecure my network for a little bit to complete this

Shouldn’t need to. Just runn the command “connmanctl” to enter interactive mode. Follow the wiki here (edit: included link to protected setup). Report back and let us know if it works!

1 Like

Amazing! It worked.

This saved me a substantial amount of time and money.

Hopefully this helps someone else in the future.

1 Like