Battery life issues?

Hi there,

I’ve been using my new 12th gen DIY Framework for about 6 weeks now and it’s been a pleasant ride so far - there’s just one problem: the rapidly decreasing battery life. I’ve tried to find any resource available regarding battery life problems with the 12th gen Framework but could only find people with the same problem - nothing worked so far to fix this.

Quick facts:
Windows 11 Pro
Intel 12th gen i5-1240p
2x USB-C, 1x HDMI, 1x USB-A
Newly bought in February

I’m working a lot “on the go” without any power outlet nearby, so battery life is a more serious concern for me. Battery life in the beginning was pretty stable and about as much as you would read about in any given review: about 6-8 hours of Wi-Fi browser work, maybe some video streaming on the side or occasionally some CAD. The last few days the battery didn’t even manage to last 3 hours on a 100% charge. This lead me to believe I somehow messed up some of the Windows 11 energy settings - so I reset the whole system and have been using a clean Windows 11 installation since yesterday.

Now the system doesn’t seem to draw that much power anymore, but it’s nowhere near the ~7 hours of work I had in the beginning. Today it went from 80% to 5% in about 4 hours of Wi-Fi browsing with max battery saving options + “Maximum Processor State” set to 30% on battery in Windows settings + screen to about 15% brightness.

Here the battery stats pulled from HWINFO:

I’m very surprised that there’s a wear level of 12,6% with 19 cycles… ?

//Edit: stats after the charging process from above reached 100%:

That doesn’t seem normal… ? //

Is my battery somewhat faulty?

Not sure what to do now, next step would be directly contacting support. Any suggestions?

Thanks in advance!

1 Like

I’ve asked that your post be moved maybe

It took a long time for my wear to stabilise after maybe 40 cycles

Wow that battery wear looks very bad for 19 cycles, could be defective. Please do update what support say, my wear is 12.3% with 110 reported cycles and this is the first time this topic has been brought up so knowing FW position on battery wear and warranty would be good to know.

Do you mean this is not the first time? as in my link above . . .

No, I think that thread is asking users to report their battery health and this topic is about a potentially defective battery/issues with an essentially new battery degrading far quicker than would be expected.

Yes I was just wondering if it could be mitigated by running a full battery discharge and recharge a few times as by doing that for a year over 62 cycles my reported wear consistently lowers, sure that can go on forever but it shows one of two things
the battery capacity does improve with certain charging routines
the battery reporting is very rough and not reliable

of course it could be a duff battery, but if it had a ‘full’ capacity then only by thorough checking, as I have done, can any realistic ideas of what could be amiss assessed.

A few readings in the first few months with a couple of dozen cycles doesn’t provide much info.


Hi there, thanks for linking your thorough topic - I actually read through it before posting my issue. Some people in there stated a similar battery situation but without any tangible hints on what could be done about it.

Thanks for suggesting running a few full discharge/recharge cycles before jumping to conclusion - I’m on that right now, I’m using different chargers as well for good measure. Will report back if anything changes / if support was able to help me in some way.


Have a look at my detailed data, the following was for Feb 23 the 12th month of ownership. It shows what happens exactly when I do a full charge. You can see all previous data from links therein.


I would expect a full cycle to improve the accuracy of the rated capacity, as I understand it batteries capacities are calculated based on previous charge/discharges profiles so are always estimates plus being chemical reactions are more “analogue” than “digital” in the their nature. In David’s and my case full cycles showed a capacity drop rather than increased suggesting it was overestimating capacity before. That in itself is not totally unusual but in my experience it is unusual to see such a large drop in capacity unless the battery has been stressed in some way e.g. high temperatures, especially during charging, bad charging equipment or a bad battery.

Here I include a history of my Macbook’s battery than spent most of it’s life charging up to 100%/sitting charged before I discovered a charge limiting app.

You can see there is variance but generally quite a stable decline and a far better ageing profile.

At the end of 2021 I finally replaced my defective phone battery and you can see the battery initially “gains capacity” (accuracy improving with cycles, being broken in) and a more “normal” wear and tear on the new battery. A side note while plugged to the laptop to capturing the data my capacity “increased” to 95.9%.

My old bad battery for comparison I guess (it was defective):

1 Like

Little update on the situation.
Support asked me to try several things, I think routine tests most of them.

While logging system behaviour I noticed something strange about one connected expansion card. I occasionally work with RasPis at the moment so I use the Micro SD card expansion module to reflash images. Usually I swap it out for my other USB C expansion card once I’m finished - but this time I forgot.

I used powercfg -energy to observe system behaviour in different scenarios and I always got a certain USB device (expansion card) somehow blocking Windows from using different CPU power states, thus always (seemingly) running full power. I should add my idle temps were around 48°C which I thought was normal for Framework 12th gen.
Unfortunately I didn’t capture the exact error so I can’t cite it properly. But after removing the SD card expansion (and all the others for good measure), updating the BIOS to the latest beta build (I was holding off for now, support asked me to do it though) and reconnecting everything one by one (2x USB-x, 1x HDMI, 1x USB-A) the error is gone and battery life / CPU behaviour seem to be back to normal. Idle temps are 35-40°C now, same external conditions.

My battery readings have normalized as well after some 100% - 0% cycles, so that seemed to be rather usual behaviour as @amoun mentioned:

I had the Framework running through one cycle and it made it to about 7-8 hours of random browser tasks (browsing, streaming, some benchmarks). Just to recall: it was 2-3 hours max before (3-4 hours on battery saver mode and very low brightness).

Guess I have to get used to the expansion modules throwing random exceptions from time to time, lesson learned. Can’t really tell in the end what exactly fixed my issue - it was a kind of “turn everything off, disconnect everything and turn it on again” situation. Not sure if the BIOS update actually did anything as the error was gone before updating it. Maybe it helps to prevent that from happening again.

I’ll observe battery life for the rest of the week before ultimately calling the issue fixed though. Thanks for helping me sorting this out!


You should note that any expansion other than type C will increase power consumption. See
here for more information.

Really interesting to see the large change in wear reported by the battery, I wonder if EC needed a “reset” to read the battery data more accurately.

Thanks for the updates!

1 Like