Battery no longer visible to ACPI

I’ve been running Ubuntu on an 11-gen DIY laptop for close to a year now and it’s been working pretty well. Today I swapped in a new drive and installed Arch, which also seemed to be going fine. As I was getting a desktop set up, I noticed that I had no battery status. /sys/class/power_supply/ contains ACAD, but no BAT0.

I figured I was missing a kernel module, so I swapped the Ubuntu drive back in, but it no longer had battery status either. Lacking other ideas, I opened the case again and carefully unplugged and re-seated the battery cable (it looked fine). I’m on firmware 3.07 and I see there’s a 3.10, so I downloaded that to a USB stick and tried to install it. It says it can’t install because there’s no battery. The battery still delivers power (for now), just not ACPI information.

So this sure feels like a hardware or firmware issue. The fact that I just opened the case is pretty damning on the surface, although swapping the hard drive was a trivial operation with no mishaps.

Anything else I could investigate?


Updated: although attaching power causes the little light to illuminate, the machine doesn’t seem to draw AC power for running or charging. The battery drained one last time and it’s now lifeless.

Hi @Peter_Sagerson,

The fact that this is happening across multiple distros and even in gives me pause.

I’m Linux support, so bear with me here. However since there is a Linux element to this, as you’ve tested multiple distros - I can offer the following thoughts.

  • Boot holding F2, once in BIOS, arrow left to Advanced, then look at what the Battery Charge Limit is showing. Take a smart phone picture of what is shown if possible.
  • With this information, please reach out to support directly. Mention you’ve tested this with multiple distributions and the Linux Lead believes this could either be battery memory or a well timed battery issue. Please ask support to loop in Matt Hartley directly so I can make sure you’re taken care of with this.
  • While plugged into power and also still in BIOS, Advanced, the support team may end up having you use the Battery Disconnect option. Only do this if instructed to do so. They may have additional steps for you to take to see about testing the battery memory, etc.
1 Like

Thanks, Matt. I actually reached out to support over the weekend, since it seemed pretty unlikely that it was an OS-level issue. I don’t appear to have a ticket number or similar, so you may have to find it from your end.

The battery charge limit is 100. Few if any BIOS settings should be off their defaults.

In the meantime, I picked up an m.2 enclosure to run the system on some other hardware, so I’m up and running after a fashion.

Hi @Peter_Sagerson

I found the ticket, looks like we have your images sent and we will be getting back to you soon.

Okay, perfect. Appreciate the update.

Support diagnosed a faulty battery and generously sent a replacement. Unfortunately, the new one behaves the same as the original, so that was a miss. At this point, I’m leaning toward just ordering a main board upgrade kit, as there doesn’t seem to be anything else left.

In the meantime, I would be interested to see some dmesg output from a fully working system, if you (or anyone) would oblige.

# dmesg | grep ACPI
[    0.945852] pnp: PnP ACPI init
[    0.948507] pnp: PnP ACPI: found 6 devices
[    1.018610] ACPI: \_SB_.PR00: Found 3 idle states
[    1.019020] ACPI: AC: AC Adapter [ACAD] (on-line)
[    1.019071] ACPI: button: Lid Switch [LID0]
[    1.020963] ACPI: button: Power Button [PWRB]
[    1.023027] ACPI: thermal: Thermal Zone [TZ00] (29 C)
[    1.023264] ACPI: battery: Slot [BAT1] (battery absent)
[    1.024734] ACPI: bus type drm_connector registered
[    7.922446] ACPI: bus type thunderbolt registered
[    9.500576] ACPI: video: Video Device [GFX0] (multi-head: yes  rom: no  post: no)

Maybe it’s nothing, but I’m curious about the BAT1 with no BAT0.


12th gen here, dmesg looks a little different:

[    1.285050] pnp: PnP ACPI init
[    1.288568] pnp: PnP ACPI: found 8 devices
[    1.686989] ACPI: AC: AC Adapter [ACAD] (on-line)
[    1.687041] ACPI: button: Lid Switch [LID0]
[    1.687086] ACPI: button: Power Button [PWRB]
[    1.690370] ACPI: thermal: Thermal Zone [TZ00] (35 C)
[    1.690743] ACPI: thermal: Thermal Zone [TZ01] (25 C)
[    1.691123] ACPI: thermal: Thermal Zone [TZ02] (30 C)
[    1.691512] ACPI: thermal: Thermal Zone [TZ03] (24 C)
[    1.691874] ACPI: thermal: Thermal Zone [TZ04] (22 C)
[    1.694070] ACPI: battery: Slot [BAT1] (battery present)
[    1.928332] ACPI: bus type thunderbolt registered
[    1.935400] ACPI: bus type drm_connector registered
[    3.600101] ACPI: video: Video Device [GFX0] (multi-head: yes  rom: no  post: no)

It’s normal that there’s BAT0 and BAT1 - BAT0 seems to point to a non-existent battery but in the dmesg output, it looks like your BAT1 is not recognised.

Mine is a DIY i7-1165 with BIOS 3.10.

[    0.975867] pnp: PnP ACPI: found 6 devices
[    1.374991] ACPI: \_SB_.PR00: Found 3 idle states
[    1.375424] ACPI: AC: AC Adapter [ACAD] (on-line)
[    1.375475] ACPI: button: Lid Switch [LID0]
[    1.375523] ACPI: button: Power Button [PWRB]
[    1.377268] ACPI: thermal: Thermal Zone [TZ00] (49 C)
[    1.380063] ACPI: battery: Slot [BAT1] (battery present)
[    1.601253] ACPI: bus type thunderbolt registered
[    1.627726] ACPI: bus type drm_connector registered
[    3.282908] ACPI: video: Video Device [GFX0] (multi-head: yes  rom: no  post: no)

I recently read that BAT1 is the correct ID for the internal battery and that others show up for the batteries in peripherals like wireless keyboards and pointing devices. A forum search might find it quick.

Interesting, thanks. One minor mystery solved, at least.

1 Like