Bitlocker triggers when egpu is connected during boot

From googling it sounds like this could be an issue with the BIOS firmware? I saw some other makes of laptops which reported having this issue later had it fixed with bios updates.

1 Like

I was looking for this too and found this post on I applied it to my laptop and can now boot it with the egpu plugged in without BitLocker prompting me:

The solution involves disabling “PCR 2: Extended or pluggable executable code” in the “Configure TPM platform validation profile for native UEFI firmware configurations” setting in Group Policy.