Can't customize keyboard or LED matrix, on Linux mint

I don’t seem to be able to connect my keyboard or led matrix’s to any of the provided software via web or offline version. I’ve tried it on a fresh install of chrome, and I got the same results. I get the permission popup, select connect, and the device stays disconnected, but says “paired” in the perm window. Same results with external keyboard and LED matrix. they’re working fine, I just can’t customize them at all.

If anyone could help it would be greatly appreciated, I’m new to Linux and this is very confusing.

Which browser?
Do you see a yellow error symbol at the top within the webpage? The location it would be at is hidden by the popup in your screenshot.

It does require a browser with WebHID enabled. Here is a WebHID checker,
If the page says WebHID is supported, but you’re still seeing errors, then you may need the qmk udev rules.

Click to show

Place this file into /etc/udev/rules.d/.

Or do it by commadline

sudo cp 50-qmk.rules /etc/udev/rules.d/

Once added, run the following to reload your rules):

sudo udevadm control --reload-rules
sudo udevadm trigger

Then reopen your browser

1 Like

Pasted all of the commands and reloaded, and I’m getting the same results. The browser is a fresh install of google chrome that I’ve only used for VIA and the LED websites. It’s installed from the mint software manager.

also not getting any errors. I’ve seen the error tab in VIA before but it’s not even showing because there are 0 errors.

Also, The install of Mint is Linux Mint 21.3 Cinnamon and I installed it like two days ago, with very little changes, just the usual apps from the software manager like VS Code and Brave and such.

Oh, I’m sorry. I overlooked the address in your first screenshot!

Go to instead. Framework has a copy of Via there. The Framework keyboard definitions aren’t yet known to You would have to sideload the definitions in order to use that site.

1 Like

Hey man, I really appreciate it, that worked and I can finally change the layout of my board. Thank you!

I’m still unable to connect to the LEDs though, the same problem is happening where it says paired but it’s not actually connecting. Just to double check, this is the correct site, right?

It should be the right site. I’m afraid I haven’t explored much about the LED matrix.

1 Like