Can't get the right display size

I just got my laptop yesterday and everything is running great and I installed Ubuntu 21.04 without any issues. The problem that I’m having though is the render size. The resolution is set to the default 2256x1504, but at scaling of 200% everything is too big, at 100% it’s way too small, and fractional scaling makes everything noticeably blurry.

I’ve also tried adding custom resolutions but I couldn’t get one to work that looked nice.

Is there any way to update the display size and still have it be high quality?

This has been an issue for awhile now, you’ll need to enable fractional scaling. Here’s the command to enable it in GNOME. Log back in and in settings, under displays the scale option will have more options.
gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"
If you need to reset it then: gsettings reset org.gnome.mutter experimental-features


Thanks! I had fractional scaling on and Chrome is pretty blurry. But Firefox and everything else looks good so I’ll just switch over and it should be good.

1 Like

idk if you saw this or not, but the framework wiki has this

$ export GDK_DPI_SCALE=1.5
$ export QT_SCALE_FACTOR=1.5

1 Like

Thank you for this. It didn’t seem to enable fractional scaling but I was unable to chance my second monitor’s scale at all. This fixed that.

1 Like

I have this same exact problem. Fractional scaling isn’t really a solution because it looks like hot garbage.

I have a Windows 10 Surface laptop with the same exact resolution and it looks fine. So maybe it’s an issue with Ubuntu. Does anyone know if Fedora looks any better?

I have Fedora 35 installed with fractional scaling turned on. I’m happy to send screenshots, if you tell me what scales you want checking.

Same here - I’m running Fedora 35 and with fractional scaling set to 150% it looks great. Chromium flatpak does look a little blurry, but VSCode, Firefox and pretty much every other app is razor sharp.

On my Fedora 35 install I had to visit chrome://flags, search for “Preferred ozone platform”, set it to “Wayland”, then restart the browser.

This made it less blurry when scaling to 150%!


Wow! @Matt_Barron that’s a night-and-day difference. Thanks!

1 Like