Some issues I have with my batch 2 fedora framework

Hey there!

I received my framework today and I am super stoked!

I still have some minor issues that I would like to resolve. I thought maybe someone with more linux/fedora experience can help me better than countless hours of googling.

I’ve installed Fedora 36 on my Framework DIY i5 1240p.

  1. It seems like my FN keys F7 - F12 aren’t working (FN lock off) (brightness doesn’t work either, even after implementing the fix mentioned in Step 12 here)

  2. Some programs seems blurry (Chrome, Zettlr, Spotify too). I activated the experimental fractional scaling feature, so maybe this is the cause here? I don’t know how to turn it back off again. But maybe this is unrelated. :thinking:

Maybe somebody else had these issues as well and found a fix, would be super happy to hear about it!

Best regards, Sam! :relaxed:

  1. Did you restart your machine after applying the fix?
    Confirm that the fix worked with journalctl -b | grep hid_sensor_hub
  2. Yes, this should be related. Use gsettings reset org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" to disable it, but i guess just setting 100% or 200% scaling in the display settings should yield similar results? Not sure though
1 Like

Yeah, that has been and still is problematic in Linux. I tried it too last year when I got my gen 11, didn’t like it.

Instead, I’ve left GNOME scaling at 100% and enabled Large Text in the accessibility settings. Works well across all apps I’ve tried, and also with an external 4K monitor.

This is under Fedora/Wayland/GNOME.

1 Like

This seems to have worked! Thank you! :slight_smile:

This as well, thanks!

Thanks for the workaround - implemented it too now! :slight_smile: