Fedora 35 makes everything either massive with 100% scaling or tiny with 200%. How to get fractional scaling without text resizing?


My Fedora system only has scaling between 100% and 200%. 100% is tiny, while 200% is massive.

A search online lead me to no-longer existing fractional scaling options and to font resizing. The font resizing was something I tried with GNOME Tweaks, but that lead to discrepancies between the UI elements and the text. Sometimes the text is even cut (when a button is smaller than the text). Text resizing? Not optimal.

Now, let me be clear. I am fully aware that this is most likely an issue with Fedora and not with Framework computers. And yet, given that Fedora could be a popular choice among us Framework users, I wonder if someone has found a workaround.


Is there something I’m missing?

Sorry I posted a response on gnome tweaks before I fully read your post.

How do you feel about KDE Plasma? You can use this desktop environment in Fedora. It’s not for everyone, but it does have fractional scaling built-in. It can handle oddball screen resolutions like that of the Framework Laptop.

If interested, see here to install fresh, or here to replace your DE in your existing Fedora installation.

I don’t know of any proper solutions for GNOME, unfortunately.

1 Like

Fractional scaling is currently a WIP for GNome. I found this article that talks about enabling experimental scaling in Gnome.

I believe you should expect some blurriness in apps that don’t support fractional scaling, but it’s worth a try!

1 Like

@Jacob_Padgett @Gabs Running Fedora 35 with KDE/Plasma currently. The Fractional Scaling seems to work better on X11 than with Wayland right now. With Wayland running as my desktop session most non-KDE apps are blurry and the scaling of everything in general is sub par. Been running most of my sessions with X11 and have found that to be a far better experience as of now.


Exactly the same experience for me. I probably should’ve mentioned that in my post, especially since Fedora defaults to Wayland, if I remember correctly?

I forget where I saw it - it might have been on this forum - but: GNOME’s “Large Text” accessibility feature did the trick for me. After enabling that I found I no longer have to tweak things like Firefox or terminal font/zoom levels, and I left GNOME’s scaling setting alone to the default 100%. Of course everyone’s eyes and second monitor situation may be different so YMMV.


@dimitris FWIW, you can scale the text size arbitrarily from the command-line. I have mine set to gsettings set org.gnome.desktop.interface text-scaling-factor 0.8257 to approximate the scale of a standard 1366px. On a slightly wider laptop, I approximate the scale of 1440px.


Thanks for your replies.

Text resizing or changing my desktop environment seem like the quickest way of solving these issues.

Given that I took so long to reply (sorry!) and my professional life demanded my computer to just work, I got somewhat used to the tiny text. It’s still way too small, but at least it’s only bothersome when I don’t have my glasses on or when someone else uses my Framework.

I think I will patiently wait for Gnome to deliver fractional scaling :slight_smile: