Clock stuck at .39Ghz

[Batch 4, i5 DIY] I consistently reproduce this with the Framework charger, but couldn’t reproduce it the three times I used my friends’ chargers (Macbook Pro chargers ?? W, Dell XPS charger 45 W). I don’t have any data to back this up though. I haven’t fiddled with the EMI shielding stickers yet.

I’d been experiencing this issue on my machine (batch 2) as well: I was throttling down to 0.18GHz, initially only occasionally, eventually all the time, even when on battery power. Fixing the EMI shielding stickers appears to have fixed this for me (3/4 were not properly seated).

One thing worth noting: I got the DIY edition, and I had clearly damaged / unseated one of the stickers while installing the wifi antenna. It might be worth mentioning the stickers in the wifi step of the setup guide? I had not even realized they were there or could be a problem at the time.

1 Like

Can confirm I’m seeing this, machine started to chug while charging at around 50ish percent, it has continued to around 80 percent. I can unplug my charger and the performance immediate jumps right back to normal.

I’m running Arch w/ GNOME, there’s a power settings toggle in the top right and I have it set to “performance” but I have no clue if that actually does anything.

1 Like

Hello, everyone,

To keep everything a bit more organized and ensure we have as much data as possible to research this current issue, please DM or email me at Bee@frame.work with any additional information you can provide. This can include OS, order number, batch number, power adapter, or anything else you feel is helpful to get us one step closer to targetting a solution!

Moving forward, before taking any troubleshooting steps, we ask that you please create a ticket via Framework | Support so we can assist you with troubleshooting and ensure that all steps taken are noted to see what does and doesn’t work! Upon doing so, please feel free to send me an email or DM with your ticket information so we can keep a close eye on that as well!

Thank you, and please let us know if you have any questions! :orange_heart:

10 Likes

@BeeAPeach, Congrats on the new Job!

1 Like

An update for everyone in the thread. We think we have identified the cause and are validating a firmware fix. We are targetting a fix for this in bios 3.07 Which we plan to release in the next 10 days.

26 Likes

I’m very curious what the cause of the issue is, I hope you can share it (even if it’s technical) at some point.

3 Likes

That’s great news! I haven’t personally noticed this problem, but it’s something people have been dealing with for a while and it’s good to know it may soon be fixed.

Definitely great news after trying the other workarounds like reseating the EMI stickers (or in my case I ended up ripping them off completely) and trying different chargers.

If you are experiencing this issue (400mhz, 0.39ghz cpu clock) while charging the battery above around 50+% and want an early test build based on 3.06 that has a fix, DM me on the forum and I can provide a link to download. Otherwise we will be releasing 3.07 in the next week or so.

Technical reason seems to be related to some component variation around the charging circuit. Internally the charger IC has several control loops that run, including an input current control loop, and a battery charging control loop. Both of these limit current, and the input current loop can also limit the battery charging control loop. At a high state of charge the battery charging control loop can allow the input current to increase to the maximum input current, and trip the prochot over a very short time interval before correcting, (microseconds) due to what I think is control lag. The charger has a setting to debounce this, and we increased the debounce time. Still getting some data on the exactly why this happens, but this sounds like a case where a pole moved to the right hand side of the plane :slight_smile:

20 Likes

@Kieran_Levin, just to confirm, will this be installable for users with Linux right away? I think I remember the existing bios updates were only installable from Windows.

3 Likes

Much appreciate the update, but I believe most of us would like to wait for a stable release.

Agreed, would be nice to have the ability to flash it via a bootable media.

5 Likes

So far, it seems to be working for me. I have tested on all 4 expansion ports. Previously, every time I charged with a particular charger and reached ~80%, the CPU throttled to 0.39GHz. Now I seem to notice no performance issues.

Thanks, @Kieran_Levin!

7 Likes

“Agreed, would be nice to have the ability to flash it via a bootable media.”

You can use a utility called Rufus and a generic win10 install iso to create a “windows-to-go” install which boots and runs from usb. You don’t need a windows license, it will run well enough and just disables some personalization stuff like setting the desktop wallpaper. It’s annoying and overkill and you shouldn’t need to do that, but it works and you can do it right now for free from public downloads. I installed to the framework 1T usbc module since it’s read/write specs are better than any thumb drive.

Update, I only just now discovered:

3 Likes

The beta BIOS 3.07 is working for me so far! Thanks framework team!

6 Likes

Just wanted to give an update on this issue. I installed the new drivers as well as the 3.07 BIOS and I haven’t had any issue anymore. My laptop has been running the best it ever has! Thank you @Kieran_Levin and whoever else from the @Framework team that worked on this!!

7 Likes

Well well well… Lookie what I have here :frowning: Good to know there is an update. Going to install now.

EDIT: Well that got scary for a minute. Update success!

3 Likes

Updated to 3.07, still having issues where the clock drops down to 800Mhz and then slowly creeps up again. Disabling BD PROCHOT in ThrottleStop doesn’t help.

posting this here since this thread is the top search result for CPU clock issues: if anyone with a batch 1 machine is still experiencing this symptom even after updating the BIOS to 3.07, consider replacing the thermal paste on the CPU. not only did this fix the clock issue on my machine, but it seems to be running much cooler overall and the fan doesn’t seem to spin up nearly as often (prior to this, i would sometimes hear the fan running at maybe 50% capacity when the computer was mostly idle).

1 Like

@Kieran_Levin I can confirm that my batch 1 model slows down heavily after a few minutes of usage if and only if “Processor performance boost mode” is enabled:

image

I got 0 issue if that setting is disabled.

Already did that. It feels much cooler/silent now. But I still got the very agressive downclocking issue described above.