Computer not charging

I have the power adapter plugged into the computer and the outlet. Its not charging. I have tried it in numerous outlets. Still not charging.
What can be done to fix this? A reply is needed soon. Thanks.

The first thing that I would try is to charge via different expansion slots, see if that helps.

The next thing would be to power the machine off completely, unplug it, let it sit for 5 minutes or so, then plug it back in. Wait a minute to see if the charging light turns on. If not, power it up and see if the charging light turns on. This also can reset an expansion slot that is not charging - I have had this happen to me once in a while.

Finally, you can follow the steps to reset the main board. Make sure that you follow the proper steps, and if you remove the RTC battery, follow the procedures carefully, as the holder is very fragile.

Good luck!

Not sure what you mean by change to a different expansion slot. You mean take the charging slot and move it to another space on the computer? I see there are 2 places on the right side of the laptop.
It doesn’t turn on at all that’s why i plugged the charger in and nothing lit up. I hit the power button and nothing happens.First time this has happened to me. I have the laptop about 13 months or so. Help!

Yes, try moving the charger to different slots. Try them all to see if one will work. If the computer is that old, it’s likely an 11th gen, and it’s possible that you hit the no-boot issue if the machine sits unused for a long period of time, or if the RTC battery is going bad.

Are you using the Framework charger, or a 3rd party usb-c charger?

It may also be helpful to send a ticket in to support in case you have a hardware issue, however they may not respond as immediately as you would like.

I would also recommend testing a couple different ports on the laptop, both expansion cards and the ports that are revealed if you take an expansion card out. If that doesn’t work I would recommend trying any other usb-c charger you might have available, as any charger should give the laptop enough power to power on the first time, and that could rule out a bad charger.

This makes me think you may have the 11th gen model and you may be experiencing a dead CMOS battery.

You can try following the guide here:

make sure to be extra careful on step 5 as the coin cell holder is fragile, and make sure to follow step 14 and keep it charging for a full 24 hours after the reset.


I had troubles with the USB C cable itself on my 12th gen.
Solved there : Charger connect and disconnect in a 2second Loop after wake up from sleep | GaN adaptative mini power

I am using the Framework charger that came with the laptop. I thought the computer is a good one from reviews i read. Now I’m not so sure. I shouldn’t have purchased this one. Should have waited for the 2nd one or later. Where am i going to get a cable to plug into the charging port? One i have from a different laptop is a plug-in type. This is something i never expected to happen.

I am going to take it to a computer guy i know who fixes laptops and desktops. I don’t want to mess around with it and not get it back together the right way.

Why did you get a Framework if you are not interested in maintaining the computer yourself?
Not trying to be mean, just wondering because there are better priced laptops with these specifications that do not “require” customer maintainance.

Edit: Also make sure to open an Support Ticket here.

1 Like

@Daniel_Talbot - good luck, I hope that you are able to get it resolved. To help others help you, can you provide the following information:

System Version (e.g. 11th Gen 1165G7)
RAM - total size and # of sticks
SSD - make, model, and size
Expansion Cards in Use (e.g. 4x usb-c, 2x usb-c + 2x usb-a, and so on)
OS in use

Troubleshooting steps taken so far (e.g.

  • plugged charger into each of the four expansion slots, no change
  • tried using a different USB-C expansion card for charging, no change
  • plugged charger directly into USB-C port - not via an expansion card note, be careful doing this so that you do not put mechanical stress on the USB-C/thunderbolt port on the motherboard
  • reset motherboard by following documented procedure note, be careful, the RTC battery holder is fragile as are the main battery pins

The above will go a long way in helping others to help you. I hope that you are able to get things sorted out. You may wind up needing to replace the RTC battery if it no longer is holding a charge.

I brought the laptop to a computer repair business.
They checked it out and said the motherboard is no good. Not working.
This computer is DEAD after having it for 13 months?
Warranty is 1 year?
What is the phone number to talk to the owner? It’s not listed anywhere on the website!!

As stated in my reply:

You should definitely open a support ticket.

That is the official way to get support.

@Daniel_Talbot - sorry to hear that. As has been noted by others:

  1. Open a ticket with Support
  2. Make sure the charger is working - test on another device, try a different charger, etc
  3. Purchase a new RTC battery and replace the old one - carefully

Best of luck, hopefully you are able to get it working again.