Laptop won’t charge or turn on

Over the last couple of weeks I’ve noticed intermittent problems with my 11th edition DIY framework laptop. It was refusing to turn on when not plugged in, just staying totally dead. Up until this morning, plugging it in fixed the problem. It would then turn on, and after it was on, I could unplug it and it would work fine on battery. When this happened the battery wasn’t particularly low, it just seemed like it needed to be plugged in to trigger something to allow it to turn on.

This morning I went to turn it on and nothing worked. More worryingly the charge light next to the USB C port is no longer lighting when I plug in the charger. I’m pretty sure it’s not a problem with the charger, the laptop has been charging fine once it has been on and I’ve tried with another charger this morning and the light doesn’t come on with that either.

Any suggestions for what this might be/ how to fix it?

Thanks in advance!

It may be the RTC/CMOS battery issue that occurs in 11th edition.

Have you checked this article?


Gah I’m really sorry, somehow I totally failed to find this when I was searching. Yes, that was absolutely it, I had to reset the mainboard and I suspect that the RTC battery is on the way out. I’ll have to replace that.

Many thanks for the link. The DIY guides are fantastic and really easy to follow!