Constant issues with literally any display

  • Which OS (Operating System)? Windows 11
  • Which release of your OS (Operating System)? - Version 10.0.22621 Build 22621
  • Framework laptop (11th or 12th generation Framework laptop) are you asking for support with? - 11th Generation

I have a USB-C, HDMI, and DisplayPort dongle (Official Framework Ones) no mater what display I use I am constantly fighting with it. It never works when I turn my PC on. I have to reboot my computer several times, take the whole dongle out of the computer or even change connectors to get it to work.

I’ve updated drivers using the driver pack, I’ve made sure windows is up-to-date. This is killing me to deal with every single day, sometimes several times a day throughout a regular work day.

Does anyone had this issue or does anyone have any solutions I can try? I bought a thunderbolt dock and it has all of the same issues. I’m at a total loss on how it can be such an awful experience.

1 Like

When looking at the display settings within windows, is the display being detected? You can check by going in Settings, System, Display, Multiple Displays (Located under the display arrangement), Detect button next to “Detect other display”.

Here are a few methods that MAY work.

  • Have you tried different expansion slot ports? Nothing is perfect and some ports may be defective.

  • Although you have connected to multiple displays, make sure the display connector is plugged in correctly.

  • Did you try to plug in the display when you have booted in windows? Windows being windows with laptops, sometimes when you startup windows your external display won’t receive and input up until the log in screen or sometimes even the desktop.

  • Not sure if it may work, but worth a try. While having the monitor plugged in and you are booted in windows, press and hold: Windows Key + CTRL + SHIFT + B. This will restart the graphics drivers. NOTE: you will hear a beep noise, don’t be alarmed.

Hope this helps!

I would HIGHLY recommend contacting Framework support if you haven’t already.

I FINALLY think I’ve figured this out, thank you so much @Ash_G. I tried everything you provided and it lead me to testing using my Steam Deck dock, I plugged this into my framework laptop and then plugging in Display Port there, poof it works everytime without failure on all my ports.

It has to be that I’ve received a defective DisplayPort adapter that has been causing my issues.

Thank you as well @Azure I am working on submitting a ticket regarding this.

1 Like