Debian 11.0 issues

I installed Debian 11.0 and I’ve found a curious collection of problems:

  1. I can’t use the trackpad click feature, so I can move the pointer but not click.
  2. I connected an Lenovo external mouse, and it isn’t recognized. UPDATE: two USB thumb drives are also not recognized on two of the USB ports.
  3. The Windows key isn’t causing the Applications menu to open, nor is any other key sequence.

As a result I can’t launch any problem, not even a terminal.

Has anyone had an major problems with Debian 11?

I can do ctrl-alt-Fn to get to another virtual console, but these are frustrating to use because the system constantly prints errors to the virtual consoles (never seen that before…) concerning Bluetooth.


Have you ckeced the trackpad issue? They have officially ackownledged that Batch1 models and some B2 have touchpad issues, including button click. Check this post: Known issues on early Framework Laptops

So, this will sound unintuitive, but you have to enable tap-to-click in the mouse settings. Press the Windows key and type “mouse” to get to the touchpad settings screen. Use the keyboard to navigate to the control that enables/disables tap-to-click and turn it on. That fixed the issue for me.

That being said, assuming you’re using a Framework-supplied wifi card, be prepared for wireless to not work in Debian 11. The 5.10 kernel they ship has a known regression that prevents the AX210 chipset from functioning. That issue is also responsible for those Bluetooth-related errors you’re seeing in the console.

I personally flipped to Ubuntu 21.04 but I’m considering giving Debian another go and building a custom 5.12 kernel to resolve the issue.

But for now, until the regression is fixed, out of the box it won’t work.

1 Like

Yeah, I had issues when I tried to install Debian 10 with the wifi and graphics drivers (I prefer KDE and it didn’t work at all). The trackpad also didn’t “tap-to-click”. You had to physically press down on the trackpad to click. Upgrading to Debian 11 fixed the graphics issue, but still not the wifi, though I got a bit further (I could attempt to connect, but it would never actually do so).

I finally gave up and installed Manjaro. So far the only issue I have with that is the fingerprint reader. But that’s a known issue with KDE in general. Happy so far with it. :slight_smile:

My problem with that is that Windows key isn’t working. The other keys work though.

Thanks. An update: I’ve found that a normal mouse click doesn’t work, but if I press down with about 3 to 5 times the force, it does register. However that’s not a normal amount of pressure. So I am guessing my trackpad has the resistance defect mentioned on the page you linked to.

This sounds likely to be the issue. Please reach out to support, and we’ll swap out your Input Cover with a new one.

For the USB ports, it sounds like you may be running into this issue as well:

I found that I also can’t get into the F12 key boot menu any longer (F2 works fine).

If a thumb drive is in the USB-A port when I boot up, there’s a light on the side of the machine that blinks and changes colors. When I remove the thumb drive, that light turns solid white.

I’ve tried moving the USB-A adapter to other slots but I get the same result.

Update: Here is a new bug, maybe a BIOS issue. I enabled the RAM test in the BIOS settings. If during the power-on RAM test I try typing fn-F12, the memory test freezes and it seems the system halts.

Could you share the blink sequence? We have a decoder for it here: My Framework Laptop is not powering on

For folks who stumble on this thread, following the Debian handbook to build out kernel 5.12.19 mostly worked:

However, be careful to ensure that the I2C_HID and I2C_HID_ACPI kernel modules are enabled to build, as you’ll need them to ensure the touchpad fully functions.

Other than that, Bullseye seems to be working great!


Just for you information: here is the Debian 11 main thread Debian 11 on the Framework Laptop .

I changed this thread’s category from “Framework Laptop DIY Edition” to “Framework Laptop DIY Edition - Linux”.