[RESPONDED] Debian 11 not working on Framework Laptop

(Transitioning from windows, not the most linux savvy yet, please handle with care)

I have been trying to install Debian on my Framework laptop, but it seems that the drivers arn’t working well with the networking hardware. I have also been looking aroung and heard that I heed to backport the kernel somehow. I’m not the most technical yet, as I’ve said, and I would really appreciate some pointers as to how to solve this problem. Here’s a list of hardware and steps I’ve already taken:


32 x 2 DDR4 -3200 SODIMM RAM (Crucial CT32G4SFD832A)


Intel® Wi-Fi 6E AX210 No vPro (Couldn’t find the part nunber)

Intel® Core™ i5-1240P (12th gen)

Things that have happened:

Tried debian-11.6.0-amd64-netinst image on DD and ISO mode using rufus, failed to install, said that it required iwlwifi driver(s)

Tried debian-11.6.0-amd64-netinst+nonfree image on DD and ISO mode using rufus, failed to install, when encrypting it says it falils to copy the system

Tried the debian-live-11.6.0-amd64-gnome image, didn’t work of cource.

Tried the debian-live-11.6.0-amd64-gnome+nonfree image on ISO mode, didn’t install, failed to copy system.

Tried the debian-live-11.6.0-amd64-gnome+nonfree image on DD mode, sucsessfully installed.

tried to boot into the system got stuck up on these errors

(Imgur: The magic of the Internet)

Note 1: whenever I burned an image to a USB drive in DD mode, i wasn’t able to acess the filesystem after it was burned. Not sure if thats normal or not.

Note 2: I have already installed fedora and it worked fine. Didnt really want to use fedora though, so now we’re here.

If you could help me out by directing me in the right direction, I would really apprcate that. I really want to learn how linux works and want to make this my daily driver. Thanks in advance.

Edit: specified components

Unfortunately, I am no Linux expert either, so hopefully someone with more knowledge than I will come along and help you, I know the Linux Support Lead should be back online in the next couple of days.

I do wonder though, is there a specific reason you are trying so hard to use Debian 11, and not one of the other Linux versions that is directly supported by the Framework team? Since you are not Linux savvy, I would assume that one of the distros with full install guides would be better (I did see that you tried Fedora, but didn’t like it). Ubuntu for example is based on Debian, and Linux Mint has versions with an Ubuntu base and a Debian base if you wanted to try those out.

If you are hell bent on running Debian though, hopefully you’ll be able to get some help from others!

1 Like

Just wondering, why Debian, as opposed to new user friendlier distros like Linux Mint, or PopOS?

First off, were you able to run the Debian live USB on your device? ie: get into the Debian gnome desktop.

^Yes - Did you use the “Install Debian” installer in the desktop mode?

^No - Try reflashing your USB using raspberry pi’s super user friendly imager. Operating system > Choose OS > Use custom > debian iso file.

If you are new to Linux (and even if you are a Linux expert) I highly recommend Ubuntu 22.04. There is a Framework guide on how to install it on your Framework laptop. (Ubuntu 22.04 LTS Installation on the Framework Laptop - Framework Guides)

Ubuntu is based on Debian, and uses the same apt infrastructure. I would highly recommend it.

1 Like

I think you are trying to install a stable version of Debian with a 5.10 kernel. I just tried this kernel and got the same error messages that you saw. It is too old and does not work with the AX210 WiFi/Bluetooth in our Framework laptops. You can follow this posting to install a testing version with a more current kernel: https://community.frame.work/t/debian-testing-on-the-framework-laptop/14448

For Linux users new to Linux and would like the best installed experience possible, Ubuntu 22.04 or Fedora 37 are the official recommendations.

1 Like

I am an huge Debian 11 fan and was using it for a while on a Intel 12 Generation i7 before I noticed that 3D graphics weren’t working. I confirmed this using glxgears and then with this command:

> inxi -Gx
Graphics:  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Realtek Laptop Camera type: USB driver: uvcvideo bus ID: 1-7:2 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting 
           unloaded: fbdev,vesa resolution: 2256x1504~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.5

I know Ubuntu is the recommended operating system, but If you prefer to run Debian and are comfortable trying out Debian 12 / Bookworm (which is currently testing) then I was able to get past all of the 3D Rendering issues by upgrading. So far it has very smooth for me 3D and Hardware Accelerated Video Playback (confirmed with vainfo) all work for me now.

> inxi -Gx
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: Realtek Laptop Camera type: USB driver: uvcvideo bus-ID: 1-7:2
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.9 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915
    resolution: 2256x1504~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes

Running kernel linux-image-6.1.0-7-amd64.

Hopefully this is helpful! I was scratching my head a while before I was able to piece this together.

1 Like

hi @Tj11 ,

welcome to the community forums, thanks for sharing your experience with debian 11 on framework laptop, just confirming you upgraded to bookworm from debian 11?

1 Like

Hi @Loell_Framework,

Yep, I was running Debian 11 on a framework laptop and then I upgraded it to bookworm. I followed the instructions here: DebianUpgrade - Debian Wiki. Most of my changes from Bullseye ported over, but a few things like the Media Key fix didn’t make it.