Debian 11 on the Framework Laptop

Check this thread.


Just switched to Debian 11 from Ubuntu 20.04 on my old machine. Thanks @neurology_equator for sharing your steps!

I was actually able to get the AX210 wifi card to download updates, including kernel backport, after initial install using the non-free iso. The wifi worked after I renamed /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm to /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm.bak and restarted the machine.

The original filename needs to be restored after updates and kernel backport, otherwise the wifi will stop working again. Also, the backport is still necessary for bluetooth to work.

Initially stumbled on this solution here

1 Like

I am using pipewire/wireplumber on my Debian Bookworm. Initially bluetooth audio was not working. I fixed that by manually installing libspa-0.2-bluetooth which is needed by wireplumber.

The line in the logs that led me further was:

wirelumber[966]: SPA handle 'api.bluez5.enum.dbus' could not be loaded; is it installed?

Anyone else having problems with not being able to pair bluetooth devices on a backported debian 11 (5.16)?

I see a lot regarding wifi, on the 2nd gen I was able to get Debian 11 running, I have tried a couple different kernels and settled on 5.18. What I do not see is anyone getting the GPU to work, I have not, am I missing some posts? I tried Fedora, but I have requirements that forced me back to Debian and I would like to stay away from Canonical if I can.

So please reply to this thread if there is a good workaround to GPU.

Sorry to jump in here, but I’m wondering if you’ve seen any progress on this?

In general, everything works well on my 12th gen, with Debian testing/bookworm. Except Signal Desktop. Firefox, everything else works fine under i3 with a composition manager (compton), but there’s tearing/shearing in Signal, and I don’t understand why. Interestingly, I’m seeing the same problem in Chromium… It’s pretty nasty!

I probably should try under Wayland but ugh, another thing!

Update: turns out the fix is simple, just pass the --disable-gpu-compositing command-line switch to signal-desktop or chromium, see also this post. This can be made persistent by adding a file in /etc/chromium.d/disable-compositing:

export CHROMIUM_FLAGS="$CHROMIUM_FLAGS --disable-gpu-compositing"

That, obviously and unfortunately, doesn’t work in Signal, which I run from Flatpak, which doesn’t support such overrides. Arghl. I had to fix a wrapper scrip to have this work. See also this commit.

1 Like

Just yesterday (Oct 22) I got my Framework Laptop and installed Debian 11 using debian-11.5.0-amd64-netinst.iso from debian dot com. My suggestions for those, like me, that are familiar but not expert in linux:

  1. Read up on UEFI if you don’t know what that is. I didn’t.

  2. I have had issues with “Graphical Install” on other systems so I always use “Install”; YMMV

  3. Initially install only a base system; no desktop environment.

  4. See this first post and this second post At the end of installation but before rebooting I suggest adding the instructions of the first post into the instructions of the second post. I did not and upon reboot my console was spammed by error messages from the bluetooth module. If that happens to you, log in as root, use dmesg -n 1 to stop the spam, and blacklist the kernel modules bnex, btusb, bluetooth, btintel, btbcm, btrtl as described on the debian wiki. Then reboot. Then apply the instructions on the first post. Then reboot. Then un-blacklist them. The rebooting between the kernel installation and the un-blacklisting procedure is superstition on my part because I don’t know how they might interact with each other through the init-ramdisk stuff.

  5. Once the laptop reliably boots run sudo tasksel to install the desktop environment(s) of your choice same as you would have from the installer.

I am still getting a warning that I have no video acceleration although my desktop environment works for all the basic stuff I’ve tried so far.

I had an additional problem that my wired ethernet dongle that worked perfectly during the install did not work on my installed system. I did have an older wired ethernet dongle that the laptop seemed to identify more easily. Still I had fun learning about the new way of naming interfaces and manually configuring networking.

That might be because you’re missing some firmware files, which are still not in Debian. See Framework 12th gen laptop review - anarcat

That drives me nuts and I disable it, in grub, you add net.ifnames=0 to the kernel commandline. :slight_smile:

My Framework Laptop gets really hot playing YouTube videos and during Zoom calls. I’m running both in FireFox. Fan is going constantly and yet the bottom of the laptop still gets uncomfortably hot. This starts shortly after the video starts and stops shortly after the video stops. Does anyone else have that experience? Does it happen on Windows?

Installed Ubuntu 22.04. I’m now watching YouTube and the laptop is no longer trying to fry my lap. This suggests (to me at least) that there may be some serious issues with the video drivers Debian 11.5 (with backports) is using.


I followed the directions in this thread and installed Debian 11 on my Framework.

I chose Gnome, Cinnamon, KDE, and LXqt, during the install in order to give me a spread of environments to try. Long story short, I am on KDE Plasma at the moment and not getting the “hardware acceleration missing” error I got in Cinnamon, the same thing @Greg_Deitrick seemed to encounter–along with the enormous heat and my battery being murdered by the lack of video acceleration.

So far though, the machine is running smoothly.

Thank you all for your efforts in writing out how you got Debian installed and what you’ve run into. In the meantime, I will add power optimizations as seen elsewhere and get an idea of how the battery runs with Debian.

As an update, I’ve been unable to connect via bluetooth thus far. The backported kernel I am running is 5.19.0-0.deb11.2-amd64. Has anyone else had issues?

ETA: Also, I am trying to resolve the missing i915 firmware issue using the instructions on the DebianOn page for the FW 12th gen. However, because I am a total noob, I am not sure how to fetch the i915 firmware to add to my /lib/firmware/i915 folder. Is there anyone out there who has accomplished this and can advise me on how to proceed?

Edit 2: I tried taking the files from a machine I have running Manjaro, dropping them in the directory, and rebuilding initramfs. No dice. Thought I would share.

Last update (for now): Since I cannot get the right i915 drivers to run, video performance is hideous. Also I can’t install certain things because of my backported kernel–I have “broken packages” (yikes). So, back to Manjaro for me for now. I will get Debian on here eventually, since it can run what I need run consistently. Next version…

That page tells you exactly how to do it, no? I had the same issue, downloaded the missing adlp_dmc and adlp_guc files from the linked to website, put them under /lib/firmware/i915/, and ran update-initramfs as described.

The files I fetched from that site were not the binaries, but HTML pages of the hex dumps. The system still didn’t recognize them as proper drivers.

I had a somewhat similar experience: deploying the new firmware caused all sorts of problems. The solution for me was to run a compositor like compton. See my notes in proprietary firmware blobs, as i mentioned before. :slight_smile:

Right. Sorry about that, most people seem to assume you will know how to use git or gitweb and, obviously, that’s a bit of a stretch. :slight_smile: A better link you could recursively download more easily could be:

If you want to go that way, you can also just pull the whole thing from git, with:

git clone git://

… and then the files you are looking for are in linux-firmware/i915, so, back from the top:

git clone git://
cp linux-firmware/i915/* /lib/firmware/i915/
update-initramfs -u

… should do what you want. Note that the git command might be slow as it’s going to fetch the entire history. You can use --depth=1 to limit the download to only the last commit.

I hope that helps!

1 Like

Thank you! I might take another crack at it then!

Oh, you don’t have to mess with Git or anything. Click the “plain” links on the page for the files you want; that downloads the binaries.

No, that isn’t user friendly at all

1 Like

LOL, nope.

Indeed, clicking on each of those hex dump files, then finding the “blob:” line at the top and clicking where it says “(plain)” gets you the actual binary.

This is another noob question, and I apologize, but yesterday I tried pulling the affected binaries from another system, this one running Arch. When I loaded them into the /lib/firmware/i915 directory and ran initramfs, of course, it eventually compiled without a problem. However I still got the “driver not found” errors when I opened Cinnamon. Is the fact that they’re from an Arch system a factor? The other system was running 5.19, the same as the backported kernel I got from Debian. I figured it would fill the hole properly. but it didn’t work…

(ETA “eventually”)

@juancnuno - Thank you for clarifying all that for me. Using git is one of the gaps in my knowledge I’ve been trying to fill and this all helps.

@anarcat and @juancnuno - Thank you again for all your help! At the moment I am in backported Debian again getting everything set up once more.

@anarcat - In the end, I did end up having to recursively download the whole i915 directory to get everything down. Compton appears to be in place and (I think is) enabled as well. The fan isn’t kicking off, so I’m very encouraged. Thank you for the extra education on git, and the meticulous notes as well.

(Edited to clarify things…)