[SOLVED] Graphical glitches and intermittent external USB


So I’ve been using my Framework laptop for a few weeks now and, at first, things were generally working rather well. I did have to hack my way around a few things (see this thorough review for details), but nothing out of the ordinary for a “fresh new laptop that I need to run Linux on”, in general.

This bug, however, is kind of weird and irritating, and I’m hoping to hear if someone else encountered it or has a fix.

It’s a little hard to describe, so please bear with me. The basic problem is that sometimes it looks like USB signals just drop completely off the bus. I would type on the keyboard and nothing would come up on screen. Sometimes, the keys would be typed in really a really long delay (think: a few seconds) or just completely dropped (think: fl instead of fail). The mouse would just stop working altogether, or hang in a similar way.

Both the mouse and the keyboard are plugged in an external USB-A hub that otherwise generally works okay, or at least used to work fine with my previous laptop.

This wouldn’t happen on the onboard touch pad or keyboard, which work correctly when this happens.

I also mention graphical glitches here because I have this (unconfirmed, “fuzzy”) impression that the problem correlates with graphical glitches, where part of the display would “tear” and become garbled in flashes. That’s not on an external monitor, mind you, on the primary display.

Has anyone witnessed something like this?

I wonder if this might not be a problem with my compositor? I’ve had issues with the GPU that felt somewhat similar; until I used a composition manager (compton), there would be noticeable lag (but not drops or hangs) in the keyboard input. and until I disabled composition in Electron apps, i had similar tear in those apps…

Maybe it’s something that would be fixed by upgrading to some Wayland compositor?

Thanks for any input!

Try opening the case and tightening the left side heatsink screws to improve the mainboard’s rigidity. I stumbled across that on my laptop and it worked for someone else I recommended it to, so it’s worth a shot.

1 Like

Wow, that was a fast response, thanks! but…

… so I just tried that. I’m not sure exactly which screws I’m supposed to tighten, there’s a lot of them! But I did try to tighten a bunch of them, including the ones to the left of the heatsink.

The problem remains. It’s actually quite noticeable and irritating, now that I think of it. The whole screen “jumps” from time to time. I completely lose the mouse once in a while… the keyboard is basically unreliable, it’s quite hectic.

I guess I should reach for support next, but thanks for the suggestion (and happy to try out more things!)

One thing that’s interesting with this problem is how unpredictable it is. Like for example, since I posted the last comment, about 15 minutes ago, things kind of stabilized: the glitches have mostly disappeared, and I don’t notice problems with the keyboard anymore. Maybe the fix took a while to settle?

So strange…

Sorry, I should have specified better! Looking at this picture from the repair guide, the left side fan screw.

Whatever the solution is, I hope things get better! I would also try a few basic troubleshooting steps like using a different port, or trying the connection directly into the USB-C port in the expansion module slot instead of using the module itself. But that’s exactly the problem I had, and only the screw tightening helped, so I’m at a loss if that isn’t it.

1 Like

hmm… well right now I’ve been using the latop for about an hour, and the problem didn’t come back, so this is fixed… i guess? :slight_smile:

i wish i could mark your answer as a solution, i’ve seen that in other discourses… .maybe something the @moderators can look into? :slight_smile:

Glad you got this fixed!

Title is marked as solved, so you’re all set.

1 Like