Debian 12 not recognizing fingerprint reader

For my own peculiar reasons I changed from Ubuntu to Debian and I have found that the fingerprint options are not in Settings as they are in Ubuntu.
Is there a way to enable the fingerprint reader on my FW using Debian?

Host: Laptop AB
OS: Debian GNU/Linux 12 (bookworm) x86_64
DE: GNOME 43.4
Kernel: Linux 6.1.0-10-amd64
Shell: bash 5.2.15
WM: Mutter
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.7GHz
GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]
GPU Driver: i915
Memory: 5.51GiB / 15.41GiB (35%)
Disk (/): 9.0G / 227G (5%)

1 Like

I am not an expert, but have you tried the below:

Install packages:
apt install fprintd libpam-fprintd

Fingerprints can be added by running fprintd-enroll CLI command in a terminal or by using GNOME’s Settings GUI:


Complete instructions in the link below:

Please do let me know how you go because I also intend to run Debian 12 as it is a great distro once I get my framework. :+1:t3:


Nosh, I switched to Mint which is working well for me, however I have not discovered how to enable the FPR. I tried your commands but Mint is not ready for this. Should I go back to Debian I will keep your comments at the ready. Thanks.

1 Like

@QRP unfortunately as I dont have the hardware yet I cannot try this myself.
I know official support is for Ubuntu & Fedora, because they provide most polish as far as out of the box functionality is concerned.

However just for fun I tried Debian 12 on a old Celeron laptop with 2GB of ram and I was surprised how polished it is. I even got fractional scaling working on it.

The FPR instructions are for Debian so they should work, I believe some tinkering is required.

There is a huge thread here you may have to dig into it, but it seems like it is a bit of a hit and a miss:

I can confirm that fingerprint scanning works well on Debian 12 by following the instructions on the Debian Wiki, as suggested above. For the last step use “sudo pam-auth-update”. Without the “sudo” the command is not recognised

1 Like