Display not turning on until OS is loaded

Ok, so some context as to how I ended up here.

I was working on the laptop USB shielding because I’ve been having issues with USB devices not connecting or once connected sometimes disconnecting and the errors I see in dmesg indicate that it just can’t initialize the devices. I wasn’t sure which batch I had, and I haven’t been able to test other adapters with it yet so I just went with my gut instinct and tried that fix first.

Anyhoo. While I had the laptop apart, I did the following: I disconnected the main battery, the display cable, the keyboard/trackpad cable, and the second RAM stick.

I double checked that everything was ok physically before reassembly, but the display wouldn’t turn on at all and the motherboard was doing the diagnostic flashes and indicated the internal display was borked. I went ahead and reseated the cable, still the same issue.

In troubleshooting this, I did a full reset of the motherboard per the guide, and now I have the display working but I can’t do anything at the UEFI level, it stays dark until the OS is loaded.

I’m running BIOS 3.07, Fedora 35, 32GB of Crucial RAM, stock Framework charger. I’d really like to avoid sending it in as I use this all the time for work, but I’m open to suggestions. Oh and I also promised this laptop that it would never run Windows LOL

When I rebooted, it’s still flashing the POST diagnostic lights, but all of the bit checks are now green instead of some green, some blue. I didn’t think to mention that before, something I noticed about an hour after the motherboard reset.

Well, the second RAM stick is mentioned in the guide to adjusting the USB shielding, so that one makes sense for me to do…

As for the display cable I did it because of the proximity to the shielding I was working with, felt prudent to detach it first. Also seems like it would be a non-issue to have done so because my experience with servicing laptops tells me it shouldn’t have mattered.

1 Like

Update: Still doing the diagnostic lights at this point. If this continues tomorrow morning, I’ll presume that it needs to be serviced. If I can get it hooked up to another monitor I can probably try reflashing the UEFI if it will let me, if anyone thinks that will help at all.

1 Like

Have you tried disabling Secureboot in the BIOS?

Try checking this thread: Why does my bootmanager only with with secure boot disabled?

1 Like

It might be best to submit a ticket to our support team here: Framework | Support so they can ensure your laptop is performing as intended.

1 Like

Ok so upon thinking about the exact sequence, it’s when the OS loads the driver, I see the Framework logo and the spinning circle, then I see the login prompt.

1 Like

Good point, have no idea why it would load Fedora.

It did do something in resetting because now the power button is fully lit and the keyboard backlight was off when it first rebooted after I did the reset. It also acted as if I had just pulled it from the box.

So I presumed it had been successful.

1 Like

@Panda_bak I’ll do that. Thanks for the link. I’ll also follow up on this post if I discover anything.

1 Like

In 3.07, you can set the timeout where it will wait for you to press Esc, Del, F1, F12, etc. Earlier versions had this timeout set very low - you had to be quick-on-the-draw when you saw the logo and really hammer that F1 key! Even then, I missed the window frequently.

Also sometimes Fn Lock was toggled off so pressing F1 or F12 wouldn’t do anything, you have to press Fn Lock, then F1, and often there just wasn’t enough time.

I wonder if this timeout has been reset really short and it just jumps past the bootup logo to your login window with such a short wait you can’t see it.

Try spamming F1, Esc or Del as soon as you see the backlight turn on - don’t even wait for the logo, you might not have enough time. Also try Fn Lock then F1.

If you finally get in, set a nice timeout. I used 5 seconds.

1 Like

I can verify that’s not the issue as on one occasion I was able to halt the startup sequence by spamming F2, and once there still couldn’t see anything but it did power off as if I was in the BIOS.

Edit: also I entered the BIOS using the systemd command as well, no display output.

1 Like

@RandomUser Did both of those. I’m guessing it’s a support issue now as well. Thanks for the suggestions all the same :)8

1 Like

The normal startup sequence is the Framework logo, followed quickly by the loading mechanic of whatever OS you are using. Based on your descriptions above it sounds like yours is booting normally. But still, I would heed the advice of Framework’s support personnel and create a ticket just to be on the safe side.

1 Like

I had something similar to this happen on my TrueNAS. I had connected an ancient monitor to it. It worked fine for the framebuffer (text), but when I went into the BIOS, blank screen. It was behaving like I was in the BIOS only I couldn’t see anything.

I connected a newer monitor and it worked as expected.

The BIOS generated an image in a certain mode the old monitor couldn’t handle.

This isn’t exactly what’s happening to you, the display is made for the laptop, but it sure sounds similar. There should be no reason why the display can’t handle certain video the hardware outputs, but the symptoms sound similar.

1 Like

Which is all that I’m seeing. I guess I wrote that incorrectly, what I’m seeing is the loading screen for Fedora which includes the Framework icon in it.

1 Like


Ok so I did as you suggested… And that was the first thing I saw was the dialog saying no bootable device.

I powered it down, reinserted the NVME drive, and upon restart noticed that I could now see the Framework logo briefly flashing, which is not what I was seeing before. I was able to get into the BIOS and look at the settings, and it seems it didn’t enable Secure Boot when I did the reset but it did change some other settings like the power button brightness setting.

Also was able to turn off quick boot, and now I see the logo as it’s testing my memory and I can see the 3-second countdown that Fedora’s menu has which I wasn’t seeing before either. It still threw the diagnostic lights and said it couldn’t initialize the display… and it threw some bit errors (I’m guessing that’s what the blue lights mean). That said I’ve had it on the charger for about 18 hours in total since this adventure started so maybe that’s helping?

1 Like

Already have, and once they reach out to me, I’ll update them with the new info and see what’s up.

I’m surprised that the RTC battery would be so bad in terms of keeping a charge when it was only unplugged for a minute or two at most.

1 Like

@Charlene_Klingele We responded to your ticket shortly after you submitted it. Please try checking you spam folder.

I don’t see anything. Maybe I typed my email incorrectly?

@Charlene_Klingele We checked on our end and the email we replied to is the same one associated with your laptop order. Try submitting another ticket and also check your email filters.

What email should I be expecting to receive from? I’m getting the emails associated to the forum postings that are coming in via noreply@mail.frame.work