[RESOLVED] Need Help -- Black Screen and doesn't boot


I’ve had my Framework for about a year now. When I tried power it on last night it was flat, after charging it, the power light would come on, the screen turns on and remains black. It doesn’t show the BIOS and remains black (but appears to be on).

I’ve tried reseating the ram, resetting the CMOS and following the first guide here re the two chargers. I believe its charged because the power light comes on and I’ve left it on and charging for about an hour in case reseating the ram required memory training.

What are my next steps here?

  • OS: Gentoo Limux w/ ZFS
    • I don’t believe it’s Linux issue because I can’t even get to the BIOS which means even booting off a lot of USB is not an option
  • Laptop: I’ll check when I get home but I’m pretty sure it’s. It’s the 11th gen)
1 Like

If 11th gen it’s very likely the RTC battery issue.
To debug you’re going to have describe what happens (lights etc) when you follow each step in the guide that you link to.

Thanks for the suggestion. I looked into it and yeah, that certainly seemed like it could have been the issue.

However, I’ve purchased a new CMOS battery, I replaced the old one and I followed the main board reset guide. I’ve left it on charge and powered on but nothing seems to change.

I’m still getting the same behaviour.

To clarify, when I power on, the power button light comes on and remains illuminated. None of the side LEDs illuminate. The screen flashes but remains black and does not display the BIOS or anything else.

What should I try next?

1 Like

Okay, I’ve just figured it out. The screen has failed, which I hadn’t even considered because the laptop was just sitting in a drawer – Bad luck I guess.

I had earlier tried to plug it into an external monitor to test that, but I hadn’t thought to attempt to type in my lUKS password.

I blindly typed in the LUKS password and then I was dropped to a shell on the external monitor.

The take away here is: if you’re testing the screen, remember that the LUKS prompt won’t appear on the main display.

I’ll play around with the connections on both sides of the screen and see if I have any luck.

Hi @Ryan_Greenup,

I hope you bought the correct rechargeable battery. It is not a standard Alkaline coin cell like it is in other systems. You probably did, I hope others understand that you can not just buy a coin cell from the store and slap it in.

Sorry to hear your screen is kaput. I would check and reseat both ends of the display cable in case it somehow worked its way loose or had a bad contact.

Good news is the screen is pretty easy to replace and much more reasonably priced than if it was a Mac, HP, Dell, Lenovo, etc.

So I ordered a new screen and put it in. At first it was the same issue but my better half reseated the cable into the motherboard and all is well.

So in the end it was a dead screen. Thankfully shipping was quick.

It did say rechargeable but I changed it back to the original now that I know it’s the screen. I intend to leave it on charge when notbinbusebnow that I know about that issue.

I’ll update the mobo in the future anyway because I’d like a faster CPU.


Should say ML 1220
a non rechargeable would be CR 1220

Thanks for the info on the screen

Glad to hear the new screen did the trick! When you get a new MB, you can get the little Cooler Master case and repurpose the old board as a little standalone computer.

New screen that you could replace is so much better than if you had to find a shop to repair it or just bite the bullet and have to buy a new laptop. The newest Intel chips they just announced are going to be so much more power efficient than even the 11th Gen chips.

I’m happy to hear that issue is now resolved Ryan. Is it safe to update the topic title with [RESOLVED] then? Maybe it will be helpful to other community members as well.

Yeah let’s mark this as [RESOLVED] (Can I do that or do I need a mod).

I’ll add also, it may have also been a loose connection to the motherboard, as the new screen didn’t work at first until I really pressed the connection in. Perhaps the old screen was fine (although I reseated the connection a dozen times).

So if someone else comes across this, try reseating the cable and pressing it in a little bit.

1 Like