Displayport expansion card stops working after a while on left bottom port

I previously had my DisplayPort expansion card plugged into the bottom left expansion port, and it worked fine except that after an hour or so or after going to s2idle sleep, it wouldn’t come back on. Nothing would restore it, unplugging the cable or the expansion card. Only fix was to shut down the laptop and start it back up.

Snippet from dmesg:

[ 3997.015745] usb usb2-port3: Cannot enable. Maybe the USB cable is bad?
[ 4001.087740] usb usb2-port3: Cannot enable. Maybe the USB cable is bad?

Today it happened again, but I tried moving the expansion card with DisplayPort cable attached to a bay on the right side of the laptop, and it started working again.

The expansion card that I swapped in for the original DisplayPort location was a USB-C card which is working with power and data.

Has anyone else noticed this behavior?

I’m running Arch Linux with kernel 5.14.8-zen1-1-zen with the DIY i7-1165G7 edition.

I’ve had issues with the DP card too (running Windows). I found that sometimes when plugging a cable into the port (or after it has been plugged in for a while), the card would stop working. For me, the solution has been to unplug the cable and wait for a few seconds/minutes, and the card will “reconnect”. Then, if I slide the DP cable into the port really slowly and carefully, it will connect the monitor successfully.