Display Port Adapter Issues

Hi All,

I have a Framework Laptop 13 AMD version. I recently purchased a DP expansion card. My issue is that whenever I have the DP cable connected when I power up the laptop, the monitor is never detected. It will work fine when I remove and re-insert the cable, just never when I boot the machine.

I also have a HDMI expansion port that does not have the same issue, so there is definitely something strange with the DP card.

Does anyone have any ideas or solutions?


What BIOS, drivers, and DP expansion card version do you have?

Just to add, I can now confirm that the HDMI port doesn’t seem to start from boot. It turns out, the issue always occurs on the front port on the right side of the Framework (Labelled port 4 in the diagram).

The BIOS version is 3.05 and I am running the most up to date Linux kernel, which includes all drivers. All my expansion cards are basically brand new and are labelled 2nd generation.

The issue can be replicated by connecting a DP card (or HDMI) into the front right port (Port 4) of the Framework 13 (AMD) whilst it is completely powered off. When powered on, the display will not work unless it is removed and reconnected.
Can someone please try to replicate the issue on their device under these conditions and let me know if they are experiencing the same issue?

Thanks heaps

The front left port does not support DP , any of the other 3 ports should be used for either the DP or HDMI cards.

However the behaviour you experience I can replicate with 7840U on 3.0.3 bios version and any of the ports including USBC / PD at seemingly random intervals of warm boot/reboot. I am convinced there is some sort of PD controller bug / race condition especially with the front left port I often get no enumeration/indication that something has been plugged in.

For your specific issue for display out. Change to one of the other ports tho.

Ahhh sorry. I made a mistake in my last post. I meant to say front RIGHT port, not front LEFT.

I have made an edit to that post now. Can I confirm DP behavior on cold boot in front right?


Has anyone out there been able to have any luck duplicating this issue? I am at my wits end trying to figure this out.

oh, it definitively happens to me too, but lucky me, if I keep the laptop with everything connected (DP, charger, mouse…) screen works between boots, so not a major issue for me, but when I turn the laptop off and disconnect everything (when cleaning), when I plug everything up (laptop off still), and boot it, it happens, I have to unplug the DP and plug it again, it is not enough to reboot or turn off and on the display

That sounds like the same issue. And this is in port 4 (front right side), correct?

front left for me, i haven’t tried front right. AMD version, btw

Ahh right. Framework openly admits that front left doesn’t support display output on AMD (see image below). I am having these issues with front right. It just never works on cold boot. I can restart or unplug and replug in the cable and it’ll work just fine, but if I plug in and boot, it won’t come on automatically. Tested and confirmed across multiple OS’s only in that port.

I’m really hoping someone can test this for me. And verify the same.

ah, what I meant by front are ports 1 and 3, sorry for the confusion. I’m aware of every port’s capability

Okay, so port 1 is what is giving you grief?
Your issues that you are describing are the same for me but in port 4.

yeah, for me it’s port 1, but i’m pretty sure it has nothing to do with the motherboard or the ports, but with the adapter itself

I thought the same thing too until I tried with my HDMI expansion card and confirmed the same behavior. It seems to be the one port on the board causing the problem. I also confirmed the expansion cards (HDMI or DP) don’t have the same issue in ports 1 or 3.