Does anyone have an issue-free FL13 AMD setup? What are your happy path use cases?

If anyone can share their issue-free experience with the FL13 AMD variant, it’ll be much appreciated. Want to see how ready it is, and what it can do as a daily driver without glitches. Details about your SSD and RAM, and how it’s serving you on a daily basis would be great. Thanks!

1 Like

I don’t know if there is any configuration without issues, as bugs always exist.
My configuration is OpenSUSE tumbleweed, with almost no issues. I’ve had an issue that sometimes my battery would drain about 50-60% per night, but that may be fixed. Other than some specific software bugs with running windows games on Linux, no issues at all.
I’m using 32 GB 4800 RAM and a 1TB Samsung 980 SSD.

1 Like

Mine is as issue-free or better than my MacBook Pro or ThinkPad P14s is. Please note I am running a Framework unsupported OS (Although I did run Windows 10 and Fedora 39 Beta fine on it too).

  • Ryzen 7
  • 32GB RAM (2x16GB Framework)
  • 2TB Solidigm P44 Pro SSD
  • Running NixOS unstable with kernelPackages.latest

Random notes

  • After BIOS 3.03 update, no more white flashes when playing full-screen video.
  • I’m getting 4 to 8 hours on battery depending on workload and screen brightness (Battery charge limit set to 90%)
  • Usually have 2x USB-C and 2x USB-A expansion cards in with the occasional 2.5 GBE card being used.
  • Only using power-profile-daemon slider in KDE to control performance
  • Suspend to ram works fine, around 1% per hour battery on sleep (I don’t know the exact sleep mode or whatever the computer is going into)
  • Play Forza Horizons 5 and Cities Skylines well with Steam/proton experimental although the fans make a good appearance when running Forza
  • Fingerprint reader works fine although I have stopped using it (when docked sometimes the computer is out of reach, I’m fine entering my password).
  • I wish the side LED’s would pulse/breath when in suspend and the lid is closed.
1 Like

Yes, that’s why I have the wording of “Happy path”. Bugs always exist (those you know, and those you have yet to know). Bugs may not create an issue if you don’t hit them (happy path). Issues exist when you hit a bug in your use case / path.

Regarding the battery drain, have you updated your BIOS to 3.03?

I’ve had a pretty smooth ride with mine so far. I think I have a relatively light use case though. I’m mostly streaming video in-browser (Vivaldi), email (Betterbird), or RDP/SSH’ing into remote systems. I almost never shut the thing down, I make extensive use of suspend. I don’t use external monitors or have any sort of docking setup.

  • Elementary OS 7.1 with latest OEM kernel on 3.0.3 BIOS
  • Ryzen 5
  • 16 GB RAM (x2 Framework supplied 8GB DIMMs)
  • 512 GB Solidigm P44 Pro
  • Monoprice 100w USB-C PD charger, Anker 45 USB-C PD charger

While I haven’t had any crashes since the 3.0.3 BIOS update, I will say my battery life is not good. I’ll get around 6 hours if I’m just web browsing/email/remote. I’m sure if I go rooting around in the OS i can get better performance, but I’m also sure I’d break it at some point. I’m hoping this improves as support for the new chip gets better. I’ve heard people get better on Windows out of the box.

1 Like

I have an absolutely bug free experience with my newly acquired FW AMD batch 3 laptop. I only had a week or so with it but so far no concerns at all. The laptop is set up with digital forensics and pen testing software in mind. Windows 11 to run software I must have and VMWare for Linux distributions. The SSD is 2TB Nextorage; 2x16 Crucial 5600 RAM. Works great with Acer brand dock and Tesmart KVM I had for a few years. No issues at all with the cards I have: USB-C, USB-A, HDMI, or Ethernet. I used 250Gb card to create Kali bootable drive and successfully booted and used Kali. I am very happy with Framework.

1 Like

Can you provide the model names / numbers for reference?

Of course. Acer Dock 2 U301 and Tesmart model HKS0401A2U.

1 Like

I would say like 95% issue-free here in Windows 11. I’m getting occasional GPU driver reboots mostly during web browsing / Youtube viewing (signified by a quick flash of a black screen). This has been less frequent since the 11/2 AMD GPU driver update, but still occurs. Twice in the time I’ve had it (Batch 2, about a week and a half now), this has locked up the device entirely, needing to turn it off through a press and hold of the power button.

I have used it for light productivity (Word, Excel, etc.), light gaming with a 4k external display connected via a Dell TB4 dock (non-AAA games not at native resolution - I’ve tried Cemu emulation, Metal Hellsinger, Tony Hawk 1+2, and Ghost Trick), I’ve used it for slicing 3D models for printing, and for web browsing and media consumption. It’s handled everything I’ve thrown at it, with the exception of the seemingly random driver instability.

…Ironic that I’m getting GPU crashes though, since the exact same problem was one of my top frustrations with the Surface Pro X I’m replacing. :man_facepalming:

Hardware: 7840U with 64GB G.Skill DDR5-5600, 2TB Hynix P41.

1 Like

I am almost 100% issue free on Windows 11. No BSODs or crashes or anything for me. I was hoping to switch to Linux full time with this machine, but personally I would not quite yet. Things mostly work on Fedora / Ubuntu that I’ve tested, but the battery life is like half of what it is on Windows right now. Plus tricky getting hardware video acceleration, suspend then hibernate, etc. working properly. Lots of manual tweaks needed to wrangle power consumption, and unclear what the best practices are. So potentially workable on Linux if you don’t care as much about power / heat.

Edit: RAM is 2x16 GB DDR5 5600 I bought from Framework, SSD is 2 TB Solidgm P44 Pro, Wifi module is Intel AX210 (Swapped from stock)

1 Like

Yes, as soon as it was possible because I only had to look at my GPU to have it crash before. After the update, no issues.

With the (very) recent battery fix, I lost about 10% over 6h instead of 50-60%, so definitely an improvement. Not perfect though, I’ll probably have to investigate further as that still sounds like quite a bit.

So it seems like Windows 11 is currently the more ready choice (relatively speaking) if you want to avoid / minimize any kind of power related issue (sleep / resume / battery drain) or graphical hiccups. And that Linux has yet to reach similar level of stability (and really distro dependent as one would expect).

Well, Windows is no possible choice for me. Did you ever try to compile free software on Windows? Much more hassle than fixing battery issues on Linux.

Depends on the toolchain dependencies I guess.

I’m thinking / hoping that whatever issue is there to be addressed can be fixed via software / firmware in the coming months before Q2 next year.

Tomorrow will be an interesting day. Fedora 39 release, and Apple m3 release. Looking forward to hear how well the F39 release can run on FL13 AMD.

I used the FC39 Nightly compose from a week ago my fixups:

  • Required Basic graphics mode selected to install
  • required edit to /etc/default/grub.conf to remove ‘nomodeset’ after install and regen of grub ( sudo grub2-mkconfig -o “$(readlink -e /etc/grub2.conf)” )
  • Enable hibernation in fedora (howto here - use a btrfs subvol file) Fedora 35 hibernation with swapfile, only for hibernation and resume · GitHub
  • Use powertop and setup as a service for some non-optimal tuneables to achieve sub 5W draw (pro-tip use firefox, chromium consumes 2-3W more browsing)
  • Tuned the vaapi about:config in firefox to true for reduced consumption during media playback
  • Using KDE Plasma and power-profiles-daemon (default in Fedora, i.e no TLP)
  • Ran FW updates from Discover (KDE Software manager) - updated USB-C PD’s and BIOS no issue
  • Disabled Secure boot (reboot to advanced bios menu with systemctl reboot --firmware-setup)
  • Enabled ‘Gaming UMA’ - which is just sets the VRAM UMA reserved to 4GB vs the default 512MB (if you have 32GB or more - you should set this).

basically issue-free here.

Batch 2, been daily driving my Framework for a few weeks now.

  • BIOS update to 3.03 went smoothly. The fingerprint reader was a bit finnicky to get setup at first and update its firmware, but it took me like 10 minutes of troubleshooting, tops.

  • started off with the Fedora 39 beta, no issues there.

  • KDE Plasma & Wayland, no issues there.

  • My battery life on PPD was quite frankly, awful, netting around 5-6 hours of office work. I switched to TLP and I’m getting closer to 9 hours, which I’m pretty happy with.

32GB Crucial DDR5 5600mts, 1TB Solidigm P44 Pro.

Mostly issue free on my arch linux install. Had to update my BIOS and the fingerprint sensor firmware, after that it worked just fine. Using Plasma on Wayland.

The issues I have:

  • vaapi on Chrome/Vivaldi is broken (there is a mesa patch that is supposed to fix it, but it only partially worked for me)
  • random kernel panic if a screen was connected last boot, but is disconnected before next boot (this happened three times the first week I had it, but not again so far, so might be fixed)
  • there is a random amdgpu driver freeze specifically when playing Horizon Zero Dawn, other games have been fine so far. Hadn’t had the time to debug or collect logs yet.

For such a new platform, I’m quite happy with how stable it is. My old 2400G based laptop never really got over the various issues it had and took several kernel versions to not randomly freeze doing basic file management/office stuff so…

My setup:

  • 7840U DIY
  • The Crucial 32GB 5600MHz CL46 kit ( CT2K16G56C46S5)
  • SK Hynix P31 1TB
  • Intel AX210
  • BIOS 3.03 with fingerprint reader firmware update installed
  • Gentoo with sys-kernel/vanilla-kernel 6.6.2 and GNOME 44

I haven’t encountered any major issues yet, so I’d call my experience so far issue-free.

7840U, DIY Version
SKHynix P31, 2TB SSD
2x16GB RAM modules, from Framework
Fedora 39, GNOME
BIOS 3.03

I’ve had no issues. I just installed Fedora and started using the machine. Granted, I have a fairly simple use case. I browse the internet, edit some pictures, use LibreOffice, transfer files from my cameras to my NAS, stuff like that. I plan to install Steam at some point, just to try some simple games in Linux, but I haven’t done it yet. I’ve had no issues with sleep or anything, but I’m just running the standard settings, no custom configs or custom battery life tuning. When I push the power button or shut the lid or just let it sit long enough, it goes to sleep. It looses about 1% an hour or a bit less while sleeping. When I press the power button it wakes up almost instantly without issue.

I use three different chargers in different locations. A Belkin 60 watt charger; A Lenovo USB C charger, I think 65 watt; and the Framework charger. All work fine.

One quirk is that Fedora seems to default to the oldest installed Kernel, instead of the newest. I manually switched the default Kernel to the newest installed Kernel (Currently 6.6.2), just because. No issues before or after doing that, but I figured I might as well run the newest, since it’s there.

Upgraded my 11th gen to AMD last weekend. Reinstalled Manjaro/GNOME and pretty much everything just worked. I did need to downgrade the firmware in the fingerprint reader.

I set up suspend-then-hibernate, which works fine, though not when I close the lid. (Haven’t had time to troubleshoot). Almost no battery loss when hibernating.

Overall, the laptop is a lot snappier, even on Powersave mode.

1 Like