DVI Adapter Cables not working

I just got my new Framework 16 working fine but has one big issue:
If I use DVI to HDMI or DP Adapter cables, the display wont work properly.
HDMI is sometimes working, but it`s very unstable and disconnects all the time. DP is not working at all.
But: If I use DP to DP oder HDMI to HDMI cables it works.

I am using port 1 and 2 but tried 4 as well. The others did not work as described in the manual.
The expansion cards are showing up in lsusb.
The adapter cables are working on my old Laptop. So it`s not the cable I guess.
I tried Arch and Ubuntu with no difference and do not expect a difference on Windows.

Due to I am holding lectures in different locations I need a reliable solution for this.
Does anyone have an idea what`s causing these issues and how I can solve it?

Not working with the DP to DVI cables is to be expected as those often use passive adapters, which are not supported with Framework’s DisplayPort Expansion Card (and would likely increase cost, complexity, and power draw to support).

Passive adapters work by adapting only the physical connector (not the signal) and requesting that the computer outputs a different signal (ex. Requesting the computer to output a HDMI/DVI signal over a DisplayPort port).

Active adapters have a chip internally that translates between different display signals.

Theoretically any HDMI to DVI adapter should work, but then you’ve got it being adapted multiple times which can sometimes cause odd behaviors. Have you tried multiple HDMI to DVI cables or is it just one that’s being problematic?

I’d suggest getting either an active DP to DVI adapter (sometimes products don’t make it very clear, if the description says anything about requiring DP++ or dual more DisplayPort then it is a passive adapter) or getting a USB-C to DVI adapter (those are guaranteed to be active).