Unable to use Displayport -> HDMI adapter on Framework 16

Heya. I’m unable to use a DisplayPort → HDMI converter in order to use my Wacom Cintiq 16 with my new Framework 16. When plugged in, the cable shows up to the kernel and is logged by dmesg:

[ 6140.722373] usb 1-2.2: new full-speed USB device number 34 using xhci_hcd
[ 6140.858411] usb 1-2.2: New USB device found, idVendor=32ac, idProduct=0003, bcdDevice= 0.00
[ 6140.858419] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6140.858421] usb 1-2.2: Product: DisplayPort Expansion Card
[ 6140.858423] usb 1-2.2: Manufacturer: Framework
[ 6140.858424] usb 1-2.2: SerialNumber: [redacted]
[ 6140.916791] hid-generic 0003:32AC:0003.0030: hiddev96,hidraw1: USB HID v1.11 Device [Framework DisplayPort Expansion Card] on usb-0000:c4:00.3-2.2/input1

I’ve tried both my Wacom Cintiq 16 and my Sceptre monitor as outputs, and they both report “no signal” from the cable. I’ve also gone out and bought two separate DP → HDMI cables from two different stores, and they both yield the same result. Testing the tablet on another device works. Testing the adapters on another device works. I’m only having these issues with the Framework 16.

I have the HDMI expansion card ordered and on the way, but I wanted a temporary solution in the interim. Based on this video, it appears that the HDMI expansion card is also using the USB-C alt mode for DisplayPort and then converting that to HDMI via a dedicated chip. I’m worried that I’ll continue having this issue with the HDMI expansion card, since the adapters don’t seem to be working.

Upon further research, it seems that the Framework 16 is using USB-C alt mode for DisplayPort. USB-C alt mode for DisplayPort doesn’t implement DisplayPort+, which is required to use passive adapters from DisplayPort to HDMI. What I need is an active DisplayPort to HDMI converter, which is what is in the HDMI expansion card.

Really frustrating, but there’s nothing I can do about it.

Hmm, now I wish I’d ordered an HDMI expansion card, or not bothered with the Display Port and just stuck with USB C and USB to DP and HDMI cables.

In my case it’s really annoying because I need to plug in an HDMI cable. The Wacom Cintiq only has HDMI input, because the power, display, and data cables are all combined into a single big cable that then splits off.

Many DisplayPort ports support outputting either DisplayPort signals or HDMI signals depending on what device is connected. This allows for super cheap adapters that do little more than connect the HDMI wires to the DisplayPort wires.

However when using DisplayPort over USB-C (what the DisplayPort expansion card uses) or just a DisplayPort port that doesn’t support that then those adapters can’t work.

Instead you need an active adapter, which is an adapter that has a chip to translate DisplayPort signals into HDMI. The HDMI Expansion Card is an active adapter.

1 Like

I seem to be having difficulties getting the simple display port adapter to work consistently :
Update: It may be a bad cable.

I too have a similar, non-Wacom, device that is HDMI. Whilst I had little intention of using it with a Framework, it is annoying that I couldn’t without the right expansion modules.


To help others, it might be helpful to list the make/model of DP->HDMI adaptors that do not work and also ones that do work with the FW16 Display port.
Hopefully from that, we will be able to work out that, for the non-working ones, it is just the difference between DP and DP+, with the FW16 DP not supporting DP+.
Does anyone know what display port version the FW16 DP expansion card supports. The FW web pages do not go into details.

Just look up a list of passive/active adapters, that should apply directly.

HDMI sucks and I’ll try to avoid it as much as possible in the future, though it’ll be hard in my home theater. When I upgrade my projector/receiver in 5-10 years I’ll make sure to search for DP alternatives. It’s really annoying that they denied AMDs open source 2.1 implementation. Thanks to that I need to spend 40€ for a DP to HDMI converter that will need some compression, as the RX 6800XT only supports DP 1.4 :​/


I have asked framework support for some clarifications, and they kindly responded. If you read it and also follow all the URL links, I find one can get answers to most DP / DP+ / HDMI questions in relation to the FW16 and expansion cards. The information is scattered between multiple different URLs, but its enough to clarify any confusion resulting from the differences between DP and DP+ (Note: FW16 has DP, not DP+)
Previously my assumption had been that “get DP, and you can get cheap adaptors for any other output HDMI, DVI, VGA”, because DP has power output to power any adaptors whereas HDMI does not have power out, so its expensive to turn HDMI to DP.
But my assumption was not correct, it should have read “DP+” and not just “DP”.
The conclusion I have come to with the FW16 is:

  1. If you need DP, use the DP expansion card.
  2. If you need HDMI or DVI-D use the HDMI expansion card.
  3. I have not enquired about DVI-A, DVI-I or VGA output.

otherwise, quite expensive active converters are needed.
I am quite impressed as to how many DP / HDMI expansion cards you can plug into a FW16 and them all actually work at the same time. I don’t think any laptop on the market today can do that many displays attached to a laptop without external docks etc. See details in the URL links from the quote below.

The response from FW support is below:
Hi there,

Thank you for reaching out to Framework Support. We are here to assist you with your inquiry.

Please refer to the links below for the answers to your inquiry:

DisplayPort Expansion card
DisplayPort (1st Gen) Expansion Card - Supports DisplayPort 1.4 for monitors up to 8k 60Hz resolution Supports up to 4 monitors at 4k 60Hz resolution (using 4 cards) 50% post-consumer-recycled aluminum 30% post-consumer-recycled plastic
DisplayPort (2nd Gen) Expansion Card - The DisplayPort (2nd Gen) Expansion Card has optimized firmware to reduce system power consumption, improving laptop battery life. Passes through DP Alt Mode directly from the Mainboard, enabling support for the maximum DisplayPort version and monitor resolution supported by the processor.
External monitor support on the Framework Laptop

The Framework Laptop 16 has 6 slots for Expansion Cards, and it is fully compatible with all Framework Expansion Cards available for the Framework Laptop 13. However, the functionality of each slot varies. Please refer to the image below

Expansion Card Slot functionality on Framework Laptop 16

We hope this information helps. Should there be anything else, do not hesitate to contact us. We are always here to assist.

Thank you for contacting Framework Support and have a good day ahead!​
Framework Support

1 Like

3, Anything analogue, you’d need to convert from USB-C DP Alt Mode or the DisplayPort Expansion card.

The Lenovo USB-C to VGA adapter I carry around in my work bag works fine. Given DVI-A (and the analogue part of DVI-I) is the same VGA signal in a different connector the same would apply.

That said, I’ve not seen a monitor DVI-A connector in well over 10 years, and that was a CRT!

I’ve received the HDMI expansion card today. It does not function under linux with the framework 16 whatsoever. I’m running Fedora Silverblue, fully up to date.

dmesg shows the following when I plug in the expansion card with a cable connected to it:

[  253.055791] usb 1-2.1: new full-speed USB device number 11 using xhci_hcd
[  253.190519] usb 1-2.1: New USB device found, idVendor=32ac, idProduct=0002, bcdDevice= 0.00
[  253.190527] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  253.190528] usb 1-2.1: Product: HDMI Expansion Card
[  253.190530] usb 1-2.1: Manufacturer: Framework
[  253.190532] usb 1-2.1: SerialNumber: [redacted]
[  253.253724] hid-generic 0003:32AC:0002.000E: hiddev96,hidraw2: USB HID v1.11 Device [Framework HDMI Expansion Card] on usb-0000:c4:00.3-2.1/input1
[  259.660837] ucsi_acpi USBC000:00: ucsi_handle_connector_change: ACK failed (-110)
[  259.768244] ucsi_acpi USBC000:00: unknown error 256
[  259.768249] ucsi_acpi USBC000:00: con2: failed to register partner alt modes (-5)
[  265.293022] ucsi_acpi USBC000:00: ucsi_handle_connector_change: ACK failed (-110)
[  265.463450] ucsi_acpi USBC000:00: unknown error 256
[  265.463458] ucsi_acpi USBC000:00: con2: failed to register partner alt modes (-5)
[  270.924893] ucsi_acpi USBC000:00: ucsi_handle_connector_change: ACK failed (-110)
[  271.092543] ucsi_acpi USBC000:00: unknown error 256
[  271.092552] ucsi_acpi USBC000:00: con2: failed to register partner alt modes (-5)
[  276.556904] ucsi_acpi USBC000:00: ucsi_handle_connector_change: ACK failed (-110)

Furthermore, I’ve tested it with every port that is listed as being capable of display output, according to the diagram you’ve linked. None of them work, all showing the same errors in dmesg.

Additional update: after monkeying with it some more, it has inexplicably begun to work flawlessly. I have no clue as to why it didn’t work in the first place, but it’s working now. Maybe there was something on the pins of the card? Your guess is as good as mine

Can you give more details on the monkeying around? I have noticed the same failed to register partner alt modes error in my new Framework 16 running Arch. I have the DP expansion card installed but no cable connected to it.

Hey! Thanks for the research! I encountered the same issue with DP-to-HDMI cables and it would have been great if Framework made that limitation more visible when configuring the laptop.

Good to know. I considered a display port card, but don’t have anything currently that uses it. So I got 2 HDMI cards instead.