Electron apps are blank / empty on startup [SOLVABLE]

Lot of apps like Install Beaker - Beaker Browser (and vscodium as sudo user) start blank… empty squares, nothing more
I have to use it
I also find this problem on the “Min Browser” app and “vscodium”…

  • Half solution (but working) :
    On some applications I can do a --disable-gpu to bypass the gpu and the app run (display the content)

I have last node/npm version

  • Permanente solution ?
    Last week all was working (on an other Manjaro installation)
    (so I have hope)

Please Help :wink:

1 Like

I’ve had problems with chromium and Chrome on Linux. The fix is to pass --disable-gpu-compositing to the commandline. For chromium, in Debian, that can be done by adding a line like:

export CHROMIUM_FLAGS="$CHROMIUM_FLAGS --disable-gpu-compositing"

in (say) /etc/chromium.d/disable-compositing. For electron-based apps, there isn’t (AFAIK) such a magic file, so you have to figure out a way to pass it at all incantations.

1 Like

I’m experiencing the same issues.

I’ve had this problem running Ubuntu (Xubuntu minimum install) 22.04 on my 12th gen i7 Framework and my older Dell Precision 5540 running Ubuntu 20.04.

I see visual glitches - black squares, displaced visual artifacts, etc - in a variety of applications, including but not limited to:

  • Slack
  • Chromium
  • VS Code
  • Bitwarden
  • Balena Etcher

In all cases, I can start the application with the --disable-gpu flag and it runs without issue. However, this is a band-aid, not a fix. There is something going on with graphics acceleration in Electron or browser-based applications. Maybe this relates to Intel graphics support?

I have not yet tried reproducing the issue in other distributions.

I wonder if anyone else has experienced this issue, or if Framework devs encountered it while working on Linux support.


Have you tried with --disable-gpu-compositing only? I suspect the problem is only with the compositor, and only with some of them, because I have anecdotal reports of people not having the problem under Wayland.

Interesting, I had this issue too, so the --disable-gpu-compositing or --disable-gpu flags helped me. However, all Electron apps tended to heat up the laptop and cause a battery drain.

am “happy” to not be alone :wink:
So, I format my computer HDD… reset all on the night…
All is fine if I dont do updates…

And, yes, we can use flags but it is not a solution
I need my GPU work on it…

GPU process isn't usable. Goodbye.

--disable-gpu-compositing no working (same issue)

Install other drivers ?
I try, not sure I do it well (intel driver using manjaro parameters)

Switching my driver from intel to modesetting seems to have fixed it.

Conflicting electrons versions?
npm install -g electron-prebuilt

Lot of issues arround the Internets, Manjaro/linux and Electrons

vscode works with --disable-gpu
Like others Electron Apps… I have an output error
libva error: /usr/lib/dri/i965_drv_video.so init failed
I will find out who it is :wink:
EDIT : libva error: i965_drv_video.so init failed · Issue #375 · intel/libva · GitHub
EDIT : I also do sudo npm install -g electron-prebuilt
PS: And now I can lanch Electron with --disable-gpu [SOLVED]

I find out modifing screen resolution dont help
(vscode dont lanch proply, empty/blank UI)

Not sure if you resolved your issue. But please be sure you don’t have xf86-video-intel installed.

1 Like

Removed/Uninstalled (+reboot) not fix in my case (and reinstall)

Not sure if you resolved your issue. But please be sure you don’t have xf86-video-intel installed.

I am running in an Endeavour OS / xfce4 configuration. Uninstalling the xf86-video-intel package worked in my case. The Arch Wiki elaborates on why using this package is not recommended.