External Hard Drive Automatically Powers off Issue

  • Windows 10 Version 10.0.19045
  • Framework laptop (11th Gen)

External Hard Drive: Seagate expansion portable drive 1TEAP6-500 2TB

While using Linux, I had no issues with my external hard drive remaining connected. However, on Windows, it’s a different story. If I don’t actively use the drive, it will power off. When I navigate the directory again, the drive will spin up and function normally. The problem is that I use Veracrypt with the drive, so if I leave it alone for a few minutes, I have to re-enter the password every time. No matter what power profile i use, the issue persists.

any help would be welcomed. Thank you.

1 Like

How exactly do you connect your drive to your FW? Does it go in a USB-A card or in a USB-C card?


I connect it via USB-A, but i have a usb-c adapter that ive tried. Still the same issue.

I assume it is a USB 3 connection? You might wanna keep an eye on these discussions, as the issue you are describing is kind of similar. Also it is concerning that this only happens under windows, as we had ruled out that to be the problem with our particular issue:

1 Like

Another thing to try is to go to the Windows Device Manager, expand Universal Serial Bus Controllers, then right-click each one, select properties, power management, and uncheck “Allow the computer to turn off this device to save power”.

Additionally you could try disabling USB Selective Suspend in your advanced power settings. This can be somewhat convoluted because the option is often hidden in the first place, but these links helped me figure it out.


Please note that neither of these options has helped me with USB disks surprise disconnecting, but maybe they fit more with your problem. The selective suspend power option did fix my bluetooth mouse stuttering problem.

In my note to myself, it looks like I used the registry method to get the selective suspend option to appear:

Run RegEdit.
Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\2a737441-1930-4402-8d77-b2bebba308a3\48e6b7a6-50f5-4782-a5d4-53bb8f07e226

On the right hand pane right click on empty space and click on New and select DWORD (32-bit) Value

Rename the DWORD Value to Attributes

Double-click on the file and change the Value Data to 2

Restart the PC

1 Like

I noticed another setting in the registry that actually works for me in terms of keeping my USB drive awake. It’s


Make the Attributes value equal to 2 in that key, then set the “Turn off hard disk after” setting in advanced power options to some big number. I tested it at 10 minutes and, sure enough, my external USB drive stayed on for 10 minutes whereas it was going to sleep after 1 minute before.