[Fedora 38 thread] Fedora 38 on the Framework Laptop

Fedora Workstation 38 is available April 18th. The announcement is here . I created this thread to be used for the Fedora 38 main thread. You can download Fedora Workstation 38 here. (Edited magazine link to reflect actual release)

Installation Guide: Fedora 38 Installation on the Framework Laptop 13 - Framework Guides

As with any brand new release, we recommend holding off for a few weeks so their team can iron out the bugs.

See also


Already on it and it is running very smoothly. Only a couple of extension not working, but I expect those to be updated by Tuesday. Dash to Dock, Impatience, Just Perfection, and Vitals are already updated. Upgrade was pretty flawless.


Same. Been testing it for sometime now. Reviews in the forums (including your input here) have been positive. Looks like some real TLC and love went into this release.

1 Like

I’ve had problems but none that I can directly attribute to the OS although I’m on Kinoite and not regular Fedora Workstation. Speaking of which, has anyone got an idea of how to eject a Thunderbolt device like a USB drive? Hotplugging doesn’t really want to work for me. Back to Fedora 38, I like it.

Which particular device? Usually, rmmodding the kernel drivers used by the device helps a lot. I have experience unmounting NVIDIA eGPUs by rmmodding all nvidia* drivers prior to unplugging the cable (but does not work if the eGPU is used by Xorg as a provider.)

With amdgpu you don’t even need to rrmod the whole driver, you can just unbind the gpu. this is going to be pretty important on the amd version cause the igpu also uses amdgpu.

1 Like

Yeah amdgpu’s hotplug/unplug support is pretty advanced.
I wish it was the same for Nvidia… oh well…

Hotplug/unplug kind of works (with Nvidia) for compute only (CUDA), but alas not for Xorg: a complete restart of the X server is required for that.

Confirmation that Nvidia hotplug support (on Linux) is inexistent:

There seems to have been a solo attempt, a very long time ago, to patch Nvidia drivers to allow hotplugging, but I didn’t manage to get a reply from the author of the blog:

Honestly have not even tried nvidia on linux for anything more advanced than display output since the pain-train it was when I messed with it a couple years ago.

Then again the amd driver sucked too not too long ago.

I found Fedora Sway Spin 38! It seems the spin is new in Fedora 38! (the proposal) Great work!


Moderators, shall we change this thread’s first comment to the wiki?

By the way, below is the release summary of Fedora 38.

Fedora Magazine about Fedora 38: Announcing Fedora Linux 38 - Fedora Magazine

1 Like

Since upgrading to f38 my external screens (USB-C dock) freeze from time to time. Also a after waking up from sleep the screen do not get any signal. Re-plugging the dock does not help and I have to restart the machine.

I noticed errors in the log:

Apr 20 13:26:48 **** kernel: usb 3-3.1: device descriptor read/64, error -32
Apr 20 13:26:48 **** kernel: usb 3-3.1: device descriptor read/64, error -32
Apr 20 13:26:48 **** kernel: usb 3-3.1: Device not responding to setup address.
Apr 20 13:26:49 **** kernel: usb 3-3.1: Device not responding to setup address.
Apr 20 13:26:49 **** kernel: usb 3-3.1: device not accepting address 57, error -71
Apr 20 13:26:49 **** kernel: usb 3-3.1: Device not responding to setup address.
Apr 20 13:26:49 **** kernel: usb 3-3.1: Device not responding to setup address.
Apr 20 13:26:49 **** kernel: usb 3-3.1: device not accepting address 58, error -71
Apr 20 13:26:49 **** kernel: usb 3-3-port1: unable to enumerate USB device
Apr 20 13:26:52 **** kernel: i915 0000:00:02.0: [drm] *ERROR* Sending link address failed with -5

Anyone got the same issue? I might have to revert to 37 for now…

I have not, however, I connect external displays using our expansion cards as we can support those directly.

On our Fedora 38 guide, we’re recommending clean installations as on any fixed release distro, they tend to avoid issues like this.

Worth trying a Live USB of 38 to see if issue persists there. If it does, it’s likely your dock isn’t ready for 38 just yet and you may want to revert to 37.

If the live usb for 38 works fine, it’s your upgrade and reflects our suggestion for a clean install.

Clean installs are indeed the best. A user also has to reinstall and set up any applications they want to continue using. More fun, remembering what you have.

For me, at least the ability to use an expansion card to install a Linux Distro on makes this more tolerable.

You could have both old and new distros available while you figure out what is missing, then finally reformat the old card for the next fresh install.

My system:
11th Gen, Batch 1, Windows 10 on the internal drive
Ubuntu 22.04 LTS on a 250gb expansion
Fedora 37 on a USB Flash Drive, mostly for experience.

Not heavily into Linux, so not playing with any other distros.

I don’t like having updates break things.


Gentle reminder and perhaps counterpoint about reinstalling: If you’ve enrolled fingerprints, there appears to be some credential material that is saved on the OS side. If you do plan on reinstalling the OS, it’s worth saving those files and maybe also trying to unenroll the fingerprint “slots” from the reader first.


Excellent feedback, this! :slight_smile:

I upgraded to Fedora Silverblue 38 yesterday on my 12th gen i5. One thing I did was install libavcodec-freeworld and intel-media-driver from RPMFusion. Some VAAPI support was removed from the Fedora repos during F37 due to some licence issues IIRC (see Firefox Hardware acceleration - Fedora Project Wiki).

@Matt_Hartley I did test with a clean installation and got the same error. Guess I’ll skip this one for a while.

In place update working great so far on my end. No hiccups with my thunderbolt dock and peripherals.

This is my 2nd major update with Fedora and the framework and it has been the smoothest experience I’ve had updating an OS in awhile.

Upgrade from F37 went fine for me!

Only issue was GDM was not applying correct HIDPI / scale configuration. I copied my monitors.xml to /var/lib/gdm/.config. I’m sure there is a better way to fix that, though.