Fedora KDE Plasma Display Settings

I wanted to share with the community my experience with setting my display configuration in Fedora KDE Plasma 5 (x11). The default settings cause your eyes to squint on this hidpi display so after tweaking some things I got it to where I wanted. I will provide a walk through with screenshots if anyone else wants to try it.

Menu Bar Panel Editing
Begin by right-clicking the menu bar and select Edit Panel. From there you will want to change the panel height (I personally chose 54, it’s all preference).

Next, you’ll need to get to your font settings. Begin by clicking your home/start/??? button. You can find your settings or just search for settings which is what I did. From there you will want to click on Appearance and then Fonts. The setting you are looking to change is Force Font DPI. Once enabled, you can set to your preference (I chose 125 but the system changed it to 144 once all my changes were applied).



Display & Monitor
Lastly, you’ll want to go into your Display & Monitor settings and change your Global Scaling (I chose 150%).

Then you’re done, just restart your system. You can play around with the slider bars in each of these settings until you get the right feel for you. Enjoy!