First power on - blank screen

Just assembled a new AMD 13" Framework laptop. But it has not successfully powered up! There are some clues: a little white light (solid) on the left side between the expansion ports; a quiet fan underneath; lit power button border; screen backlight. But no logo, no messages, no BIOS indications, no beeps. Fn+space does not seem to light up the keyboard.

I have 1 memory card (selected with the Framework laptop order–DDR5-5600 32gb), and there are 2 memory slots, so I moved the memory to the other slot. I also re-seated the storage, which also came from the Framework AMD configuration menu. But the power-on behavior remained the same!

Please advise! What should I do?

Hi @Phill_Wolf,

Congratulations on your new 13" Framework AMD laptop. The first time you power the device on it has to “train the memory” which can take a few minutes. There is some feedback from users about which slot to put the memory in if you only have one stick. If you search the forums something should come up.

You might want to file a ticket with support to get the ball rolling on them guiding you. They can guide you on how to reset the mainboard on the machine if it is stuck and that is what is preventing the machine from the BIOS power on self test (POST).

Some things to try: (In no particular order)

  1. Remove the AC cord of your power adapter count to 10 and plug it back in.
  2. Remove your NVMe drive.
  3. Remove all but the one USBC expansion card.
  4. Hold down the power button for a good 15 seconds; then wait 10 seconds and press the power button once and wait. (Again if this is the first time the machine is successfully booting it has to train the memory)
  5. Try everything listed above all at once… (maybe do this first?)

If the computer successfully goes through the POST it will either pop into the BIOS screen or display a message that a boot device can not be found (I do not remember which one)

If it still is unresponsive, and after you have contacted support (or tried the Mainboard reset procedure; might want to get the go ahead from support first!); your memory module could potentially be bad.

It is not common but does happen. If you had another stick of DDR5 memory to try that would definitely determine the machine is ok but the RAM you ordered may not be.

Sorry I do not have time to link some of the articles and other forum posts right now; I have to get some work done tonight before bed. I wanted to give you some things to try though. The anticipation of getting a new machine working is frustrating when it does not work right out of the box.

Let us know what you find out.

Thanks for the tips! The symptom seemed the same with the storage card removed. But the experiment was quite useful because after I put it back in, and tried again to power up, I noticed some blinking of the side bulb! The blinking began more than 30 seconds after the power-key border illuminated. Is there a decoder for the colored strobes on the 13-inch AMD? Blink 13 was red!

Ta da! Somewhere was a suggestion to consider the cable that connects the display. I caressed that cable at both ends and in the middle. Then I reapplied the bezel. In so doing, I bumped the power button and suddenly the laptop booted up like a laptop!


Great job @Phill_Wolf! I am glad you found the loose connection. Enjoy your new machine!