Framework 13” AMD Cannot get into BIOS only Black screen

HelloAll, just received my Framework 13” DIY, i have added a Crucial DDR5-5600 32GB x 2 and. WD SN850x nvme, after powering up, i only get a blank screen. I have tried everything they recommended but nothing still. Anyone else experience something similar?



1 Like

Hello Vishal,

You are not alone. I also added 64 Gb and a Kingston 4TB drive to my new Framework 13 AMD and am getting a blank screen


Keep in mind RAM training can take a minute or two where you see no screen indicator.

However if it never comes on, you might want to check the keyboard/input tray ribbon connector. Especially the end connected to the keyboard tray. People have had their’s short out. Maybe try an external monitor to see if the system is booting up at all. There have definitely been some apparent QA issues in recent batches.

Hello Josh,

At this point I have waited up to 10 minutes after powering on with a USB-C connected with no output to the laptop screen.

Inspected keyboard/input tray ribbon for tears connector for shorted or open connections and found none.

I did not order a module for monitor output since, so do not have the ability to test an alternate video output.

The fan is running when powered up.

Also tried reducing the RAM to 32Gb with no change in behavior.

Added SDD - Kingston NV2 PCIe 4.0 NVMe M.2
Added RAM - Crucial RAM 64GB Kit (2x32GB) DDR5 5200MT/s

Please advise on additional troubleshooting steps.


1 Like

From looking at a separate post I believe this is a RAM compatibility issue. Same RAM was bought.

Will purchase 5600 speed RAM to see if this resolves the issue


I have experienced the exact same issue. I used Crucial 32 GB kit of DDR5 - 5200 SODIMMM (2x16GB).

It seems memory is the cause. Has anyone else found memory that work?

5200 mhz RAM does not work. You’ll need 5600 mhz RAM.

I dont think its the issue with RAM. I tried Crucial DDR5 32GB x 2 5600Mhz and I get the same result with blank screen. I followed troubleshooting instructions by support and nothing worked.

Have you tried with a single stick of the 5600?

Yes i have tried a single DIMM in each of the slot but nothing changes. I have tried two different brands of RAM( kingston and crucial) and nothing works. Pretty frustrating when you buy a laptop throw in the ram and nvme and doesnt work. Currently after all the test Framework Support had me carried, with photos and videos submitted. They are going to replace my laptop. This really should not happen when its brand new out of the box. I hope the replacement will not have these issues.

You always get some major failures in the early days of a product. Ideally it doesn’t happen, but every product follows the ‘bathtub curve’.

1 Like

I wonder what bios revision your board shipped with and if RAM less bios updates are an option on the AMD framework

1 Like

I’m also in the same spot.
I bought a pack of crucial RAM DDR5-5200 64GB (2x32GB) and get no post, no display, and fan spins. I tried removing 1 stick of RAM, swapped, reseating.
After finding this thread last night, I over nighted a set of g.skill DDR5-5600 64GB (2x32GB) RAM. I received them a couple of hours ago and installed them.
On boot, I got some backlight and after about 1 minute I got post, then booted to OS.

For reference,
BIOS Version: JFP30.03.03

Which one did you purchase? CL-40 or CL-46

Not sure if I’m allowed to add the Amazon link but I can.

G.SKILL Ripjaws DDR5 SO-DIMM Series DDR5 RAM 64GB (2x32GB) 5600MT/s CL46-45-45-89 1.10V Unbuffered Non-ECC Notebook/Laptop Memory SODIMM (F5-5600S4645A32GX2-RS)

Thank you so much for your resppnse, much appreciated. How the laptop running? What OS are you running?

You’re welcome!
It’s running great. I’m pretty happy with it. I was running Manjaro dual booted with Windows 10, then setup Arch, and currently running NixOS. Issues I’ve run into have been:

  • In Manjaro random white screen flickering with starting a game of taking the laptop out of sleep. I have to logout and sometimes reboot to get rid of the flickering. But that’s probably from the OS being originally used on other laptops that had Intel or Nvidia GPUs. So I disregarded that issue and just moved on.
  • In NixOS when I close the laptop and open it back up later, I’ll find that it’s booting up from POST. That might be related to the luks setup and I just need do some more tweaking.