Framework 16 not powering up after a day in suspend

Add me to the “Framework 16 won’t power up” gang. Fully charged the laptop, placed it in suspend mode a day or two ago (Ubuntu Linux). Powered on the laptop, and the power light illuminates. Nothing on the screen, no indicator LED activity. Pressing caps lock/num lock does not illuminate.

Tried plugging into the 180w adapter. Charging light turns white (fully charged). Tried moving the RAM to slot 1, removing/reinserting the battery, ensuring the SSD is seated. No dice.

Any advice? Machine worked perfectly on Friday. It hasn’t been knocked around at all. It’s the AMD Ryzen™ 7040 Series model (Batch 10).

Thanks in advance!

Framework Laptop 16 hardware

Hi @Jeff_Orr,

Something is stuck in the sleep state probably in the Embedded Controller. There is a procedure to hard reset the mainboard on the FW13; I imagine there is a similar procedure on the FW16. Someone had a similar issue and his came back to life when the battery was fully drained and he plugged it back in again.

If you get it working again, I would enable the standalone mode in the BIOS. Then you should be able to force the system to an “OFF” state by unplugging the charger and battery as a last resort. Then connect the 180W charger and leave the battery disconnected. Try powering on the machiine and hopefully the BIOS will POST.

Pay attention to the diagnostic lights too, they may give some insight as to what is not responding correctly. See the support site to decode the diagnostic lights.

At this time I would not trust the suspend function for long periods of time (more than a few hours) especially if you are not using Windows.

Thanks for the reply @pkunk

I tried what i think is the reset procedure. Pulled the battery for 40 seconds, powered up with the battery out, got the red-blue-off sequence for 10 seconds. Powered off, put the battery + midplate + modules back in. Plugged in the 180w adapter, got a solid white light. Turned the laptop on… the LED matrix and power LEDs light, with the PD side light a solid white. Still no boot or display panel activity :frowning:

I am on BIOS version 3.03, in case it is relevant.

Hi @Jeff_Orr,

Try leaving the battery out entirely and put it back together. You don’t have to screw it all together just connect the midplate cable and carefully set the modules in. Maybe it will POST that way. If it doesn’t, unplug it from the power, wait 15 seconds or so then plug it back in and wait a minute before pressing the power button.

I had a FW13 Intel Gen11 board I bought with the CoolerMaster case for a little project and on occasion it wouldn’t respond to the power button so I had to long press it for 30 seconds to turn it off, disconnect the USBC power cable, wait 10 seconds then plug it back in and it would finally respond to the power button but it took its sweet time like almost a minute before it finally posted.

Might have to open a support ticket and see what they say.

Yeah, I’ve already tried a few permutations into what you mentioned as well. No change. Guess it’s ticket time.

Bummer,

I just read this in the FW16 motherboard replacement guide and it said:

  • As we disconnected the battery in BIOS at the beginning of this guide, we can now reconnect it.
  • Start by connecting an a charger to the Framework Laptop 16, it will not power on without one until the battery is reconnected.
  • Press the power button and then repeatedly press the F2 Key to boot into the Framework UEFI BIOS

Oops!

There is a HARD reset the mainboard procedure for the FW13 AMD boards you have to press the chassis intrusion switch ten times (press and hold for 2 seconds, wait for LEDs to flash RED) then it resets EVERYTHING though but that should put it back to when you first took it out of the box. The switch on the FW16 is just below the left memory module.

If you have secureboot enabled though or keys in your TPM they get wiped out though.